summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-09-23 12:04:44 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-09-23 12:04:44 +0000
commitb59a4fe709271be624e1a34d42a2f0558cea9eca (patch)
tree9b8297912089e2f07f3ec4bd3a8b5c5dcf3cceab /sys-process
parentAdded myself as maintainer. (diff)
downloadgentoo-2-b59a4fe709271be624e1a34d42a2f0558cea9eca.tar.gz
gentoo-2-b59a4fe709271be624e1a34d42a2f0558cea9eca.tar.bz2
gentoo-2-b59a4fe709271be624e1a34d42a2f0558cea9eca.zip
Version bump. Fixed warnings in init script (bug #382319)
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/ChangeLog10
-rw-r--r--sys-process/at/at-3.1.13.ebuild72
-rw-r--r--sys-process/at/files/at-3.1.13-Makefile.patch29
-rw-r--r--sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch22
-rwxr-xr-xsys-process/at/files/atd.rc64
5 files changed, 134 insertions, 3 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index 5ddfa8962cfb..854fb945565e 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-process/at
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.26 2011/04/17 22:46:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.27 2011/09/23 12:04:44 polynomial-c Exp $
+
+*at-3.1.13 (23 Sep 2011)
+
+ 23 Sep 2011; Lars Wendler <polynomial-c@gentoo.org> +at-3.1.13.ebuild,
+ +files/at-3.1.13-Makefile.patch,
+ +files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch, files/atd.rc6:
+ non-maintainer commit: Version bump. Fixed warnings in init script (bug
+ #382319).
*at-3.1.10.2-r2 (17 Apr 2011)
diff --git a/sys-process/at/at-3.1.13.ebuild b/sys-process/at/at-3.1.13.ebuild
new file mode 100644
index 000000000000..9bdab77f1267
--- /dev/null
+++ b/sys-process/at/at-3.1.13.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13.ebuild,v 1.1 2011/09/23 12:04:44 polynomial-c Exp $
+
+inherit eutils flag-o-matic autotools pam
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/at_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+DEPEND="virtual/mta
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${P}-configure.in-fix-PAM-automagick-dep.patch
+
+ eautoconf
+}
+
+src_compile() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install IROOT="${D}" || die
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd atd
+ prepalldocs
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/files/at-3.1.13-Makefile.patch b/sys-process/at/files/at-3.1.13-Makefile.patch
new file mode 100644
index 000000000000..d9b1acf7da37
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-Makefile.patch
@@ -0,0 +1,29 @@
+# - install into Gentoo/FHS doc dir
+# - respect Gentoo LDFLAGS
+# - dont allow install to strip binaries
+
+--- at-3.1.13/Makefile.in
++++ at-3.1.13/Makefile.in
+@@ -12,8 +12,11 @@
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+-docdir = $(prefix)/doc
+-atdocdir = $(docdir)/at
++ifndef PF
++PF = at-$(VERSION)
++endif
++docdir = $(prefix)/share/doc
++atdocdir = $(docdir)/$(PF)
+ etcdir = @ETCDIR@
+
+ DAEMON_USERNAME = @DAEMON_USERNAME@
+@@ -35,7 +38,7 @@
+ -DDAEMON_USERNAME=\"$(DAEMON_USERNAME)\" \
+ -DDAEMON_GROUPNAME=\"$(DAEMON_GROUPNAME)\" \
+ -DLFILE=\"$(LFILE)\" -Wall
+-LIBS = @LIBS@
++LIBS = @LIBS@ @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+ INSTALL = @INSTALL@
+ PAMLIB = @PAMLIB@
diff --git a/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
new file mode 100644
index 000000000000..ee24b7f13147
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
@@ -0,0 +1,22 @@
+--- at-3.1.13/configure.ac
++++ at-3.1.13/configure.ac
+@@ -82,10 +82,15 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
+-AC_CHECK_HEADERS(security/pam_appl.h, [
+- PAMLIB="-lpam"
+- AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
+-])
++AC_ARG_WITH([pam], AS_HELP_STRING([--without-pam],
++ [Build without PAM support(default: enabled)]))
++
++if test "x$with_pam" != "xno"; then
++ AC_CHECK_HEADERS(security/pam_appl.h, [
++ PAMLIB="-lpam"
++ AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
++ ])
++fi
+
+ dnl Checking for programs
+
diff --git a/sys-process/at/files/atd.rc6 b/sys-process/at/files/atd.rc6
index d0dc71045556..8c89ad5335e4 100755
--- a/sys-process/at/files/atd.rc6
+++ b/sys-process/at/files/atd.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/files/atd.rc6,v 1.2 2011/04/17 22:46:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/files/atd.rc6,v 1.3 2011/09/23 12:04:44 polynomial-c Exp $
depend() {
need clock logger
@@ -10,7 +10,7 @@ depend() {
start() {
ebegin "Starting atd"
start-stop-daemon --start --quiet --pidfile /var/run/atd.pid \
- --startas /usr/sbin/atd -- ${ATD_OPTS}
+ --exec /usr/sbin/atd -- ${ATD_OPTS}
eend $?
}