summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-05 05:11:23 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-05 05:11:23 +0000
commit86ec6cd1a19c2859312be69a0011f5a0731f3f64 (patch)
treeb69cac51828f47590685f603058c99b8814ca028 /virtual/python-futures
parentdrop py2.6 add pypy support, upgrade test phase (diff)
downloadgentoo-2-86ec6cd1a19c2859312be69a0011f5a0731f3f64.tar.gz
gentoo-2-86ec6cd1a19c2859312be69a0011f5a0731f3f64.tar.bz2
gentoo-2-86ec6cd1a19c2859312be69a0011f5a0731f3f64.zip
drop py2.6 add pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'virtual/python-futures')
-rw-r--r--virtual/python-futures/ChangeLog5
-rw-r--r--virtual/python-futures/python-futures-0.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/virtual/python-futures/ChangeLog b/virtual/python-futures/ChangeLog
index 2534888aeeff..c80fcf0cfdee 100644
--- a/virtual/python-futures/ChangeLog
+++ b/virtual/python-futures/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for virtual/python-futures
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/ChangeLog,v 1.3 2014/04/19 18:02:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/ChangeLog,v 1.4 2014/05/05 05:11:23 idella4 Exp $
+
+ 05 May 2014; Ian Delaney <idella4@gentoo.org> python-futures-0.ebuild:
+ drop py2.6 add pypy support
19 Apr 2014; Michał Górny <mgorny@gentoo.org> python-futures-0.ebuild:
Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
diff --git a/virtual/python-futures/python-futures-0.ebuild b/virtual/python-futures/python-futures-0.ebuild
index c677244262ff..224de255c2cd 100644
--- a/virtual/python-futures/python-futures-0.ebuild
+++ b/virtual/python-futures/python-futures-0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/python-futures-0.ebuild,v 1.3 2014/04/19 18:02:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/python-futures-0.ebuild,v 1.4 2014/05/05 05:11:23 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
inherit python-r1
DESCRIPTION="A virtual for the Python concurrent.futures module"
@@ -16,4 +16,4 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2*')"
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' python2_7 pypy)"