summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-01 09:29:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-01 09:29:04 +0000
commit295846014a451ef1c07cbf71f76efe5cd56654f2 (patch)
treeced7bef2ed592c750d8c8d517ca19697d361af07 /www-apache/anyterm/files
parentadd missing IUSE as per bug #224375 (diff)
downloadgentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.tar.gz
gentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.tar.bz2
gentoo-2-295846014a451ef1c07cbf71f76efe5cd56654f2.zip
fix #214377
(Portage version: 2.1.5.2)
Diffstat (limited to 'www-apache/anyterm/files')
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch b/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
new file mode 100644
index 000000000000..6dae0a41d41a
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
@@ -0,0 +1,64 @@
+--- apachemod/Makefile
++++ apachemod/Makefile
+@@ -85,7 +85,7 @@
+ -DUSE_SHMEM \
+ -I../boost_shmem
+
+-COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall -O0 -g
++COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall
+
+ C_COMPILE_FLAGS=$(COMPILE_FLAGS) -std=gnu99
+
+@@ -108,23 +108,23 @@
+ OBJS=$(addsuffix .lo,$(basename $(C_SRCS) $(CC_SRCS)))
+
+ %.lo: %.cc
+- $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CC_COMPILE_FLAGS) -o $@ -c $<
+
+ %.lo: %.c
+- $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(C_COMPILE_FLAGS) -o $@ -c $<
+
+
+ compile: $(OBJS) $(LIBPBE_LIB)
+- $(APXS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
++ $(APXS) $(LDFLAGS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
+
+ install: FORCE
+ $(APXS) -n anyterm -i anyterm.la
+
+ %.d: %.cc
+- $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ %.d: %.c
+- $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CC) $(CPPFLAGS) $(CFLAGS) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
+
+--- libpbe/build/Makefile
++++ libpbe/build/Makefile
+@@ -53,7 +53,7 @@
+
+ WARN_FLAGS=-W -Wall
+
+-OPTIMISE_FLAGS=-O
++OPTIMISE_FLAGS=
+
+ DEBUG_FLAGS=
+
+@@ -71,10 +71,10 @@
+ $(AR) ruv $(LIBRARY) $(OBJS)
+
+ %.o: %.cc
+- $(CXX) $(COMPILE_FLAGS) -c $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(COMPILE_FLAGS) -c $<
+
+ %.d: %.cc
+- $(CXX) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
+
+ all: $(EXECUTABLE)
+