summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-08-08 10:27:21 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-08-08 10:27:21 +0000
commit1d1ea7153de83dbca9e583fd15a12c5ec2284083 (patch)
tree50109867fc45faca4f3ce854aff9a25acb619daf /www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild
parentVersion bump (diff)
downloadgentoo-2-1d1ea7153de83dbca9e583fd15a12c5ec2284083.tar.gz
gentoo-2-1d1ea7153de83dbca9e583fd15a12c5ec2284083.tar.bz2
gentoo-2-1d1ea7153de83dbca9e583fd15a12c5ec2284083.zip
bug 101292 - note for threaded vs unthreaded apache/perl systems
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild')
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild b/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild
index bdf34746c95d..d58a0b013f85 100644
--- a/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild
+++ b/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild,v 1.1 2005/08/08 09:35:43 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.1-r2.ebuild,v 1.2 2005/08/08 10:27:21 mcummings Exp $
inherit apache-module perl-module eutils
DESCRIPTION="An embedded Perl interpreter for Apache2"
@@ -27,6 +27,19 @@ DOCFILES="Changes INSTALL LICENSE README STATUS"
APACHE2_MOD_DEFINE="PERL"
src_unpack() {
+ INSTALLED_MPM="$(${ROOT}/usr/sbin/apxs2 -q MPM_NAME)"
+ eval `perl '-V:useithreads'`
+ ITHREADS="${useithreads}"
+ if [ "${INSTALLED_MPM}" != "prefork" ]; then
+ if [ "${ITHREADS}" == "undef" ]; then
+ ewarn "You cannot build mod_perl on a threaded apache"
+ ewarn "with an unthreaded perl. You must either emerge"
+ ewarn "perl with ithreads in your USE flags, or emerge"
+ ewarn "apache without threading support"
+ exit
+ fi
+ fi
+
unpack ${A}
cd ${S}