summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:25:29 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:25:29 +0000
commit18f5c82dfaea2701499f60477807570104950b41 (patch)
tree49bb84005c84d33e0bade9f2da3aef1c2e651ce3 /www-apache
parentReplace "echo -n" with "echo", bash removes trailing newline in subshells any... (diff)
downloadgentoo-2-18f5c82dfaea2701499f60477807570104950b41.tar.gz
gentoo-2-18f5c82dfaea2701499f60477807570104950b41.tar.bz2
gentoo-2-18f5c82dfaea2701499f60477807570104950b41.zip
Cleanup
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_perl/ChangeLog7
-rw-r--r--www-apache/mod_perl/files/CVE-2009-0796.patch47
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch78
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.4-r1.ebuild131
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.5.ebuild156
5 files changed, 6 insertions, 413 deletions
diff --git a/www-apache/mod_perl/ChangeLog b/www-apache/mod_perl/ChangeLog
index c6b52ef2a6dc..9d48a72015f6 100644
--- a/www-apache/mod_perl/ChangeLog
+++ b/www-apache/mod_perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_perl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.102 2012/10/10 14:15:02 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.103 2012/10/30 20:25:29 idl0r Exp $
+
+ 30 Oct 2012; Christian Ruppert <idl0r@gentoo.org> -mod_perl-2.0.4-r1.ebuild,
+ -mod_perl-2.0.5.ebuild, -files/mod_perl-2.0.5-bundled-Apache-Test.patch,
+ -files/CVE-2009-0796.patch:
+ Cleanup
10 Oct 2012; Brent Baude <ranger@gentoo.org> mod_perl-2.0.7.ebuild:
Marking mod_perl-2.0.7 ppc for bug 432610
diff --git a/www-apache/mod_perl/files/CVE-2009-0796.patch b/www-apache/mod_perl/files/CVE-2009-0796.patch
deleted file mode 100644
index c13db0de155a..000000000000
--- a/www-apache/mod_perl/files/CVE-2009-0796.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- perl/modperl/trunk/lib/Apache2/Status.pm 2007/12/31 08:05:11 607697
-+++ perl/modperl/trunk/lib/Apache2/Status.pm 2009/04/01 15:39:56 760926
-@@ -29,7 +29,7 @@
-
- use Apache2::Const -compile => qw(OK);
-
--$Apache2::Status::VERSION = '4.00'; # mod_perl 2.0
-+$Apache2::Status::VERSION = '4.01'; # mod_perl 2.0
-
- use constant IS_WIN32 => ($^O eq "MSWin32");
-
-@@ -126,7 +126,7 @@
- $r->print(symdump($r, $qs));
- }
- else {
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- $r->print('<p>');
- $r->print(
- map { qq[<a href="$uri?$_">$status{$_}</a><br />\n] } sort { lc $a cmp lc $b } keys %status
-@@ -198,7 +198,7 @@
- sub status_inc {
- my ($r) = @_;
-
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my @retval = (
- '<table border="1">',
- "<tr>",
-@@ -289,7 +289,7 @@
- my ($r) = @_;
-
- local $_;
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my $cache = __PACKAGE__->registry_cache;
-
- my @retval = "<h2>Compiled registry scripts grouped by their handler</h2>";
-@@ -765,7 +765,7 @@
- my ($self, $package, $r) = @_;
-
- my @m = qw(<table>);
-- my $uri = $r->uri;
-+ my $uri = $r->location;
- my $is_main = $package eq "main";
-
- my $do_dump = has($r, "dumper");
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch b/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
deleted file mode 100644
index 1c7828b48949..000000000000
--- a/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/Makefile.PL b/Makefile.PL
-index ca80816..4196f8e 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -24,7 +24,7 @@ BEGIN {
-
- }
-
--use lib qw(lib Apache-Test/lib);
-+use lib qw(lib);
-
- use Config;
- use File::Spec::Functions;
-@@ -116,16 +116,6 @@ sub get_DEFINE {
- }
-
- sub configure {
--
-- # mod_perl test suite relies on having Apache-Test bundled with
-- # the mod_perl source, since any pre-installed version may not do
-- # the right thing
-- unless (-d "Apache-Test") {
-- error "Can't find a sub-directory Apache-Test. " .
-- "Make sure that you are using a complete source distribution";
-- exit 1;
-- }
--
- set_modperl_version();
-
- if ($old_modperl_version) {
-@@ -794,47 +784,11 @@ run_tests : test_clean
- run_subtests ::
- $(MAKE) -C ModPerl-Registry test
-
--run_subtests ::
-- $(MAKE) -C Apache-Reload test
--
--run_subtests ::
-- $(MAKE) -C Apache-SizeLimit test
--
- test :: pure_all run_tests test_clean
- EOF
-
- }
-
--sub MY::postamble {
-- my $self = shift;
--
-- my $string = $self->ModPerl::BuildMM::MY::postamble;
--
-- $string .= <<'EOF';
--mydist : Apache-Test/META.yml mod_perl.spec manifest tardist
--
--rpm: dist
-- @[ -d $(PWD)/rpm ] || mkdir $(PWD)/rpm
-- rpmbuild -ta --define "_rpmdir $(PWD)/rpm" \
-- --define "_srcrpmdir $(PWD)/rpm" \
-- $(DISTVNAME).tar.gz
-- @mv $(PWD)/rpm/*/*.rpm $(PWD)/rpm/
-- @rm -rf $(PWD)/rpm/*/
--
--mod_perl.spec: build/make_rpm_spec
-- $(PERL) build/make_rpm_spec
--
--Apache-Test/META.yml:
-- cd Apache-Test && make metafile
--
--tag :
-- svn copy https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM) https://svn.apache.org/repos/asf/perl/modperl/tags/$(VERSION_SYM)
-- svn copy https://svn.apache.org/repos/asf/perl/modperl/docs/trunk https://svn.apache.org/repos/asf/perl/modperl/docs/tags/$(VERSION_SYM)
--EOF
--
-- return $string;
--}
--
- # this is a workaround so that ModPerl::MM will move MY::constants
- # away, and Apache-Test/Makefile.PL which has its own MY::constants
- # won't get complaints on MY::constants redefined
diff --git a/www-apache/mod_perl/mod_perl-2.0.4-r1.ebuild b/www-apache/mod_perl/mod_perl-2.0.4-r1.ebuild
deleted file mode 100644
index 0a3827e310a5..000000000000
--- a/www-apache/mod_perl/mod_perl-2.0.4-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.4-r1.ebuild,v 1.16 2012/04/03 20:23:27 idl0r Exp $
-
-EAPI="2"
-
-inherit apache-module perl-module eutils multilib
-
-DESCRIPTION="An embedded Perl interpreter for Apache2"
-SRC_URI="mirror://apache/perl/${P}.tar.gz"
-HOMEPAGE="http://perl.apache.org/"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-SLOT="1"
-
-DEPEND="<www-servers/apache-2.4
- >=dev-perl/Apache-Test-1.27
- >=virtual/perl-CGI-3.08
- >=virtual/perl-IO-Compress-1.09
- dev-lang/perl
- || ( www-servers/apache[-threads] dev-lang/perl[ithreads] )"
-RDEPEND="${DEPEND}"
-PDEPEND="dev-perl/Apache-Reload"
-
-APACHE2_MOD_FILE="${S}/src/modules/perl/mod_perl.so"
-APACHE2_MOD_CONF="2.0.3/75_${PN}"
-APACHE2_MOD_DEFINE="PERL"
-
-DOCFILES="Changes INSTALL LICENSE README STATUS"
-
-need_apache2
-
-src_prepare() {
- # I am not entirely happy with this solution, but here's what's
- # going on here if someone wants to take a stab at another
- # approach. When userpriv compilation is off, then the make
- # process drops to user "nobody" to run the test servers. This
- # server is closed, and then the socket is rebound using
- # SO_REUSEADDR. If the same user does this, there is no problem,
- # and the socket may be rebound immediately. If a different user
- # (yes, in my testing, even root) attempts to rebind, it fails.
- # Since the "is the socket available yet" code and the
- # second-batch bind call both run as root, this will fail.
-
- # The upstream settings on my test machine cause the second batch
- # of tests to fail, believing the socket to still be in use. I
- # tried patching various parts to make them run as the user
- # specified in $config->{vars}{user} using getpwnam, but found
- # this patch to be fairly intrusive, because the userid must be
- # restored and the patch must be applied to multiple places.
-
- # For now, we will simply extend the timeout in hopes that in the
- # non-userpriv case, the socket will clear from the kernel tables
- # normally, and the tests will proceed.
-
- # If anybody is still having problems, then commenting out "make
- # test" below should allow the software to build properly.
-
- # Robert Coie <rac@gentoo.org> 2003.05.06
-
- sed -i -e "s/sleep \$_/sleep \$_ << 2/" \
- "${S}"/Apache-Test/lib/Apache/TestServer.pm \
- || die "problem editing TestServer.pm"
-
- # rendhalver - this got redone for 2.0.1 and seems to fix the make test problems
- epatch "${FILESDIR}"/mod_perl-2.0.1-sneak-tmpdir.patch
-
- epatch "${FILESDIR}"/CVE-2009-0796.patch
-}
-
-src_configure() {
- perl Makefile.PL \
- PREFIX="${D}"/usr \
- MP_TRACE=1 \
- MP_DEBUG=1 \
- MP_USE_DSO=1 \
- MP_APXS=${APXS} \
- INSTALLDIRS=vendor </dev/null || die
-}
-
-src_compile() {
- # reported that parallel make is broken in bug 30257
- emake -j1 || die
-}
-
-src_test() {
- # make test notes whether it is running as root, and drops
- # privileges all the way to "nobody" if so, so we must adjust
- # write permissions accordingly in this case.
-
- # IF YOU SUDO TO EMERGE AND HAVE !env_reset set testing will fail!
- if [[ "$(id -u)" == "0" ]]; then
- chown nobody:nobody "${WORKDIR}"
- chown nobody:nobody "${T}"
- fi
-
- # this does not || die because of bug 21325. kudos to smark for
- # the idea of setting HOME.
- TMPDIR="${T}" HOME="${T}/" make test
-}
-
-src_install() {
- apache-module_src_install
-
- dodir "${APACHE_MODULESDIR}"
- make install \
- MODPERL_AP_LIBEXECDIR="${D}${APACHE_MODULESDIR}" \
- MODPERL_AP_INCLUDEDIR="${D}${APACHE_INCLUDEDIR}" \
- MP_INST_APACHE2=1 \
- INSTALLDIRS=vendor || die
-
- # rendhalver - fix the perllocal.pod that gets installed
- # it seems to me that this has been getting installed for ages
- fixlocalpod
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}"/2.0.3/apache2-mod_perl-startup.pl
- cp -pPR docs "${D}"/usr/share/doc/${PF}
- cp -pPR todo "${D}"/usr/share/doc/${PF}
-
- # this is an attempt to get @INC in line with /usr/bin/perl.
- # there is blib garbage in the mainstream one that can only be
- # useful during internal testing, so we wait until here and then
- # just go with a clean slate. should be much easier to see what's
- # happening and revert if problematic.
- for FILE in $(grep -lr portage "${D}"/*|grep -v ".so"); do
- sed -i -e "s:${D}:/:g" ${FILE}
- done
-}
diff --git a/www-apache/mod_perl/mod_perl-2.0.5.ebuild b/www-apache/mod_perl/mod_perl-2.0.5.ebuild
deleted file mode 100644
index 8a2e5daedb9e..000000000000
--- a/www-apache/mod_perl/mod_perl-2.0.5.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.5.ebuild,v 1.9 2012/04/03 20:23:27 idl0r Exp $
-
-EAPI="3"
-
-inherit apache-module perl-module eutils
-
-DESCRIPTION="An embedded Perl interpreter for Apache2"
-SRC_URI="mirror://apache/perl/${P}.tar.gz"
-HOMEPAGE="http://perl.apache.org/"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug"
-SLOT="1"
-
-# Make sure we always use the latest Apache-Test version or even check the
-# version of the bundled Apache-Test!
-#
-# We need both, apache and perl but either apache without threads or perl with
-# ithreads, bug 373943
-DEPEND="<www-servers/apache-2.4
- >=dev-perl/Apache-Test-1.360
- >=virtual/perl-CGI-3.08
- dev-lang/perl
- www-servers/apache
- || ( www-servers/apache[-threads] dev-lang/perl[ithreads] )"
-RDEPEND="${DEPEND}"
-PDEPEND=">=dev-perl/Apache-Reload-0.11
- >=dev-perl/Apache-SizeLimit-0.95"
-
-APACHE2_MOD_FILE="${S}/src/modules/perl/mod_perl.so"
-APACHE2_MOD_CONF="2.0.3/75_${PN}"
-APACHE2_MOD_DEFINE="PERL"
-
-SRC_TEST="do"
-
-DOCFILES="Changes INSTALL README STATUS"
-
-need_apache2
-
-src_prepare() {
- perl-module_src_prepare
-
- # I am not entirely happy with this solution, but here's what's
- # going on here if someone wants to take a stab at another
- # approach. When userpriv compilation is off, then the make
- # process drops to user "nobody" to run the test servers. This
- # server is closed, and then the socket is rebound using
- # SO_REUSEADDR. If the same user does this, there is no problem,
- # and the socket may be rebound immediately. If a different user
- # (yes, in my testing, even root) attempts to rebind, it fails.
- # Since the "is the socket available yet" code and the
- # second-batch bind call both run as root, this will fail.
-
- # The upstream settings on my test machine cause the second batch
- # of tests to fail, believing the socket to still be in use. I
- # tried patching various parts to make them run as the user
- # specified in $config->{vars}{user} using getpwnam, but found
- # this patch to be fairly intrusive, because the userid must be
- # restored and the patch must be applied to multiple places.
-
- # For now, we will simply extend the timeout in hopes that in the
- # non-userpriv case, the socket will clear from the kernel tables
- # normally, and the tests will proceed.
-
- # If anybody is still having problems, then commenting out "make
- # test" below should allow the software to build properly.
-
- # Robert Coie <rac@gentoo.org> 2003.05.06
-# sed -i -e "s/sleep \$_/sleep \$_ << 2/" \
-# "${S}"/Apache-Test/lib/Apache/TestServer.pm \
-# || die "problem editing TestServer.pm"
-
- # rendhalver - this got redone for 2.0.1 and seems to fix the make test problems
- epatch "${FILESDIR}"/mod_perl-2.0.1-sneak-tmpdir.patch
-
- # bug 352724
- epatch "${FILESDIR}/${P}-bundled-Apache-Test.patch"
- rm -rf Apache-{Test,Reload,SizeLimit}/ lib/Bundle/
-}
-
-src_configure() {
- local myargs=
-
- if use debug; then
- myargs="MP_TRACE=1 MP_DEBUG=1"
- else
- myargs="MP_TRACE=0 MP_DEBUG=0"
- fi
-
- perl Makefile.PL \
- PREFIX="${EPREFIX}"/usr \
- INSTALLDIRS=vendor \
- MP_USE_DSO=1 \
- MP_APXS=${APXS} \
- ${myargs} || die
-}
-
-src_test() {
- # make test notes whether it is running as root, and drops
- # privileges all the way to "nobody" if so, so we must adjust
- # write permissions accordingly in this case.
-
- # IF YOU SUDO TO EMERGE AND HAVE !env_reset set testing will fail!
- if [[ "$(id -u)" == "0" ]]; then
- chown nobody:nobody "${WORKDIR}"
- chown nobody:nobody "${T}"
- fi
-
- # this does not || die because of bug 21325. kudos to smark for
- # the idea of setting HOME.
- TMPDIR="${T}" HOME="${T}/" perl-module_src_test
-}
-
-src_install() {
- apache-module_src_install
-
- emake DESTDIR="${D}" install || die
-
- # TODO: add some stuff from docs/ back?
-
- # rendhalver - fix the perllocal.pod that gets installed
- # it seems to me that this has been getting installed for ages
- fixlocalpod
- # Remove empty .bs files as well
- perl_delete_packlist
-
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}"/2.0.3/apache2-mod_perl-startup.pl || die
-
- # this is an attempt to get @INC in line with /usr/bin/perl.
- # there is blib garbage in the mainstream one that can only be
- # useful during internal testing, so we wait until here and then
- # just go with a clean slate. should be much easier to see what's
- # happening and revert if problematic.
-
- # Sorry for this evil hack...
- perlinfo # just to be sure...
- sed -i -e "s,-I${S}/[^[:space:]\"\']\+[[:space:]]\?,,g" \
- -e "s,-typemap[[:space:]]${S}/[^[:space:]\"\']\+[[:space:]]\?,,g" \
- -e "s,${S}\(/[^[:space:]\"\']\+\)\?,/,g" "${D}/${VENDOR_ARCH}/Apache2/BuildConfig.pm" || die
-
- for fname in $(find "${D}" -type f -not -name '*.so'); do
- grep -q "\(${D}\|${S}\)" "${fname}" && ewarn "QA: File contains a temporary path ${fname}"
- sed -i -e "s:\(${D}\|${S}\):/:g" ${fname}
- done
- # All the rest
- perl_remove_temppath
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
- apache-module_pkg_postinst
-}