summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-10 11:30:27 +0000
committerMike Frysinger <vapier@gentoo.org>2015-06-10 11:30:27 +0000
commit61f6945dca137256ed389a9c5dc5957891e183a9 (patch)
treec3ea17aa7044fc813df04a852154cb4c27b003c4 /www-apache
parentVersion bump to 0.7.1. Drop older releases. (diff)
downloadgentoo-2-61f6945dca137256ed389a9c5dc5957891e183a9.tar.gz
gentoo-2-61f6945dca137256ed389a9c5dc5957891e183a9.tar.bz2
gentoo-2-61f6945dca137256ed389a9c5dc5957891e183a9.zip
Version bump. Require apache use either mpm_worker or mpm_event per upstream docs.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/ChangeLog9
-rw-r--r--www-apache/mod_h2/mod_h2-0.6.4.ebuild57
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild12
3 files changed, 76 insertions, 2 deletions
diff --git a/www-apache/mod_h2/ChangeLog b/www-apache/mod_h2/ChangeLog
index 6a67bdd51a1b..824e99ab3fa5 100644
--- a/www-apache/mod_h2/ChangeLog
+++ b/www-apache/mod_h2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_h2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.4 2015/06/01 14:40:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.5 2015/06/10 11:30:27 vapier Exp $
+
+*mod_h2-0.6.4 (10 Jun 2015)
+
+ 10 Jun 2015; Mike Frysinger <vapier@gentoo.org> +mod_h2-0.6.4.ebuild,
+ mod_h2-9999.ebuild:
+ Version bump. Require apache use either mpm_worker or mpm_event per upstream
+ docs.
*mod_h2-0.6.3 (01 Jun 2015)
diff --git a/www-apache/mod_h2/mod_h2-0.6.4.ebuild b/www-apache/mod_h2/mod_h2-0.6.4.ebuild
new file mode 100644
index 000000000000..dda23adc16c1
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-0.6.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-0.6.4.ebuild,v 1.1 2015/06/10 11:30:27 vapier Exp $
+
+EAPI="5"
+
+inherit apache-module
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="=net-libs/nghttp2-0.7*
+ ssl? ( www-servers/apache[alpn] )"
+DEPEND="${RDEPEND}"
+
+# The mpm_prefork module doesn't work right. See upstream docs.
+# The threads logic is to handle the default eclass behavior which selects a
+# default mpm via the USE=threads flag.
+RDEPEND+="
+ || (
+ www-servers/apache[apache2_mpms_worker]
+ www-servers/apache[apache2_mpms_event]
+ www-servers/apache[threads,-apache2_mpms_prefork,-apache2_mpms_peruser]
+ )"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror \
+ --disable-sandbox
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_h2.conf" "75_mod_h2.conf"
+}
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index ad93591e0eb1..6cb442be3448 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-9999.ebuild,v 1.2 2015/06/01 06:08:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-9999.ebuild,v 1.3 2015/06/10 11:30:27 vapier Exp $
EAPI="5"
@@ -25,6 +25,16 @@ RDEPEND="=net-libs/nghttp2-0.7*
ssl? ( www-servers/apache[alpn] )"
DEPEND="${RDEPEND}"
+# The mpm_prefork module doesn't work right. See upstream docs.
+# The threads logic is to handle the default eclass behavior which selects a
+# default mpm via the USE=threads flag.
+RDEPEND+="
+ || (
+ www-servers/apache[apache2_mpms_worker]
+ www-servers/apache[apache2_mpms_event]
+ www-servers/apache[threads,-apache2_mpms_prefork,-apache2_mpms_peruser]
+ )"
+
need_apache2_4
src_configure() {