summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 18:45:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 18:45:13 +0000
commit923363cffde03be6c002195f9229780a1736fc72 (patch)
treee431fe28e61bc0baa9cdddc8b7c8455904952ff8 /www-apache
parentRemove myself from metadata, package has no bugs, leave it to desktop-misc herd (diff)
downloadgentoo-2-923363cffde03be6c002195f9229780a1736fc72.tar.gz
gentoo-2-923363cffde03be6c002195f9229780a1736fc72.tar.bz2
gentoo-2-923363cffde03be6c002195f9229780a1736fc72.zip
Don't call deprecated python_version() (bug #311233).
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_python/ChangeLog8
-rw-r--r--www-apache/mod_python/mod_python-3.3.1-r1.ebuild29
2 files changed, 22 insertions, 15 deletions
diff --git a/www-apache/mod_python/ChangeLog b/www-apache/mod_python/ChangeLog
index 72a297ee2404..453e83c85409 100644
--- a/www-apache/mod_python/ChangeLog
+++ b/www-apache/mod_python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_python
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.19 2009/09/17 10:50:39 hollow Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.20 2010/03/26 18:45:13 arfrever Exp $
+
+ 26 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mod_python-3.3.1-r1.ebuild:
+ Don't call deprecated python_version() (bug #311233).
17 Sep 2009; Benedikt Böhm <hollow@gentoo.org> -mod_python-3.3.1.ebuild:
cleanup
diff --git a/www-apache/mod_python/mod_python-3.3.1-r1.ebuild b/www-apache/mod_python/mod_python-3.3.1-r1.ebuild
index 55777bdb7d56..c05ff2987a5f 100644
--- a/www-apache/mod_python/mod_python-3.3.1-r1.ebuild
+++ b/www-apache/mod_python/mod_python-3.3.1-r1.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.3.1-r1.ebuild,v 1.5 2009/08/07 02:41:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.3.1-r1.ebuild,v 1.6 2010/03/26 18:45:13 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
-inherit autotools eutils python apache-module multilib
-
-KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+inherit apache-module autotools eutils python
DESCRIPTION="An Apache2 module providing an embedded Python interpreter."
HOMEPAGE="http://www.modpython.org/"
SRC_URI="mirror://apache/httpd/modpython/${P}.tgz"
+
LICENSE="Apache-1.1"
SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
IUSE=""
-DEPEND="dev-lang/python"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND=""
APACHE2_MOD_CONF="16_${PN}"
APACHE2_MOD_DEFINE="PYTHON"
@@ -25,6 +26,10 @@ DOCFILES="README NEWS CREDITS"
need_apache2
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}/${PN}-apr_brigade_sentinel.patch"
epatch "${FILESDIR}/${P}-apache-2.4.patch"
@@ -51,21 +56,19 @@ src_install() {
}
src_test() {
- python_version
cd test
PYTHONPATH="$(ls -d ${S}/dist/build/lib.*)"
sed -i \
-e "120ios.environ['PYTHONPATH']=\"${PYTHONPATH}\"" \
test.py || die "sed failed"
- "${python}" test.py || die "tests failed"
+ "$(PYTHON)" test.py || die "tests failed"
}
pkg_postinst() {
- python_version
- python_mod_optimize $(python_get_sitedir)/mod_python
apache-module_pkg_postinst
+ python_mod_optimize mod_python
}
pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/mod_python
+ python_mod_cleanup mod_python
}