summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-21 16:13:23 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-21 16:13:23 +0000
commitbc0a4da386703b772435d7653b23919b4a3b0032 (patch)
tree351ca7d65eb1aebb712cffda006fdba30101f3cd /www-apache
parentDisable gnulib update-copyright test for now #554728 by Paolo Pedroni. (diff)
downloadgentoo-2-bc0a4da386703b772435d7653b23919b4a3b0032.tar.gz
gentoo-2-bc0a4da386703b772435d7653b23919b4a3b0032.tar.bz2
gentoo-2-bc0a4da386703b772435d7653b23919b4a3b0032.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/ChangeLog7
-rw-r--r--www-apache/mod_h2/mod_h2-0.8.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/www-apache/mod_h2/ChangeLog b/www-apache/mod_h2/ChangeLog
index 115aed96f5a3..da86560dd49b 100644
--- a/www-apache/mod_h2/ChangeLog
+++ b/www-apache/mod_h2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_h2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.11 2015/07/05 14:16:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.12 2015/07/21 16:13:23 vapier Exp $
+
+*mod_h2-0.8.1 (21 Jul 2015)
+
+ 21 Jul 2015; Mike Frysinger <vapier@gentoo.org> +mod_h2-0.8.1.ebuild:
+ Version bump.
*mod_h2-0.8.0 (05 Jul 2015)
diff --git a/www-apache/mod_h2/mod_h2-0.8.1.ebuild b/www-apache/mod_h2/mod_h2-0.8.1.ebuild
new file mode 100644
index 000000000000..02eca3f68663
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-0.8.1.ebuild,v 1.1 2015/07/21 16:13:23 vapier Exp $
+
+EAPI="5"
+
+inherit apache-module
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ ssl? ( www-servers/apache[alpn] )"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror \
+ --disable-sandbox
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_h2.conf" "75_mod_h2.conf"
+}