summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-29 07:39:40 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-29 07:39:40 +0000
commitf7246f5f356d0205e5153edd383718ff1fb2ad24 (patch)
tree08e6b0ed6c7d4f11151ad2eb1160b5266e2b2a4c /www-apache
parentAdd missing 'die' statement to sed, keyword ~amd64 wrt bug #439868, thanks to... (diff)
downloadgentoo-2-f7246f5f356d0205e5153edd383718ff1fb2ad24.tar.gz
gentoo-2-f7246f5f356d0205e5153edd383718ff1fb2ad24.tar.bz2
gentoo-2-f7246f5f356d0205e5153edd383718ff1fb2ad24.zip
Cleanup.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/ChangeLog6
-rw-r--r--www-apache/passenger/passenger-3.0.11-r1.ebuild90
-rw-r--r--www-apache/passenger/passenger-3.0.11.ebuild86
-rw-r--r--www-apache/passenger/passenger-3.0.12.ebuild93
4 files changed, 5 insertions, 270 deletions
diff --git a/www-apache/passenger/ChangeLog b/www-apache/passenger/ChangeLog
index 472278bea50d..486409b74c49 100644
--- a/www-apache/passenger/ChangeLog
+++ b/www-apache/passenger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/passenger
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.53 2012/08/29 05:47:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.54 2012/10/29 07:39:40 graaff Exp $
+
+ 29 Oct 2012; Hans de Graaff <graaff@gentoo.org> -passenger-3.0.11.ebuild,
+ -passenger-3.0.11-r1.ebuild, -passenger-3.0.12.ebuild:
+ Cleanup.
*passenger-3.0.17 (29 Aug 2012)
diff --git a/www-apache/passenger/passenger-3.0.11-r1.ebuild b/www-apache/passenger/passenger-3.0.11-r1.ebuild
deleted file mode 100644
index c73978258460..000000000000
--- a/www-apache/passenger/passenger-3.0.11-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-3.0.11-r1.ebuild,v 1.2 2012/05/05 06:25:29 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-inherit apache-module flag-o-matic ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-ruby_add_rdepend "
- >=dev-ruby/daemon_controller-0.2.5
- >=dev-ruby/rack-1.0.0"
-
-USE_RUBY="ruby18" ruby_add_rdepend ">=dev-ruby/fastthread-1.0.1"
-
-CDEPEND=">=dev-libs/libev-3.90 net-misc/curl[ssl]"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}
- doc? ( >=app-text/asciidoc-8.6.5[highlight] )"
-
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-REQUIRED_USE+=" ruby_targets_ruby18? ( !ruby_targets_ruby19 )
- ruby_targets_ruby19? ( !ruby_targets_ruby18 )"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.8-gentoo.patch
- epatch "${FILESDIR}"/${PN}-3.0.0-ldflags.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "s/gcc/$(tc-getCC)/" -e "s/g++/$(tc-getCXX)/" build/config.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/phusion-passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- lib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version.
- rm -rf ext/libev || die "Unable to remove vendored libev."
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake fakeroot || die "rake failed"
-
- # TODO: this will create a mess when multiple RUBY_TARGETS have been
- # selected.
- APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-3.0.11.ebuild b/www-apache/passenger/passenger-3.0.11.ebuild
deleted file mode 100644
index 3e60b4142804..000000000000
--- a/www-apache/passenger/passenger-3.0.11.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-3.0.11.ebuild,v 1.1 2011/12/26 11:51:00 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18"
-
-inherit apache-module flag-o-matic ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-ruby_add_rdepend "
- >=dev-ruby/daemon_controller-0.2.5
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rack-1.0.0"
-
-CDEPEND=">=dev-libs/libev-3.90 net-misc/curl[ssl]"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}
- doc? ( >=app-text/asciidoc-8.6.5[highlight] )"
-
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.8-gentoo.patch
- epatch "${FILESDIR}"/${PN}-3.0.0-ldflags.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "s/gcc/$(tc-getCC)/" -e "s/g++/$(tc-getCXX)/" build/config.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/phusion-passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- lib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version.
- rm -rf ext/libev || die "Unable to remove vendored libev."
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake fakeroot || die "rake failed"
-
- # TODO: this will create a mess when multiple RUBY_TARGETS have been
- # selected.
- APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-3.0.12.ebuild b/www-apache/passenger/passenger-3.0.12.ebuild
deleted file mode 100644
index 27f11ff289b6..000000000000
--- a/www-apache/passenger/passenger-3.0.12.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-3.0.12.ebuild,v 1.3 2012/05/05 06:25:29 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-inherit apache-module flag-o-matic ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-ruby_add_rdepend "
- >=dev-ruby/daemon_controller-0.2.5
- >=dev-ruby/rack-1.0.0"
-
-USE_RUBY="ruby18" ruby_add_rdepend ">=dev-ruby/fastthread-1.0.1"
-
-CDEPEND=">=dev-libs/libev-3.90 net-misc/curl[ssl]"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}
- doc? ( >=app-text/asciidoc-8.6.5[highlight] )"
-
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-REQUIRED_USE+=" ruby_targets_ruby18? ( !ruby_targets_ruby19 )
- ruby_targets_ruby19? ( !ruby_targets_ruby18 )"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.8-gentoo.patch
- epatch "${FILESDIR}"/${PN}-3.0.12-ldflags.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "s/gcc/$(tc-getCC)/" -e "s/g++/$(tc-getCXX)/" build/config.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/phusion-passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- lib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" ext/common/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' lib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version.
- rm -rf ext/libev || die "Unable to remove vendored libev."
-
- # fix automagic use of asciidoc, bug 413469
- sed -i -e '/fakeroot/ s/+ Packaging::ASCII_DOCS//' build/packaging.rb || die
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
- rake fakeroot || die "rake failed"
-
- # TODO: this will create a mess when multiple RUBY_TARGETS have been
- # selected.
- APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
- apache-module_src_install
-}