summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2006-04-09 22:14:24 +0000
committerLance Albertson <ramereth@gentoo.org>2006-04-09 22:14:24 +0000
commit16dbdac842fc50bb0966a2778b7d2b2459ea92f3 (patch)
tree2c069e6463882b504934cc48f2f37da25b44b504 /www-apps/dokuwiki
parentVersion bump, pruned old version. (diff)
downloadgentoo-2-16dbdac842fc50bb0966a2778b7d2b2459ea92f3.tar.gz
gentoo-2-16dbdac842fc50bb0966a2778b7d2b2459ea92f3.tar.bz2
gentoo-2-16dbdac842fc50bb0966a2778b7d2b2459ea92f3.zip
verison bump, add proper config file support
(Portage version: 2.0.54)
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/ChangeLog9
-rw-r--r--www-apps/dokuwiki/Manifest2
-rw-r--r--www-apps/dokuwiki/dokuwiki-20060309.ebuild62
-rw-r--r--www-apps/dokuwiki/files/digest-dokuwiki-200603091
4 files changed, 73 insertions, 1 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index cf13a0b409da..14235127218f 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/dokuwiki
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.5 2006/03/10 04:58:49 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.6 2006/04/09 22:14:24 ramereth Exp $
+
+*dokuwiki-20060309 (09 Apr 2006)
+
+ 09 Apr 2006; Lance Albertson <ramereth@gentoo.org>
+ +dokuwiki-20060309.ebuild:
+ * Version bump
+ * Added proper config file support for .htaccess and conf/ files
*dokuwiki-20060305 (10 Mar 2006)
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index 7324e2c7502d..14714fbfac5a 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -2,8 +2,10 @@ MD5 4bdb3ec7f6f3a36ca25a0ddd2566aa85 ChangeLog 1026
MD5 81e31544f5fdc97318231fa56e0ecded dokuwiki-20050713.ebuild 1498
MD5 ff3c1be2a0242be8b4c82c569291bc00 dokuwiki-20050922.ebuild 1498
MD5 ea04a6453c070856698e0785bd86264e dokuwiki-20060305.ebuild 1503
+MD5 c3216b8b8a4c6afe43df40c68a837ce0 dokuwiki-20060309.ebuild 1590
MD5 a65ef20ee770f09cfcd76f346f3da136 files/digest-dokuwiki-20050713 68
MD5 a8cdb48781eb1d76bdd22351814a2b9a files/digest-dokuwiki-20050922 68
MD5 0adbd91b5af89c1dd5e28f21a5dc8a61 files/digest-dokuwiki-20060305 68
+MD5 11a8b6d4353a7ed4414cbd86e5785661 files/digest-dokuwiki-20060309 68
MD5 1b5b86b6942f3451fc286451dbaf7c4a files/postinstall-en.txt 1590
MD5 0922f8bcb85431dab1ce19e2675e2e24 metadata.xml 704
diff --git a/www-apps/dokuwiki/dokuwiki-20060309.ebuild b/www-apps/dokuwiki/dokuwiki-20060309.ebuild
new file mode 100644
index 000000000000..c10c70ab80b1
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20060309.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20060309.ebuild,v 1.1 2006/04/09 22:14:24 ramereth Exp $
+
+inherit webapp
+
+# Upstream uses dashes in the datestamp
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small companies
+documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/php"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${PN}-${MY_PV}.tgz
+ mv ${PN}-${MY_PV} ${P}
+}
+
+src_compile() {
+ # Default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ local docs="README"
+ webapp_src_preinst
+
+ # NOTE: doc files should go into /usr/share/doc, and NOT installed in the vhost
+ einfo "Installing docs"
+ dodoc ${docs}
+ for doc in ${docs} COPYING; do
+ rm -f ${doc}
+ done
+
+ einfo "Copying main files"
+ cp -r . ${D}/${MY_HTDOCSDIR}
+
+ # Install the htaccess file for pretty urls
+ cp .htaccess ${D}/${MY_HTDOCSDIR}
+
+ # Create initial changes file
+ touch ${D}/${MY_HTDOCSDIR}/data/changes.log data/changes.log
+
+ # The data dir needs to be owned by the server
+ for x in `find . -print | grep "data/*" | grep -v .htaccess` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+ webapp_configfile ${MY_HTDOCSDIR}/conf/*
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/files/digest-dokuwiki-20060309 b/www-apps/dokuwiki/files/digest-dokuwiki-20060309
new file mode 100644
index 000000000000..65cc4e0d0a36
--- /dev/null
+++ b/www-apps/dokuwiki/files/digest-dokuwiki-20060309
@@ -0,0 +1 @@
+MD5 d67c854712347e7c3cdba6b4a951c533 dokuwiki-2006-03-09.tgz 834975