summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-06-29 21:34:22 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-06-29 21:34:22 +0000
commite84566c05447ff071d731acc991e0f5291f26f9e (patch)
treede13915c7cb85d15f8390f0382b85bf2d64bf232 /www-apps/drupal
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-e84566c05447ff071d731acc991e0f5291f26f9e.tar.gz
gentoo-2-e84566c05447ff071d731acc991e0f5291f26f9e.tar.bz2
gentoo-2-e84566c05447ff071d731acc991e0f5291f26f9e.zip
[www-apps/drupal] Bumped to the latest release - 6.17.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog8
-rw-r--r--www-apps/drupal/drupal-6.17.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index ac3fa4776ebe..55ebe8cd46d0 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/drupal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.64 2010/06/21 15:01:09 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.65 2010/06/29 21:34:22 jmbsvicetto Exp $
+
+*drupal-6.17 (29 Jun 2010)
+
+ 29 Jun 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +drupal-6.17.ebuild:
+ [www-apps/drupal] Bumped to the latest release - 6.17.
21 Jun 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
files/postinstall-en.txt:
diff --git a/www-apps/drupal/drupal-6.17.ebuild b/www-apps/drupal/drupal-6.17.ebuild
new file mode 100644
index 000000000000..acb2859ea93b
--- /dev/null
+++ b/www-apps/drupal/drupal-6.17.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.17.ebuild,v 1.1 2010/06/29 21:34:22 jmbsvicetto Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ ewarn
+}