summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-20 18:07:42 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-20 18:07:42 +0000
commit523c1e3ae7b75c388ce5dd8f3c010c8050533310 (patch)
tree493b1d006e714787eae28a5c376768b7ba5b0093 /www-apps/gallery
parentAdd ESVN_REVISION support. Remove problematic to_upper function. Provide revi... (diff)
downloadgentoo-2-523c1e3ae7b75c388ce5dd8f3c010c8050533310.tar.gz
gentoo-2-523c1e3ae7b75c388ce5dd8f3c010c8050533310.tar.bz2
gentoo-2-523c1e3ae7b75c388ce5dd8f3c010c8050533310.zip
merge from webapp overlay + further cleanup and checks wrt #208584
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog10
-rw-r--r--www-apps/gallery/gallery-1.5.3.ebuild36
-rw-r--r--www-apps/gallery/gallery-1.5.5.ebuild39
-rw-r--r--www-apps/gallery/gallery-1.5.7.ebuild37
-rw-r--r--www-apps/gallery/gallery-2.2.4.ebuild48
-rw-r--r--www-apps/gallery/metadata.xml6
6 files changed, 73 insertions, 103 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 4ae17438ffbf..6351b9e11dff 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.134 2008/02/05 15:13:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.135 2008/02/20 18:07:42 hollow Exp $
+
+ 20 Feb 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml,
+ gallery-1.5.3.ebuild, -gallery-1.5.5.ebuild, gallery-1.5.7.ebuild,
+ gallery-2.2.4.ebuild:
+ merge from webapp overlay + further cleanup and checks wrt #208584
+
+ 05 Feb 2008; Jakub Moc <jakub@gentoo.org> gallery-2.2.4.ebuild:
+ Remove bogus media-libs/gd dependency, simplify PHP check, clean-up.
05 Feb 2008; Benedikt Böhm <hollow@gentoo.org> gallery-1.5.3.ebuild,
gallery-1.5.5.ebuild, gallery-1.5.7.ebuild:
diff --git a/www-apps/gallery/gallery-1.5.3.ebuild b/www-apps/gallery/gallery-1.5.3.ebuild
index 0a5c91a83686..b011279121d9 100644
--- a/www-apps/gallery/gallery-1.5.3.ebuild
+++ b/www-apps/gallery/gallery-1.5.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.3.ebuild,v 1.10 2008/02/05 15:13:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.3.ebuild,v 1.11 2008/02/20 18:07:42 hollow Exp $
-inherit webapp depend.apache
+inherit webapp depend.php confutils
DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
HOMEPAGE="http://gallery.sourceforge.net/"
@@ -12,28 +12,38 @@ LICENSE="GPL-2"
KEYWORDS="alpha amd64 hppa ppc sparc x86"
IUSE="imagemagick netpbm unzip zip"
-RDEPEND="virtual/php
- media-libs/jpeg
- netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+RDEPEND="media-libs/jpeg
imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
unzip? ( app-arch/unzip )
zip? ( app-arch/zip )"
-need_apache2
+need_php_httpd
+
+S="${WORKDIR}"/${PN}
-S=${WORKDIR}/${PN}
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any imagemagick netpbm
+ require_php_with_use pcre session
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gunzip ChangeLog.archive.gz
+}
src_install() {
webapp_src_preinst
- cp -R * ${D}/${MY_HTDOCSDIR}
- for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
- dodoc ${file}
- rm -f ${D}/${MY_HTDOCSDIR}/${file}
- done
+ dodoc AUTHORS ChangeLog ChangeLog.archive README
dohtml docs/*
+ rm -rf AUTHORS ChangeLog ChangeLog.archive README LICENSE.txt docs/
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}
diff --git a/www-apps/gallery/gallery-1.5.5.ebuild b/www-apps/gallery/gallery-1.5.5.ebuild
deleted file mode 100644
index e330630ec3b5..000000000000
--- a/www-apps/gallery/gallery-1.5.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.5.ebuild,v 1.4 2008/02/05 15:13:28 hollow Exp $
-
-inherit webapp depend.apache
-
-DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
-HOMEPAGE="http://gallery.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="imagemagick netpbm unzip zip"
-
-RDEPEND="virtual/php
- media-libs/jpeg
- netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
- imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
- unzip? ( app-arch/unzip )
- zip? ( app-arch/zip )"
-
-need_apache2
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- webapp_src_preinst
-
- cp -R * ${D}/${MY_HTDOCSDIR}
- for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
- dodoc ${file}
- rm -f ${D}/${MY_HTDOCSDIR}/${file}
- done
- dohtml docs/*
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
-
- webapp_src_install
-}
diff --git a/www-apps/gallery/gallery-1.5.7.ebuild b/www-apps/gallery/gallery-1.5.7.ebuild
index 312084a19a2c..e7f7b2d7cb07 100644
--- a/www-apps/gallery/gallery-1.5.7.ebuild
+++ b/www-apps/gallery/gallery-1.5.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.7.ebuild,v 1.2 2008/02/05 15:13:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.7.ebuild,v 1.3 2008/02/20 18:07:42 hollow Exp $
-inherit webapp depend.apache
+inherit webapp depend.php confutils
DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
HOMEPAGE="http://gallery.sourceforge.net/"
@@ -12,29 +12,38 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="imagemagick netpbm unzip zip"
-RDEPEND="virtual/httpd-cgi
- virtual/php
- media-libs/jpeg
- netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+RDEPEND="media-libs/jpeg
imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
unzip? ( app-arch/unzip )
zip? ( app-arch/zip )"
-need_apache2
+need_php_httpd
+
+S="${WORKDIR}"/${PN}
-S=${WORKDIR}/${PN}
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any imagemagick netpbm
+ require_php_with_use pcre session
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gunzip ChangeLog.archive.gz
+}
src_install() {
webapp_src_preinst
- cp -R * "${D}/${MY_HTDOCSDIR}"
- for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
- dodoc ${file}
- rm -f "${D}/${MY_HTDOCSDIR}/${file}"
- done
+ dodoc AUTHORS ChangeLog ChangeLog.archive README
dohtml docs/*
+ rm -rf AUTHORS ChangeLog ChangeLog.archive README LICENSE.txt docs/
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}
diff --git a/www-apps/gallery/gallery-2.2.4.ebuild b/www-apps/gallery/gallery-2.2.4.ebuild
index bd5c843aa17d..e6a69a0f3fb8 100644
--- a/www-apps/gallery/gallery-2.2.4.ebuild
+++ b/www-apps/gallery/gallery-2.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.4.ebuild,v 1.8 2008/01/23 16:02:22 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.4.ebuild,v 1.9 2008/02/20 18:07:42 hollow Exp $
-inherit webapp eutils depend.php
+inherit webapp eutils depend.php confutils
DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
HOMEPAGE="http://gallery.sourceforge.net/"
@@ -12,61 +12,47 @@ LICENSE="GPL-2"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw unzip zip"
-RDEPEND="virtual/httpd-cgi
- media-libs/jpeg
+RDEPEND="media-libs/jpeg
raw? ( >=media-gfx/dcraw-8.03 )
ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
- gd? ( >=media-libs/gd-2 )
imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
unzip? ( app-arch/unzip )
- zip? ( app-arch/zip )
-"
+ zip? ( app-arch/zip )"
-S=${WORKDIR}/${PN}2
+S="${WORKDIR}"/${PN}2
-need_php
+need_php_httpd
pkg_setup() {
webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres
local php_flags="pcre session"
- local DIE=
-
use mysql && php_flags="${php_flags} mysql"
use postgres && php_flags="${php_flags} postgres"
- if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags}; then
- DIE="yes"
- fi
- if use gd; then
- if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
- DIE="yes"
- fi
- fi
-
- if [[ ${DIE} == "yes" ]]; then
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
+ ( use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
eerror
- eerror "${PHP_PKG} needs to be re-installed with all of the following"
- eerror "USE flags enabled:"
+ eerror "${PHP_PKG} needs to be re-installed with all of the following USE flags enabled:"
eerror
eerror "${php_flags}"
eerror
- if use gd; then
- eerror "as well as any of the following USE flags enabled:"
- eerror
- eerror "gd gd-external"
- eerror
- fi
- die "Re-install ${PHP_PKG}"
+ use gd && eerror "as well as with either gd or gd-external USE flag enabled."
+ die "Re-install ${PHP_PKG}."
fi
}
src_install() {
webapp_src_preinst
- cp -R * "${D}/${MY_HTDOCSDIR}"
dohtml README.html
+ rm README.html LICENSE MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
webapp_postinst_txt en "${FILESDIR}"/postinstall-en2.txt
webapp_src_install
diff --git a/www-apps/gallery/metadata.xml b/www-apps/gallery/metadata.xml
index 13bc126c7d91..6632069b5aff 100644
--- a/www-apps/gallery/metadata.xml
+++ b/www-apps/gallery/metadata.xml
@@ -1,9 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>web-apps</herd>
-<maintainer>
-<email>web-apps@gentoo.org</email>
-<name>Gentoo Web Application Packages Maintainers</name>
-</maintainer>
+ <herd>web-apps</herd>
</pkgmetadata>