summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-03-29 21:04:43 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-03-29 21:04:43 +0000
commit7325e54bb19e3873b042373009fb5594b8c02fb7 (patch)
tree2796e5c3d0b68c0c4ca6201991a142d01e51e376 /www-apps/gitweb
parentVersion bump (diff)
downloadgentoo-2-7325e54bb19e3873b042373009fb5594b8c02fb7.tar.gz
gentoo-2-7325e54bb19e3873b042373009fb5594b8c02fb7.tar.bz2
gentoo-2-7325e54bb19e3873b042373009fb5594b8c02fb7.zip
Version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-apps/gitweb')
-rw-r--r--www-apps/gitweb/ChangeLog7
-rw-r--r--www-apps/gitweb/files/digest-gitweb-1.5.0.63
-rw-r--r--www-apps/gitweb/gitweb-1.5.0.6.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/www-apps/gitweb/ChangeLog b/www-apps/gitweb/ChangeLog
index 17c550b74830..7517bb8f2030 100644
--- a/www-apps/gitweb/ChangeLog
+++ b/www-apps/gitweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gitweb
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.20 2007/02/15 18:39:39 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.21 2007/03/29 21:04:43 ferdy Exp $
+
+*gitweb-1.5.0.6 (29 Mar 2007)
+
+ 29 Mar 2007; Fernando J. Pereda <ferdy@gentoo.org> +gitweb-1.5.0.6.ebuild:
+ Version bump
*gitweb-1.5.0 (15 Feb 2007)
diff --git a/www-apps/gitweb/files/digest-gitweb-1.5.0.6 b/www-apps/gitweb/files/digest-gitweb-1.5.0.6
new file mode 100644
index 000000000000..c97e84e6e6c1
--- /dev/null
+++ b/www-apps/gitweb/files/digest-gitweb-1.5.0.6
@@ -0,0 +1,3 @@
+MD5 25a20a1c305e7791e5101424a048b6d2 git-1.5.0.6.tar.bz2 1052288
+RMD160 ad67f2b6495d1664248c15784eda17e46816285d git-1.5.0.6.tar.bz2 1052288
+SHA256 3a47a2940dabdb83495a7fcd32196844689eb154467d5bc9cf273c600e553264 git-1.5.0.6.tar.bz2 1052288
diff --git a/www-apps/gitweb/gitweb-1.5.0.6.ebuild b/www-apps/gitweb/gitweb-1.5.0.6.ebuild
new file mode 100644
index 000000000000..a8b46406a8b1
--- /dev/null
+++ b/www-apps/gitweb/gitweb-1.5.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/gitweb-1.5.0.6.ebuild,v 1.1 2007/03/29 21:04:43 ferdy Exp $
+
+inherit webapp
+
+GIT_VERSION="${PV}"
+
+DESCRIPTION="Web interface to GIT repositories"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+>=dev-util/git-${PV}"
+
+S="${WORKDIR}"/git-${GIT_VERSION}/gitweb
+
+src_compile() {
+ sed -i \
+ -e 's~^\(GITWEB_PROJECTROOT =\).*$~\1 /var/git~g' \
+ -e 's~^\(GITWEB_SITE_HEADER =\).*$~\1 header.html~g' \
+ -e 's~^\(GITWEB_SITE_FOOTER =\).*$~\1 footer.html~g' \
+ ../Makefile || die "failed to sed Makefile"
+ emake -C .. prefix=/usr gitweb/gitweb.cgi || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc README "${FILESDIR}"/README.gentoo
+ rm -f README
+
+ cp gitweb.{cgi,css} git-{favicon,logo}.png "${D}/${MY_HTDOCSDIR}"
+ cp "${FILESDIR}"/apache.htaccess "${D}/${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}