summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-23 20:51:25 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-23 20:51:25 +0000
commit4a8b50c26d03d37974a20d6447182f1122672c19 (patch)
tree10b113f323160dbd123e55a6070b1d5d58c6285b /www-apps/joomla/joomla-1.0.15.ebuild
parentremove unused app-admin/webalizer:search use flag (diff)
downloadgentoo-2-4a8b50c26d03d37974a20d6447182f1122672c19.tar.gz
gentoo-2-4a8b50c26d03d37974a20d6447182f1122672c19.tar.bz2
gentoo-2-4a8b50c26d03d37974a20d6447182f1122672c19.zip
readd 1.0 branch
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/joomla/joomla-1.0.15.ebuild')
-rw-r--r--www-apps/joomla/joomla-1.0.15.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-apps/joomla/joomla-1.0.15.ebuild b/www-apps/joomla/joomla-1.0.15.ebuild
new file mode 100644
index 000000000000..52d716b7e524
--- /dev/null
+++ b/www-apps/joomla/joomla-1.0.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/joomla-1.0.15.ebuild,v 1.1 2008/02/23 20:51:25 hollow Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System."
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="http://downloads.joomlacode.org/frsrelease/2/2/5/22536/Joomla_${PV}-Stable-Full_Package.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.php INSTALL.php
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files="administrator/backups administrator/components
+ administrator/modules administrator/templates cache components images
+ images/banners images/stories language mambots mambots/content
+ mambots/editors mambots/editors-xtd mambots/search mambots/system media
+ modules templates"
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}