summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 15:08:21 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 15:08:21 +0000
commit80549c793dca018b3969b329646b3c53cccc43ad (patch)
tree2ca2f74ca73955f71e710a4891e94d91bb1e59b1 /www-apps/lxr/lxr-0.3.1.ebuild
parentMoved from net-www/issue-tracker to www-apps/issue-tracker (diff)
downloadgentoo-2-80549c793dca018b3969b329646b3c53cccc43ad.tar.gz
gentoo-2-80549c793dca018b3969b329646b3c53cccc43ad.tar.bz2
gentoo-2-80549c793dca018b3969b329646b3c53cccc43ad.zip
Moved from net-www/lxr to www-apps/lxr.
Diffstat (limited to 'www-apps/lxr/lxr-0.3.1.ebuild')
-rw-r--r--www-apps/lxr/lxr-0.3.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-apps/lxr/lxr-0.3.1.ebuild b/www-apps/lxr/lxr-0.3.1.ebuild
new file mode 100644
index 000000000000..dddba821e1e9
--- /dev/null
+++ b/www-apps/lxr/lxr-0.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.3.1.ebuild,v 1.1 2004/08/15 15:08:21 stuart Exp $
+
+inherit webapp
+
+S=${WORKDIR}/${P%.?}
+
+DESCRIPTION="A general purpose source code indexer and cross-referencer that provides web-based browsing of source code with links to the definition and usage of any identifier."
+HOMEPAGE="http://sourceforge.net/projects/lxr"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RESTRICT="nomirror"
+IUSE=""
+
+# Glimpse is actually optional, but since there is no USE flag, require it
+RDEPEND="app-misc/glimpse
+ dev-lang/perl
+ >=dev-perl/DB_File-1.807"
+DEPEND=${RDEPEND}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ # prepare ${D} for our arrival
+ webapp_src_preinst
+
+ # Install documentation
+ dodoc COPYING INSTALL README
+
+ # Makefile macros
+ PERLBIN=`which perl`
+ INSTALLPREFIX=${D}/usr
+
+ # Install
+ #
+ # first we do it LXR's way ...
+ make install INSTALLPREFIX=${INSTALLPREFIX} PERLBIN=${PERLBIN}
+
+ # and now we do it our way
+ cp -R ${INSTALLPREFIX}/http/* ${D}${MY_HTDOCSDIR}
+ rm -rf ${INSTALLPREFIX}/http
+ rm -rf ${INSTALLPREFIX}/source
+
+ # Identify the configuration files that this app uses
+ webapp_configfile ${MY_HTDOCSDIR}/lxr.conf
+
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ for x in find ident search diff source; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/$x
+ done
+
+ # Add the post-installation instructions
+ webapp_postinst_txt en INSTALL
+
+ # Fix perms on genxref
+ fperms o+rx /usr/bin/genxref
+
+ # Let webapp.eclass do the rest
+ webapp_src_install
+}