summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-05-16 15:22:30 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-05-16 15:22:30 +0000
commit6cc25a7f5f23cbc9c833298d3ac355c58528de79 (patch)
tree4d803060039ca8a168ad2f6d9d0371105144ffff /www-apps/mambo
parentFixed doman locale. (diff)
downloadgentoo-2-6cc25a7f5f23cbc9c833298d3ac355c58528de79.tar.gz
gentoo-2-6cc25a7f5f23cbc9c833298d3ac355c58528de79.tar.bz2
gentoo-2-6cc25a7f5f23cbc9c833298d3ac355c58528de79.zip
Added mambo-4.6.2 to the tree.
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-apps/mambo')
-rw-r--r--www-apps/mambo/ChangeLog7
-rw-r--r--www-apps/mambo/files/digest-mambo-4.6.23
-rw-r--r--www-apps/mambo/mambo-4.6.2.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index 6815be2fca8f..98b27feeb88b 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.29 2007/01/02 22:36:43 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.30 2007/05/16 15:22:30 wrobel Exp $
+
+*mambo-4.6.2 (16 May 2007)
+
+ 16 May 2007; wrobel@gentoo.org +mambo-4.6.2.ebuild:
+ Added mambo-4.6.2 to the tree.
02 Jan 2007; Renat Lumpau <rl03@gentoo.org> -mambo-4.5.4-r2.ebuild,
mambo-4.6.1.ebuild:
diff --git a/www-apps/mambo/files/digest-mambo-4.6.2 b/www-apps/mambo/files/digest-mambo-4.6.2
new file mode 100644
index 000000000000..1e6019d9aa5f
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.6.2
@@ -0,0 +1,3 @@
+MD5 18654cfc78821585fac9e934ef41c86c MamboV4.6.2.tar.gz 2674116
+RMD160 bb37b06f9a6bc94c085857d6fc409ad91a493468 MamboV4.6.2.tar.gz 2674116
+SHA256 13e498b3c4f2c4db6879730b646ce38ed9f5e5a231881e80804be8285e4a6823 MamboV4.6.2.tar.gz 2674116
diff --git a/www-apps/mambo/mambo-4.6.2.ebuild b/www-apps/mambo/mambo-4.6.2.ebuild
new file mode 100644
index 000000000000..fbdb2194a158
--- /dev/null
+++ b/www-apps/mambo/mambo-4.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.6.2.ebuild,v 1.1 2007/05/16 15:22:30 wrobel Exp $
+
+inherit webapp depend.php
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is a dynamic portal engine and content management system"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/8291/${MY_PN}V${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates mambots/editors mambots/editors-xtd uploadfiles"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}