summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-05-08 19:16:06 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-05-08 19:16:06 +0000
commit5a78dd95b2709aacaba2be6498c00628624beca8 (patch)
tree1a95979e581a7e9c08cfa3dadbf0be0567acdf85 /www-apps/mantisbt
parentAdded to ~ppc (diff)
downloadgentoo-2-5a78dd95b2709aacaba2be6498c00628624beca8.tar.gz
gentoo-2-5a78dd95b2709aacaba2be6498c00628624beca8.tar.bz2
gentoo-2-5a78dd95b2709aacaba2be6498c00628624beca8.zip
Version bump
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'www-apps/mantisbt')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/files/digest-mantisbt-1.0.33
-rw-r--r--www-apps/mantisbt/mantisbt-1.0.3.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 25d04140af16..102c2f3b0e95 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.29 2006/04/20 18:55:50 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.30 2006/05/08 19:16:06 rl03 Exp $
+
+*mantisbt-1.0.3 (08 May 2006)
+
+ 08 May 2006; Renat Lumpau <rl03@gentoo.org> +mantisbt-1.0.3.ebuild:
+ Version bump
20 Apr 2006; Tobias Scherbaum <dertobi123@gentoo.org>
mantisbt-1.0.2.ebuild:
diff --git a/www-apps/mantisbt/files/digest-mantisbt-1.0.3 b/www-apps/mantisbt/files/digest-mantisbt-1.0.3
new file mode 100644
index 000000000000..7e79e55ca792
--- /dev/null
+++ b/www-apps/mantisbt/files/digest-mantisbt-1.0.3
@@ -0,0 +1,3 @@
+MD5 6c70d00da4cad5da2e0df387f474d3e4 mantis-1.0.3.tar.gz 1426811
+RMD160 46565f06374c3d8c49e102c32f943ebbda15d74d mantis-1.0.3.tar.gz 1426811
+SHA256 fa96e3ea7e0a8435ecfbe135a6d2f64272a69477166d1ebb0c2855c6e538545e mantis-1.0.3.tar.gz 1426811
diff --git a/www-apps/mantisbt/mantisbt-1.0.3.ebuild b/www-apps/mantisbt/mantisbt-1.0.3.ebuild
new file mode 100644
index 000000000000..1363dcf0738c
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.0.3.ebuild,v 1.1 2006/05/08 19:16:06 rl03 Exp $
+
+inherit webapp
+
+IUSE="mysql postgres"
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/mantis-${PV}.tar.gz"
+
+S=${WORKDIR}/mantis-${PV}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ mysql? ( >=dev-db/mysql-3.23.32 )
+ postgres? ( >=dev-db/postgresql-7 )
+ net-www/apache
+ virtual/httpd-php
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+ dodoc doc/*
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/doc
+
+ mv ${D}/${MY_HTDOCSDIR}/config_inc.php.sample ${D}/${MY_HTDOCSDIR}/config_inc.php
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-1.0.0.txt
+ webapp_src_install
+}