summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-10-31 22:49:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-10-31 22:49:12 +0000
commitf359d629deee5da42b7b7cad5e5069834d375940 (patch)
tree2284255f2f4ff1822e6e19f5e1a90070764bde53 /www-apps/mythweb
parentmask 0.22 version of mythtv-themes-extra (diff)
downloadgentoo-2-f359d629deee5da42b7b7cad5e5069834d375940.tar.gz
gentoo-2-f359d629deee5da42b7b7cad5e5069834d375940.tar.bz2
gentoo-2-f359d629deee5da42b7b7cad5e5069834d375940.zip
add post-RC2 ebuild for 0.22
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/mythweb-0.22_rc22667.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 4de8f7d24d1f..6463d3ff7a54 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.67 2009/07/31 18:18:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.68 2009/10/31 22:49:12 cardoe Exp $
+
+*mythweb-0.22_rc22667 (31 Oct 2009)
+
+ 31 Oct 2009; Doug Goldstein <cardoe@gentoo.org>
+ +mythweb-0.22_rc22667.ebuild:
+ add post-RC2 ebuild for 0.22
31 Jul 2009; Doug Goldstein <cardoe@gentoo.org>
mythweb-0.21_p17573.ebuild, mythweb-0.21_p20323.ebuild:
diff --git a/www-apps/mythweb/mythweb-0.22_rc22667.ebuild b/www-apps/mythweb/mythweb-0.22_rc22667.ebuild
new file mode 100644
index 000000000000..f0a09fcfebfe
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.22_rc22667.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.22_rc22667.ebuild,v 1.1 2009/10/31 22:49:12 cardoe Exp $
+
+EAPI=2
+inherit mythtv webapp depend.php
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+need_httpd_cgi
+need_php5_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use session mysql pcre posix json
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}"/mythweb
+ dodoc README INSTALL
+
+ dodir "${MY_HTDOCSDIR}"/data
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/mythweb.conf.{apache,lighttpd}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.21.txt
+
+ webapp_src_install
+}