summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-08-30 14:18:40 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-08-30 14:18:40 +0000
commit3174cf5144521bf6934ea3832a9a9724556c0a13 (patch)
treeb0ba1abedab32e6ca645576175f30d4f5f0aebdc /www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
parentRemoved mambo version affected by #176915. (diff)
downloadgentoo-2-3174cf5144521bf6934ea3832a9a9724556c0a13.tar.gz
gentoo-2-3174cf5144521bf6934ea3832a9a9724556c0a13.tar.bz2
gentoo-2-3174cf5144521bf6934ea3832a9a9724556c0a13.zip
phpsysinfo version bump to 2.5.4 because of security issue #186931.
(Portage version: 2.1.2.12)
Diffstat (limited to 'www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild')
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild b/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
new file mode 100644
index 000000000000..3542d49d8304
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/phpsysinfo-2.5.4.ebuild,v 1.1 2007/08/30 14:18:39 wrobel Exp $
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="phpSysInfo is a nice package that will display your system stats via PHP."
+HOMEPAGE="http://phpsysinfo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog README
+ cp -R [:dit:]* ${D}${MY_HTDOCSDIR}
+ cp config.php.new ${D}${MY_HTDOCSDIR}/config.php
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+ webapp_src_install
+}