summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-28 20:25:13 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-28 20:25:13 +0000
commitf7684bc3337f0c7c9a233b3a41a18905d3db2f11 (patch)
tree12a1852d9f0d6849de97612fed83de093fa683ef /www-apps/phpwebsite
parentWe don't need PROVIDE anymore with new-style virtuals. (diff)
downloadgentoo-2-f7684bc3337f0c7c9a233b3a41a18905d3db2f11.tar.gz
gentoo-2-f7684bc3337f0c7c9a233b3a41a18905d3db2f11.tar.bz2
gentoo-2-f7684bc3337f0c7c9a233b3a41a18905d3db2f11.zip
Version bump ( bug #130295 ).
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'www-apps/phpwebsite')
-rw-r--r--www-apps/phpwebsite/ChangeLog9
-rw-r--r--www-apps/phpwebsite/files/digest-phpwebsite-0.10.26
-rw-r--r--www-apps/phpwebsite/files/digest-phpwebsite-0.10.2_rc22
-rw-r--r--www-apps/phpwebsite/phpwebsite-0.10.2.ebuild50
4 files changed, 65 insertions, 2 deletions
diff --git a/www-apps/phpwebsite/ChangeLog b/www-apps/phpwebsite/ChangeLog
index d13ed86444e6..4541574b8abc 100644
--- a/www-apps/phpwebsite/ChangeLog
+++ b/www-apps/phpwebsite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/phpwebsite
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.49 2005/11/20 16:39:00 stuart Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/ChangeLog,v 1.50 2006/04/28 20:25:13 rl03 Exp $
+
+*phpwebsite-0.10.2 (28 Apr 2006)
+
+ 28 Apr 2006; Renat Lumpau <rl03@gentoo.org> +phpwebsite-0.10.2.ebuild:
+ Version bump ( bug #130295 ).
20 Nov 2005; Stuart Herbert <stuart@gentoo.org>
phpwebsite-0.10.2_rc2.ebuild:
diff --git a/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2 b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2
new file mode 100644
index 000000000000..16d401d3c99d
--- /dev/null
+++ b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2
@@ -0,0 +1,6 @@
+MD5 b9ebdb57fd5e16fbe68acd9c997345e6 phpwebsite-0.10.2-full.tar.gz 3338377
+RMD160 ab1918020a9baede3bea8af481970e7131c7f096 phpwebsite-0.10.2-full.tar.gz 3338377
+SHA256 1b91045e6e8d40dbfaac2b0016dac378885f98588e68e752fec76d1991c71696 phpwebsite-0.10.2-full.tar.gz 3338377
+MD5 1fa5ff38499641f1f5b0891a34be9ce1 phpws_patch_20060419.2.tgz 1560
+RMD160 f88fa69637ac71660f540d23e58fbbcd32491a7d phpws_patch_20060419.2.tgz 1560
+SHA256 7df6518405f13da4b7ffd87cf5ec3d11d6df32927b6f8a045fc0ec02eef96345 phpws_patch_20060419.2.tgz 1560
diff --git a/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2_rc2 b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2_rc2
index 0362931dc6f7..de65fe6b8010 100644
--- a/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2_rc2
+++ b/www-apps/phpwebsite/files/digest-phpwebsite-0.10.2_rc2
@@ -1 +1,3 @@
MD5 2c1d79cfbacda52c5cf2a85da6212c73 phpwebsite-0.10.2-RC2.tar.gz 1716780
+RMD160 fd0c856c1e08512217872ebbf9d3df8876ba1bd8 phpwebsite-0.10.2-RC2.tar.gz 1716780
+SHA256 45793f2ab224f0e678a673c7ef8052369c86aa81e0dd871c62217f6e9292afb4 phpwebsite-0.10.2-RC2.tar.gz 1716780
diff --git a/www-apps/phpwebsite/phpwebsite-0.10.2.ebuild b/www-apps/phpwebsite/phpwebsite-0.10.2.ebuild
new file mode 100644
index 000000000000..46db7917d6e6
--- /dev/null
+++ b/www-apps/phpwebsite/phpwebsite-0.10.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwebsite/phpwebsite-0.10.2.ebuild,v 1.1 2006/04/28 20:25:13 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="phpWebSite Content Management System"
+HOMEPAGE="http://phpwebsite.appstate.edu"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz
+http://phpwebsite.appstate.edu/downloads/security/phpws_patch_20060419.2.tgz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/httpd-php
+ >=dev-db/mysql-3.23.23"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ cp -f index.php ${P}-full
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd ${S}/${P}-full
+
+ local docs="docs/CHANGELOG.txt docs/CONVERSION.txt docs/CREDITS.txt docs/INSTALL.txt docs/KNOWNISSUES.txt docs/PEARERRORS.txt docs/README.txt docs/REQUIREMENTS.txt docs/THEMES.txt docs/UNINSTALL.txt docs/UPGRADE.txt docs/sample.config.php"
+ dodoc ${docs}
+
+ einfo "Installing main files"
+ cp -r * ${D}${MY_HTDOCSDIR}
+
+ #webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
+
+ # Files that need to be owned by webserver
+ webapp_serverowned ${MY_HTDOCSDIR}/conf
+ webapp_serverowned ${MY_HTDOCSDIR}/files
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod
+ webapp_serverowned ${MY_HTDOCSDIR}/images/mod/controlpanel
+ webapp_serverowned ${MY_HTDOCSDIR}/mod
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}