summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-08-22 17:45:40 +0000
committerMatti Bickel <mabi@gentoo.org>2011-08-22 17:45:40 +0000
commitf199c611e9d6398bfacab792ad348821827b925f (patch)
treefd8b7070a48775efe7351d55b852f264df3f5684 /www-apps/phpwiki
parentVersion bump. (diff)
downloadgentoo-2-f199c611e9d6398bfacab792ad348821827b925f.tar.gz
gentoo-2-f199c611e9d6398bfacab792ad348821827b925f.tar.bz2
gentoo-2-f199c611e9d6398bfacab792ad348821827b925f.zip
version bump to fix php upgrade related issue (bug #324819), also bump to EAPI4
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/phpwiki')
-rw-r--r--www-apps/phpwiki/ChangeLog10
-rw-r--r--www-apps/phpwiki/phpwiki-1.4.0_rc1.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/www-apps/phpwiki/ChangeLog b/www-apps/phpwiki/ChangeLog
index cfdd610a414c..b5ddd1a17691 100644
--- a/www-apps/phpwiki/ChangeLog
+++ b/www-apps/phpwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/phpwiki
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.24 2008/02/04 08:30:59 hollow Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/ChangeLog,v 1.25 2011/08/22 17:45:40 mabi Exp $
+
+*phpwiki-1.4.0_rc1 (22 Aug 2011)
+
+ 22 Aug 2011; Matti Bickel <mabi@gentoo.org> +phpwiki-1.4.0_rc1.ebuild:
+ version bump to fix php upgrade related issue (bug #324819), also bump to
+ EAPI4
04 Feb 2008; Benedikt Böhm <hollow@gentoo.org> phpwiki-1.3.14.ebuild:
merge from webapps overlay wrt #208584
diff --git a/www-apps/phpwiki/phpwiki-1.4.0_rc1.ebuild b/www-apps/phpwiki/phpwiki-1.4.0_rc1.ebuild
new file mode 100644
index 000000000000..2f19f43fab0b
--- /dev/null
+++ b/www-apps/phpwiki/phpwiki-1.4.0_rc1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.4.0_rc1.ebuild,v 1.1 2011/08/22 17:45:40 mabi Exp $
+
+EAPI=4
+
+inherit webapp
+
+MY_P=${P/_/}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PhpWiki is a WikiWikiWeb clone in PHP"
+HOMEPAGE="http://phpwiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="msql mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ dev-lang/php[msql?,mysql?,postgres?]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ || ( dev-lang/php[cgi] dev-lang/php[apache2] )"
+
+src_prepare() {
+ rm -f Makefile LICENSE
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -pPR * "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}"/{doc,schemas,README,INSTALL,TODO,UPGRADING}
+
+ dodoc README INSTALL TODO UPGRADING doc/* schemas/*
+
+ # Create config file from distribution default, and fix up invalid defaults
+ sed -ie "s:;DEBUG = 1:DEBUG = 0:" "${D}/${MY_HTDOCSDIR}"/config/config-dist.ini
+ cd "${D}"/${MY_HTDOCSDIR}/config
+ cp config-dist.ini config.ini
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-1.3-en.txt
+ webapp_configfile "${MY_HTDOCSDIR}"/config/config.ini
+
+ webapp_src_install
+}