summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-10 21:50:24 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-10 21:50:24 +0000
commit1ab40628138823987768991634a8d136328f2d60 (patch)
tree68a3b694fddc99fa124ae22f8882018c28f55a79 /www-apps/pyblosxom/pyblosxom-1.2.1.ebuild
parent0.17.0 version bump. (diff)
downloadgentoo-2-1ab40628138823987768991634a8d136328f2d60.tar.gz
gentoo-2-1ab40628138823987768991634a8d136328f2d60.tar.bz2
gentoo-2-1ab40628138823987768991634a8d136328f2d60.zip
Added pyblosxom-1.2.1 from the webapps overlay to the portage tree
(Portage version: 2.0.53)
Diffstat (limited to 'www-apps/pyblosxom/pyblosxom-1.2.1.ebuild')
-rw-r--r--www-apps/pyblosxom/pyblosxom-1.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/pyblosxom/pyblosxom-1.2.1.ebuild b/www-apps/pyblosxom/pyblosxom-1.2.1.ebuild
new file mode 100644
index 000000000000..21fc252a70af
--- /dev/null
+++ b/www-apps/pyblosxom/pyblosxom-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/pyblosxom/pyblosxom-1.2.1.ebuild,v 1.1 2006/01/10 21:50:24 wrobel Exp $
+
+inherit eutils distutils webapp
+
+DESCRIPTION="PyBlosxom is a lightweight weblog system."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pyblosxom.sourceforge.net/"
+
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/python"
+
+src_unpack() {
+
+ unpack ${A} && cd "${S}"
+
+ epatch ${FILESDIR}/gentoo-webapp.patch
+
+}
+
+src_install() {
+ webapp_src_preinst
+
+ distutils_src_install
+ dodoc README
+
+ keepdir /usr/share/${P}/plugins
+ keepdir ${MY_HTDOCSDIR}/data
+ keepdir ${MY_HTDOCSDIR}/log
+
+ mkdir -p ${D}${MY_CGIBINDIR}/pyblosxom
+ cp web/{config.py,pyblosxom.cgi} ${D}${MY_CGIBINDIR}/pyblosxom/
+
+ webapp_configfile ${MY_CGIBINDIR}/pyblosxom/config.py
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/config-hook.sh
+
+ webapp_src_install
+}