summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2006-11-13 23:10:16 +0000
committerJulien Allanos <dju@gentoo.org>2006-11-13 23:10:16 +0000
commita038c38c6e8244e26ffaaa199dff6c33e5fc649c (patch)
treebad84f854dabef40b9cc56beaa24e4b161dc613e /www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild
parentFix for bug #153888 thanks to Robert Buchholz (diff)
downloadgentoo-2-a038c38c6e8244e26ffaaa199dff6c33e5fc649c.tar.gz
gentoo-2-a038c38c6e8244e26ffaaa199dff6c33e5fc649c.tar.bz2
gentoo-2-a038c38c6e8244e26ffaaa199dff6c33e5fc649c.zip
Version bump for trac-0.10*.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild')
-rw-r--r--www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild b/www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild
new file mode 100644
index 000000000000..73d22cb5141e
--- /dev/null
+++ b/www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac-webadmin/trac-webadmin-0.1.2.ebuild,v 1.1 2006/11/13 23:10:16 dju Exp $
+
+inherit distutils
+
+DESCRIPTION="A Trac plugin for administering Trac projects through the web interface."
+HOMEPAGE="http://projects.edgewall.com/trac/wiki/WebAdmin"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="trac"
+KEYWORDS="~amd64"
+IUSE=""
+
+SLOT="0"
+
+DEPEND=">=www-apps/trac-0.10
+ >=dev-python/setuptools-0.6_rc1"
+
+# from marienz's setuptools.eclass:
+src_install() {
+ "${python}" setup.py install --root=${D} --no-compile \
+ --single-version-externally-managed "$@" || die "install failed"
+}
+
+src_test() {
+ "${python}" setup.py test || die "tests failed"
+}
+
+pkg_postinst() {
+ einfo "To enable the WebAdmin plugin in your Trac environments, you have to add:"
+ einfo " [components]"
+ einfo " webadmin.* = enabled"
+ einfo "to your trac.ini files."
+ einfo
+ einfo "To be able to see the Admin tab, your users must have the TRAC_ADMIN permission"
+ einfo "and/or the TICKET_ADMIN permission."
+}