summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-20 13:02:06 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-20 13:02:06 +0000
commitbc599a259438c57d6a35dbbd9017ac48f00c2c73 (patch)
tree78e7bead7cc1aad34543115c8c4e6d2a10ab868e /www-apps/tt-rss/tt-rss-1.8.ebuild
parentAdd descriptive headers to the HPPA patches (bug #414297). (diff)
downloadgentoo-2-bc599a259438c57d6a35dbbd9017ac48f00c2c73.tar.gz
gentoo-2-bc599a259438c57d6a35dbbd9017ac48f00c2c73.tar.bz2
gentoo-2-bc599a259438c57d6a35dbbd9017ac48f00c2c73.zip
Version bump to version 1.8.
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'www-apps/tt-rss/tt-rss-1.8.ebuild')
-rw-r--r--www-apps/tt-rss/tt-rss-1.8.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/www-apps/tt-rss/tt-rss-1.8.ebuild b/www-apps/tt-rss/tt-rss-1.8.ebuild
new file mode 100644
index 000000000000..46703fe5d896
--- /dev/null
+++ b/www-apps/tt-rss/tt-rss-1.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/tt-rss-1.8.ebuild,v 1.1 2013/06/20 13:02:05 scarabeus Exp $
+
+EAPI=5
+
+inherit user eutils webapp depend.php depend.apache vcs-snapshot
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="http://tt-rss.org/"
+SRC_URI="https://github.com/gothfox/Tiny-Tiny-RSS/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="daemon +mysql postgres"
+
+DEPEND="
+ daemon? ( dev-lang/php[mysql?,postgres?,pcntl,curl] )
+ !daemon? ( dev-lang/php[mysql?,postgres?,curl] )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use daemon; then
+ enewgroup ttrssd
+ enewuser ttrssd -1 /bin/sh /dev/null ttrssd
+ fi
+}
+
+src_prepare() {
+ # Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
+ einfo "Customizing config.php..."
+ mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
+
+ if use mysql && ! use postgres; then
+ sed -i \
+ -e "/define('DB_TYPE',/{s:pgsql:mysql:}" \
+ config.php || die
+ fi
+
+ sed -i \
+ -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" \
+ config.php || die
+
+ # per 462578
+ epatch_user
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "/${MY_HTDOCSDIR}"
+ doins -r *
+ keepdir "/${MY_HTDOCSDIR}"/feed-icons
+
+ for DIR in cache lock feed-icons; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ if use daemon; then
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon.txt
+ newinitd "${FILESDIR}"/ttrssd.initd-r1 ttrssd
+ newconfd "${FILESDIR}"/ttrssd.confd-r1 ttrssd
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/ttrssd.logrotated ttrssd
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ fi
+
+ webapp_src_install
+}