summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-04-24 08:15:15 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-04-24 08:15:15 +0000
commit0d23c37c2590a25429a36bc946ec330c1d231112 (patch)
treeef1529d980bcdb204a084822e68376f2e0e50591 /www-apps/webmcp
parentMask sys-apps/kuroevtd for removal, bug 441930. (diff)
downloadgentoo-2-0d23c37c2590a25429a36bc946ec330c1d231112.tar.gz
gentoo-2-0d23c37c2590a25429a36bc946ec330c1d231112.tar.bz2
gentoo-2-0d23c37c2590a25429a36bc946ec330c1d231112.zip
New package
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps/webmcp')
-rw-r--r--www-apps/webmcp/ChangeLog10
-rw-r--r--www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch97
-rw-r--r--www-apps/webmcp/metadata.xml11
-rw-r--r--www-apps/webmcp/webmcp-1.2.5.ebuild66
4 files changed, 184 insertions, 0 deletions
diff --git a/www-apps/webmcp/ChangeLog b/www-apps/webmcp/ChangeLog
new file mode 100644
index 000000000000..96132d330ddb
--- /dev/null
+++ b/www-apps/webmcp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apps/webmcp
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/webmcp/ChangeLog,v 1.1 2013/04/24 08:15:15 tupone Exp $
+
+*webmcp-1.2.5 (24 Apr 2013)
+
+ 24 Apr 2013; Alfredo Tupone <tupone@gentoo.org> +webmcp-1.2.5.ebuild,
+ +files/webmcp-1.2.5-gentoo.patch, +metadata.xml:
+ New package
+
diff --git a/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
new file mode 100644
index 000000000000..e318f0328ead
--- /dev/null
+++ b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
@@ -0,0 +1,97 @@
+--- Makefile.old 2013-03-12 21:49:03.976676966 +0100
++++ Makefile 2013-03-12 21:50:02.888103540 +0100
+@@ -1,11 +1,11 @@
+ include Makefile.options
+
+ all::
+- make documentation
+- make accelerator
+- make libraries
+- make symlinks
+- make precompile
++ $(MAKE) documentation
++ $(MAKE) accelerator
++ $(MAKE) libraries
++ $(MAKE) symlinks
++ $(MAKE) precompile
+
+ documentation::
+ rm -f doc/autodoc.tmp
+@@ -14,12 +14,12 @@
+ rm -f doc/autodoc.tmp
+
+ accelerator::
+- cd framework/accelerator; make
++ $(MAKE) -C framework/accelerator
+
+ libraries::
+- cd libraries/extos; make
+- cd libraries/mondelefant; make
+- cd libraries/multirand; make
++ $(MAKE) -C libraries/extos
++ $(MAKE) -C libraries/mondelefant
++ $(MAKE) -C libraries/multirand
+
+ symlinks::
+ ln -s -f ../../libraries/atom/atom.lua framework/lib/
+--- Makefile.options.old 2013-03-12 21:54:27.245530485 +0100
++++ Makefile.options 2013-03-12 21:55:45.756768247 +0100
+@@ -10,13 +8,13 @@
+ # C compiler flags
+ # TODO: check alternatives to -D_GNU_SOURCE -fPIC
+ # using libtool?
+-CFLAGS = -O2 -D_GNU_SOURCE -fPIC -Wall -I /usr/include -I /usr/local/include
++CPPFLAGS = -D_GNU_SOURCE -I /usr/include
+
+ # additional C compiler flags for parts which depend on PostgreSQL
+ CFLAGS_PGSQL = -I /usr/include/postgresql -I /usr/include/postgresql/server -I /usr/local/include/postgresql -I /usr/local/include/postgresql/server
+
+ # linker flags
+-LDFLAGS = -shared -L /usr/lib -L /usr/local/lib
++LDFLAGS += -shared
+
+ # additional linker flags for parts which depend on PostgreSQL
+ LDFLAGS_PGSQL =
+--- libraries/extos/Makefile.old 2013-03-13 21:49:19.710360750 +0100
++++ libraries/extos/Makefile 2013-03-13 21:49:47.778096460 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ extos.so: extos.o
+- $(LD) $(LDFLAGS) -lrt -lcrypt -o extos.$(SLIB_EXT) extos.o
++ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+ $(CC) -c $(CFLAGS) -o extos.o extos.c
+--- libraries/mondelefant/Makefile.old 2013-03-13 21:52:54.884250479 +0100
++++ libraries/mondelefant/Makefile 2013-03-13 21:53:27.511932686 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ mondelefant_native.so: mondelefant_native.o
+- $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq
++ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+ $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+--- libraries/multirand/Makefile.old 2013-03-13 21:54:29.399328173 +0100
++++ libraries/multirand/Makefile 2013-03-13 21:54:58.019048434 +0100
+@@ -1,7 +1,7 @@
+ include ../../Makefile.options
+
+ multirand.so: multirand.o
+- $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o
++ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+ $(CC) -c $(CFLAGS) -o multirand.o multirand.c
+--- libraries/extos/extos.c.old 2013-04-05 23:19:52.028115226 +0200
++++ libraries/extos/extos.c 2013-04-05 23:20:14.819896253 +0200
+@@ -12,6 +12,7 @@
+ #include <fcntl.h>
+ #include <poll.h>
+ #include <stdlib.h>
++#include <crypt.h>
+
+ #define EXTOS_MAX_ERRLEN 80
+ #define EXTOS_EXEC_MAX_ARGS 64
diff --git a/www-apps/webmcp/metadata.xml b/www-apps/webmcp/metadata.xml
new file mode 100644
index 000000000000..133931e024a5
--- /dev/null
+++ b/www-apps/webmcp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tupone@gentoo.org</email>
+<name>Alfredo Tupone</name>
+</maintainer>
+<longdescription lang="en">
+WebMCP is web application framework written in Lua and C. Instead of using the classical Model-View-Controller (MVC) concept, WebMCP makes use of a so-called Model-View-Action concept. The database is accessed through the Model layer, which provides an Object-Relational Mapping (ORM). HTTP-GET requests are handled by Views, which process the request data, query the database, and render the result. HTTP-POST requests are handled by Actions, which can write to the database and redirect to a View, dependent on success or failure.
+</longdescription>
+</pkgmetadata>
diff --git a/www-apps/webmcp/webmcp-1.2.5.ebuild b/www-apps/webmcp/webmcp-1.2.5.ebuild
new file mode 100644
index 000000000000..c14094283cbc
--- /dev/null
+++ b/www-apps/webmcp/webmcp-1.2.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/webmcp/webmcp-1.2.5.ebuild,v 1.1 2013/04/24 08:15:15 tupone Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="Web application framework written in Lua and C"
+HOMEPAGE="http://www.public-software-group.org/webmcp"
+SRC_URI="http://www.public-software-group.org/pub/projects/${PN}/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+KEYWORDS="~amd64"
+SLOT=0
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC)
+ # Dereference symlinks
+ cd framework
+ mkdir lib.link
+ mv lib/* lib.link
+ cp lib.link/* lib
+}
+
+src_install() {
+ into /usr/lib/${PN}
+ dolib.so framework/lib/*.so
+ for subdir in "" ".precompiled"; do
+ MY_DEST=/usr/lib/${PN}/framework${subdir}
+
+ cd framework${subdir}
+ exeinto ${MY_DEST}/accelerator
+ doexe accelerator/webmcp_accelerator.so
+ insinto ${MY_DEST}
+ doins -r env js
+ exeinto ${MY_DEST}/cgi-bin
+ doexe cgi-bin/webmcp*.lua
+ into ${MY_DEST}
+ dobin bin/*
+ insinto ${MY_DEST}/lib
+ doins lib/*.lua
+ cd ..
+
+ for file in extos.so mondelefant_native.so multirand.so; do
+ dosym ../../$(get_libdir)/$file ${MY_DEST}/lib/$file
+ done
+
+ insinto /usr/share/${PN}
+ doins -r demo-app${subdir}
+ done
+ dodoc doc/*sample.conf libraries/mondelefant/example.lua
+ dohtml doc/autodoc.html
+}