summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-10-23 10:29:38 +0000
committerRoy Marples <uberlord@gentoo.org>2006-10-23 10:29:38 +0000
commit33f79735950327e27575716e52ad3f6ae61fa9eb (patch)
tree812aff05f3cd9cdde6367ecdb04194dc284bba2a /www-apps/websvn
parentMask crypt useflag for cyrus-sasl. (diff)
downloadgentoo-2-33f79735950327e27575716e52ad3f6ae61fa9eb.tar.gz
gentoo-2-33f79735950327e27575716e52ad3f6ae61fa9eb.tar.bz2
gentoo-2-33f79735950327e27575716e52ad3f6ae61fa9eb.zip
Version bump, fixes #152450 thanks to Emanuele Gentili.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'www-apps/websvn')
-rw-r--r--www-apps/websvn/ChangeLog7
-rw-r--r--www-apps/websvn/files/digest-websvn-2.0_rc43
-rw-r--r--www-apps/websvn/websvn-2.0_rc4.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
index 9ab8447e355f..4026e25d2ed9 100644
--- a/www-apps/websvn/ChangeLog
+++ b/www-apps/websvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/websvn
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.14 2006/07/09 13:43:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.15 2006/10/23 10:29:38 uberlord Exp $
+
+*websvn-2.0_rc4 (23 Oct 2006)
+
+ 23 Oct 2006; Roy Marples <uberlord@gentoo.org> +websvn-2.0_rc4.ebuild:
+ Version bump, fixes #152450 thanks to Emanuele Gentili.
09 Jul 2006; Roy Marples <uberlord@gentoo.org> websvn-2.0_rc1.ebuild:
Use depend.php to work out if we have xml support, #139627
diff --git a/www-apps/websvn/files/digest-websvn-2.0_rc4 b/www-apps/websvn/files/digest-websvn-2.0_rc4
new file mode 100644
index 000000000000..75694a526adb
--- /dev/null
+++ b/www-apps/websvn/files/digest-websvn-2.0_rc4
@@ -0,0 +1,3 @@
+MD5 8a5938bad14021c61f0bbf06f7faf618 websvn-2.0rc4.tar.bz2 98840
+RMD160 3699883a3fbd8569fb9d7cb73034e1593b195c76 websvn-2.0rc4.tar.bz2 98840
+SHA256 4a5a1d2fed05eff091ff52ced3f94265c09fe30b5bb73038d3c92be3e2cff333 websvn-2.0rc4.tar.bz2 98840
diff --git a/www-apps/websvn/websvn-2.0_rc4.ebuild b/www-apps/websvn/websvn-2.0_rc4.ebuild
new file mode 100644
index 000000000000..b6eeef141992
--- /dev/null
+++ b/www-apps/websvn/websvn-2.0_rc4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.0_rc4.ebuild,v 1.1 2006/10/23 10:29:38 uberlord Exp $
+
+inherit depend.php eutils webapp
+
+MY_PV="${PV//_/}"
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/34307/websvn-${MY_PV}.tar.bz2"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="virtual/php
+ dev-util/subversion
+ sys-apps/sed
+ enscript? ( app-text/enscript )"
+
+S="${WORKDIR}/websvn-${MY_PV}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! has_version "=dev-lang/php-5*" ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-2.0_rc1"-pathinfo.patch
+}
+
+src_compile() {
+ mv "${S}"/include/distconfig.inc "${S}"/include/config.inc
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="changes.txt templates.txt"
+
+ dodoc ${docs}
+ for doc in ${docs} install.txt ; do
+ rm -f "${doc}"
+ done
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.inc
+
+ # This is the multiview config file
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ # The cache directory needs to be writeable
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}