summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-08-16 10:12:19 +0000
committerRoy Marples <uberlord@gentoo.org>2005-08-16 10:12:19 +0000
commit3b393fa26ec6d362a222daa3563da9f3eb0fda24 (patch)
treed35ee7dd4d14360d5b2342d1254a68d517ecbd51 /www-apps/websvn
parentUpdated HOMEPAGE, closing bug #101187 (diff)
downloadgentoo-2-3b393fa26ec6d362a222daa3563da9f3eb0fda24.tar.gz
gentoo-2-3b393fa26ec6d362a222daa3563da9f3eb0fda24.tar.bz2
gentoo-2-3b393fa26ec6d362a222daa3563da9f3eb0fda24.zip
Created a patch from the below user submitted patches to websvn
http://websvn.tigris.org/issues/show_bug.cgi?id=29 http://websvn.tigris.org/issues/show_bug.cgi?id=31 http://websvn.tigris.org/issues/show_bug.cgi?id=33 http://websvn.tigris.org/issues/show_bug.cgi?id=37 Fixes our #102675 (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/websvn')
-rw-r--r--www-apps/websvn/ChangeLog15
-rw-r--r--www-apps/websvn/files/digest-websvn-1.61-r11
-rw-r--r--www-apps/websvn/files/websvn-1.61-r1.patch118
-rw-r--r--www-apps/websvn/websvn-1.61-r1.ebuild57
4 files changed, 190 insertions, 1 deletions
diff --git a/www-apps/websvn/ChangeLog b/www-apps/websvn/ChangeLog
index 1ad4524e9ea2..47609887f0cf 100644
--- a/www-apps/websvn/ChangeLog
+++ b/www-apps/websvn/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for www-apps/websvn
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.4 2005/05/21 16:46:06 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/ChangeLog,v 1.5 2005/08/16 10:12:19 uberlord Exp $
+
+*websvn-1.61-r1 (16 Aug 2005)
+
+ 16 Aug 2005; Roy Marples <uberlord@gentoo.org>
+ +files/websvn-1.61-r1.patch, +websvn-1.61-r1.ebuild:
+ Created a patch from the below user submitted patches to websvn
+
+ http://websvn.tigris.org/issues/show_bug.cgi?id=29
+ http://websvn.tigris.org/issues/show_bug.cgi?id=31
+ http://websvn.tigris.org/issues/show_bug.cgi?id=33
+ http://websvn.tigris.org/issues/show_bug.cgi?id=37
+
+ Fixes our #102675
21 May 2005; Simon Stelling <blubb@gentoo.org> websvn-1.61.ebuild:
added ~amd64 keyword
diff --git a/www-apps/websvn/files/digest-websvn-1.61-r1 b/www-apps/websvn/files/digest-websvn-1.61-r1
new file mode 100644
index 000000000000..9a1a0b280f50
--- /dev/null
+++ b/www-apps/websvn/files/digest-websvn-1.61-r1
@@ -0,0 +1 @@
+MD5 9f81a3793d08bde2e425d2c98f923875 WebSVN_161.tar.gz 89305
diff --git a/www-apps/websvn/files/websvn-1.61-r1.patch b/www-apps/websvn/files/websvn-1.61-r1.patch
new file mode 100644
index 000000000000..327b12c96ac7
--- /dev/null
+++ b/www-apps/websvn/files/websvn-1.61-r1.patch
@@ -0,0 +1,118 @@
+This patchset applies the patches at the below urls
+
+http://websvn.tigris.org/issues/show_bug.cgi?id=29
+http://websvn.tigris.org/issues/show_bug.cgi?id=31
+http://websvn.tigris.org/issues/show_bug.cgi?id=33
+http://websvn.tigris.org/issues/show_bug.cgi?id=37
+
+--- include/feedcreator.class.php.orig 2004-06-24 03:14:52.000000000 -0400
++++ include/feedcreator.class.php 2005-05-06 09:57:15.000000000 -0400
+@@ -122,11 +122,6 @@
+ * A little setup *
+ **************************************************************************/
+
+-// your local timezone, set to "" to disable or for GMT
+-define("TIME_ZONE","+01:00");
+-
+-
+-
+
+ /**
+ * Version string.
+@@ -588,10 +583,7 @@
+ * @return a date in RFC 822 format
+ */
+ function rfc822() {
+- //return gmdate("r",$this->unix);
+- $date = gmdate("D, d M Y H:i:s", $this->unix);
+- if (TIME_ZONE!="") $date .= " ".str_replace(":","",TIME_ZONE);
+- return $date;
++ return gmdate("r",$this->unix);
+ }
+
+ /**
+@@ -602,7 +594,6 @@
+ function iso8601() {
+ $date = gmdate("Y-m-d\TH:i:sO",$this->unix);
+ $date = substr($date,0,22) . ':' . substr($date,-2);
+- if (TIME_ZONE!="") $date = str_replace("+00:00",TIME_ZONE,$date);
+ return $date;
+ }
+
+--- include/svnlook.inc.orig 2005-01-07 11:26:06.000000000 -0500
++++ include/svnlook.inc 2005-05-09 19:42:52.000000000 -0400
+@@ -188,20 +188,10 @@
+ // Remove the offset to get the time in GMT
+ $h -= $offset / 100;
+
+- // Get the commit time as seconds. Note that the mktime function assumes that the time being
+- // passed to it is a local time - it will therefore subtract/add the required number of hours
+- // to make it GMT. Since we already have the time in GMT we first add the localtime offset to
+- // get the commit time in local time. The offset calculated above already handles the summer
+- // time case, so we tell mktime not to take this into account.
+-
+- $lt = gettimeofday();
+- $minwest = $lt["minuteswest"];
+- $committime = mktime($h ,$m - $minwest, $s, $mo, $d, $y, 0);
++ $committime = gmmktime($h ,$m, $s, $mo, $d, $y, -1);
+ $log["committime"] = $committime;
+
+- // Get the current time (as GMT)
+- $t = localtime(time(), 1);
+- $curtime = mktime($t["tm_hour"], $t["tm_min"], $t["tm_sec"], $t["tm_mon"] + 1, $t["tm_mday"], $t["tm_year"] + 1900, $t["tm_isdst"]);
++ $curtime = time();
+
+ // Get the number of seconds since the commit
+ $agesecs = $curtime - $committime;
+--- include/configclass.inc.orig 2005-05-26 21:25:25.000000000 -0400
++++ include/configclass.inc 2005-05-26 21:24:53.000000000 -0400
+@@ -402,7 +402,7 @@
+ if ($rep == -1)
+ return $fname."?path=".urlencode($path)."&amp;";
+ else
+- return $fname."?repname=".$rep->name."&amp;path=".urlencode($path)."&amp;";
++ return $fname."?repname=".urlencode($rep->name)."&amp;path=".urlencode($path)."&amp;";
+ }
+ }
+
+--- include/configclass.inc.orig 2005-08-16 10:00:42.000000000 +0100
++++ include/configclass.inc 2005-08-16 10:02:01.000000000 +0100
+@@ -339,8 +339,11 @@
+
+ if ($this->multiViews)
+ {
+- // Remove the .php
+- $base = substr($base, 0, -4);
++ if ( eregi(".php$", $base) )
++ {
++ // Remove the .php
++ $base = substr($base, 0, -4);
++ }
+
+ if ($path && $path{0} != "/") $path = "/".$path;
+
+Index: log.php
+===================================================================
+--- log.php (revision 328)
++++ log.php (working copy)
+@@ -199,16 +199,17 @@
+ $parent = substr($rpath, 0, $pos + 1);
+
+ $url = $config->getURL($rep, $parent, "dir");
+- $listing[$index]["compare_box"] = "<input type=\"checkbox\" name=\"compare[]\" value=\"$parent@${r["rev"]}\" onClick=\"checkCB(this)\">";
+ $listing[$index]["revlink"] = "<a href=\"${url}rev=${r["rev"]}&amp;sc=1\">${r["rev"]}</a>";
+
+ if ($isDir)
+- {
++ {
++ $listing[$index]["compare_box"] = "<input type=\"checkbox\" name=\"compare[]\" value=\"$parent@${r["rev"]}\" onClick=\"checkCB(this)\">";
+ $url = $config->getURL($rep, $rpath, "dir");
+ $listing[$index]["revpathlink"] = "<a href=\"${url}rev=${r["rev"]}&amp;sc=$showchanged\">$rpath</a>";
+ }
+ else
+- {
++ {
++ $listing[$index]["compare_box"] = "<input type=\"checkbox\" name=\"compare[]\" value=\"$rpath@${r["rev"]}\" onClick=\"checkCB(this)\">";
+ $url = $config->getURL($rep, $rpath, "file");
+ $listing[$index]["revpathlink"] = "<a href=\"${url}rev=${r["rev"]}&amp;sc=$showchanged\">$rpath</a>";
+ }
diff --git a/www-apps/websvn/websvn-1.61-r1.ebuild b/www-apps/websvn/websvn-1.61-r1.ebuild
new file mode 100644
index 000000000000..80a9c0afa386
--- /dev/null
+++ b/www-apps/websvn/websvn-1.61-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-1.61-r1.ebuild,v 1.1 2005/08/16 10:12:19 uberlord Exp $
+
+inherit eutils webapp
+
+MY_PV="161"
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/14334/WebSVN_${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND=">=dev-php/mod_php-4.1.0
+ sys-apps/sed
+ enscript? ( >=app-text/enscript-1.6.0 )"
+DEPEND="sys-apps/findutils"
+
+S="${WORKDIR}/WebSVN"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/websvn-1.61-r1.patch"
+}
+
+src_compile() {
+ mv "${S}/include/distconfig.inc" "${S}/include/config.inc"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="changes.txt install.txt templates.txt"
+
+ dodoc ${docs}
+ for doc in ${docs}; do
+ rm -f "${doc}"
+ done
+
+ # Remove .cvs* files and CVS directories
+ find -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+ webapp_configfile "${MY_HTDOCSDIR}/include/config.inc"
+
+ # This is the multiview config file
+ webapp_configfile "${MY_HTDOCSDIR}/wsvn.php"
+
+ # The cache directory needs to be writeable
+ webapp_serverowned "${MY_HTDOCSDIR}/cache"
+
+ webapp_src_install
+}