summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Kulbe <superlag@gentoo.org>2006-07-30 02:48:33 +0000
committerAaron Kulbe <superlag@gentoo.org>2006-07-30 02:48:33 +0000
commitbf41d26fb77e4cc599a849b55f0b5cb1bd88e6e3 (patch)
tree4400b4d2b6b2d1d111f9c38d45512954753830b5 /www-apps/wordpress
parentold (diff)
downloadgentoo-2-bf41d26fb77e4cc599a849b55f0b5cb1bd88e6e3.tar.gz
gentoo-2-bf41d26fb77e4cc599a849b55f0b5cb1bd88e6e3.tar.bz2
gentoo-2-bf41d26fb77e4cc599a849b55f0b5cb1bd88e6e3.zip
Version bump wrt Bug #142142.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/ChangeLog7
-rw-r--r--www-apps/wordpress/files/digest-wordpress-2.0.43
-rw-r--r--www-apps/wordpress/wordpress-2.0.4.ebuild95
3 files changed, 104 insertions, 1 deletions
diff --git a/www-apps/wordpress/ChangeLog b/www-apps/wordpress/ChangeLog
index 12d8bbe4d900..3b5fd4510843 100644
--- a/www-apps/wordpress/ChangeLog
+++ b/www-apps/wordpress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/wordpress
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.53 2006/06/15 05:46:38 superlag Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.54 2006/07/30 02:48:33 superlag Exp $
+
+*wordpress-2.0.4 (30 Jul 2006)
+
+ 30 Jul 2006; Aaron Kulbe <superlag@gentoo.org> +wordpress-2.0.4.ebuild:
+ Version bump wrt Bug #142142
15 Jun 2006; Aaron Kulbe <superlag@gentoo.org> -wordpress-2.0.1.ebuild,
-wordpress-2.0.2.ebuild, wordpress-2.0.3.ebuild:
diff --git a/www-apps/wordpress/files/digest-wordpress-2.0.4 b/www-apps/wordpress/files/digest-wordpress-2.0.4
new file mode 100644
index 000000000000..fb4765bd9d92
--- /dev/null
+++ b/www-apps/wordpress/files/digest-wordpress-2.0.4
@@ -0,0 +1,3 @@
+MD5 0de8e4b2051ce9313a23d7726210d5e3 wordpress-2.0.4.tar.gz 508231
+RMD160 b864202b3eb139170c174f9f8ad404efd9422d83 wordpress-2.0.4.tar.gz 508231
+SHA256 e3ca99e0a6c53dbefb806973384887e829a7987fc52187c21752b0b5fc29c1c3 wordpress-2.0.4.tar.gz 508231
diff --git a/www-apps/wordpress/wordpress-2.0.4.ebuild b/www-apps/wordpress/wordpress-2.0.4.ebuild
new file mode 100644
index 000000000000..9f3010d05ef0
--- /dev/null
+++ b/www-apps/wordpress/wordpress-2.0.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.0.4.ebuild,v 1.1 2006/07/30 02:48:33 superlag Exp $
+
+inherit webapp eutils
+
+#Wordpress releases have a release name tagged on the end of the version on the tar.gz files
+#MY_EXT="mingus"
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+#Latest version is only available in the format!
+#Download is renamed by HTTP Header as wordpress-<version number>.tar.gz
+SRC_URI=mirror://gentoo/${P}.tar.gz
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND="virtual/httpd-php
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+# no patch needed anymore
+# epatch ${FILESDIR}/${PV}/login-patch.diff
+}
+
+src_install() {
+ local docs="license.txt readme.html"
+
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp -r * ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ ewarn
+ ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+ ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+ ewarn php_flag register_globals off
+ ewarn
+
+ ewarn
+ ewarn You will need to create a table for your WordPress database. This
+ ewarn assumes you have some knowledge of MySQL, and already have it
+ ewarn installed and configured. If not, please refer to
+ ewarn the Gentoo MySQL guide at the following URL:
+ ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+ ewarn Log in to MySQL, and create a new database called
+ ewarn "wordpress". From this point, you will need to edit
+ ewarn your wp-config.php file in $DocumentRoot/wordpress/
+ ewarn and point to your database. Once this is done, you can log in to
+ ewarn WordPress at http://localhost/wordpress
+ ewarn
+
+ ewarn
+ ewarn If you are upgrading from a previous version BACK UP your
+ ewarn database. Once you are done with that, browse to
+ ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+ ewarn the instructions on the screen.
+ ewarn
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/index.php
+ #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for wordpress, we *assume* that all .php files need to have CGI/BIN
+ # support added
+
+ # post-install instructions
+ #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+
+}