summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-04-25 03:02:38 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-04-25 03:02:38 +0000
commit11f8c5e63887b2d7e3efd33ee3905dbc320e9d7f (patch)
treeefbfbad99c0e23ed603cf2172dd62b4b675bd903 /www-apps
parentAccording to ftp://download.nvidia.com/XFree86/Linux-x86/295.40/README/suppor... (diff)
downloadgentoo-2-11f8c5e63887b2d7e3efd33ee3905dbc320e9d7f.tar.gz
gentoo-2-11f8c5e63887b2d7e3efd33ee3905dbc320e9d7f.tar.bz2
gentoo-2-11f8c5e63887b2d7e3efd33ee3905dbc320e9d7f.zip
Version bump. Removed old. Synced release ebuild with live ebuild.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/blohg/ChangeLog8
-rw-r--r--www-apps/blohg/blohg-0.10.ebuild (renamed from www-apps/blohg/blohg-0.9.2.ebuild)33
-rw-r--r--www-apps/blohg/blohg-0.8.ebuild58
-rw-r--r--www-apps/blohg/blohg-9999.ebuild39
4 files changed, 59 insertions, 79 deletions
diff --git a/www-apps/blohg/ChangeLog b/www-apps/blohg/ChangeLog
index abaeb40b4c8e..f7177952efe8 100644
--- a/www-apps/blohg/ChangeLog
+++ b/www-apps/blohg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/blohg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.16 2012/04/06 00:15:43 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.17 2012/04/25 03:02:38 rafaelmartins Exp $
+
+*blohg-0.10 (25 Apr 2012)
+
+ 25 Apr 2012; Rafael G. Martins <rafaelmartins@gentoo.org> -blohg-0.8.ebuild,
+ -blohg-0.9.2.ebuild, +blohg-0.10.ebuild, blohg-9999.ebuild:
+ Version bump. Removed old. Synced release ebuild with live ebuild.
*blohg-0.9.2 (06 Apr 2012)
diff --git a/www-apps/blohg/blohg-0.9.2.ebuild b/www-apps/blohg/blohg-0.10.ebuild
index 81574d840f4e..f45b27e0d9ea 100644
--- a/www-apps/blohg/blohg-0.9.2.ebuild
+++ b/www-apps/blohg/blohg-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.9.2.ebuild,v 1.1 2012/04/06 00:15:43 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.10.ebuild,v 1.1 2012/04/25 03:02:38 rafaelmartins Exp $
EAPI="3"
@@ -9,19 +9,31 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
DISTUTILS_SRC_TEST="setup.py"
-inherit distutils
+HG_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ HG_ECLASS="mercurial"
+ EHG_REPO_URI="https://hg.rafaelmartins.eng.br/blohg/"
+ EHG_REVISION="default"
+fi
+
+inherit distutils ${HG_ECLASS}
DESCRIPTION="A Mercurial-based blogging engine."
HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
+
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
LICENSE="GPL-2"
SLOT="0"
IUSE="doc test"
-DEPEND=">=dev-python/docutils-0.7
- >=dev-python/flask-0.8
+CDEPEND=">=dev-python/docutils-0.7
+ >=dev-python/flask-0.7
>=dev-python/flask-babel-0.6
>=dev-python/flask-script-0.3
>=dev-python/frozen-flask-0.7
@@ -29,10 +41,12 @@ DEPEND=">=dev-python/docutils-0.7
>=dev-vcs/mercurial-1.6
dev-python/pyyaml
dev-python/setuptools
- dev-python/pygments
+ dev-python/pygments"
+
+DEPEND="${CDEPEND}
doc? ( dev-python/sphinx )"
-RDEPEND="${DEPEND}"
+RDEPEND="${CDEPEND}"
src_compile() {
distutils_src_compile
@@ -53,8 +67,9 @@ src_install() {
}
pkg_postinst() {
- distutils_pkg_postinst
+ local ver="${PV}"
+ [[ ${PV} = *9999* ]] && ver="latest"
- einfo "If you're upgrading from <=blohg-0.5.1, please read the upgrade notes:"
- einfo "http://docs.blohg.org/upgrade/#from-0-5-1-to-0-6"
+ elog "You may want to check the upgrade notes:"
+ elog "http://docs.blohg.org/en/${ver}/upgrade/"
}
diff --git a/www-apps/blohg/blohg-0.8.ebuild b/www-apps/blohg/blohg-0.8.ebuild
deleted file mode 100644
index 947fd69ea776..000000000000
--- a/www-apps/blohg/blohg-0.8.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.8.ebuild,v 1.1 2011/11/17 00:38:16 rafaelmartins Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
-
-inherit distutils
-
-DESCRIPTION="A Mercurial-based blogging engine."
-HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-
-DEPEND=">=dev-python/docutils-0.7
- >=dev-python/flask-0.7
- >=dev-python/flask-babel-0.6
- >=dev-python/flask-script-0.3
- >=dev-python/jinja-2.5.2
- >=dev-vcs/mercurial-1.6
- dev-python/pyyaml
- dev-python/setuptools
- dev-python/pygments
- doc? ( dev-python/sphinx )"
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo 'building documentation'
- emake -C docs html
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- einfo 'installing documentation'
- dohtml -r docs/_build/html/*
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "If you're upgrading from <=blohg-0.5.1, please read the upgrade notes:"
- einfo "http://docs.blohg.org/upgrade/#from-0-5-1-to-0-6"
-}
diff --git a/www-apps/blohg/blohg-9999.ebuild b/www-apps/blohg/blohg-9999.ebuild
index 0e160ac78951..7d6affdcd320 100644
--- a/www-apps/blohg/blohg-9999.ebuild
+++ b/www-apps/blohg/blohg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-9999.ebuild,v 1.7 2012/01/08 13:50:14 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-9999.ebuild,v 1.8 2012/04/25 03:02:38 rafaelmartins Exp $
EAPI="3"
@@ -9,21 +9,30 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
DISTUTILS_SRC_TEST="setup.py"
-EHG_REPO_URI="http://hg.rafaelmartins.eng.br/blohg/"
-EHG_REVISION="default"
+HG_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ HG_ECLASS="mercurial"
+ EHG_REPO_URI="https://hg.rafaelmartins.eng.br/blohg/"
+ EHG_REVISION="default"
+fi
-inherit mercurial distutils
+inherit distutils ${HG_ECLASS}
DESCRIPTION="A Mercurial-based blogging engine."
HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
-SRC_URI=""
-KEYWORDS=""
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
LICENSE="GPL-2"
SLOT="0"
IUSE="doc test"
-DEPEND=">=dev-python/docutils-0.7
+CDEPEND=">=dev-python/docutils-0.7
>=dev-python/flask-0.7
>=dev-python/flask-babel-0.6
>=dev-python/flask-script-0.3
@@ -32,12 +41,12 @@ DEPEND=">=dev-python/docutils-0.7
>=dev-vcs/mercurial-1.6
dev-python/pyyaml
dev-python/setuptools
- dev-python/pygments
- doc? ( dev-python/sphinx )"
+ dev-python/pygments"
-RDEPEND="${DEPEND}"
+DEPEND="${CDEPEND}
+ doc? ( dev-python/sphinx )"
-S="${WORKDIR}/${PN}"
+RDEPEND="${CDEPEND}"
src_compile() {
distutils_src_compile
@@ -56,3 +65,11 @@ src_install() {
dohtml -r docs/_build/html/*
fi
}
+
+pkg_postinst() {
+ local ver="${PV}"
+ [[ ${PV} = *9999* ]] && ver="latest"
+
+ elog "You may want to check the upgrade notes:"
+ elog "http://docs.blohg.org/en/${ver}/upgrade/"
+}