summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-20 17:05:14 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-20 17:05:14 +0000
commit44f55661f613c834ebc5f8155df40935a2610bcd (patch)
tree4922c17b3eb4ef1150b91230503c89e16ffbc6e3 /www-apps
parentVersion bump. (diff)
downloadgentoo-2-44f55661f613c834ebc5f8155df40935a2610bcd.tar.gz
gentoo-2-44f55661f613c834ebc5f8155df40935a2610bcd.tar.bz2
gentoo-2-44f55661f613c834ebc5f8155df40935a2610bcd.zip
Version bump (#130165).
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpBB/ChangeLog9
-rw-r--r--www-apps/phpBB/files/digest-phpBB-2.0.203
-rw-r--r--www-apps/phpBB/files/postinstall-en.txt3
-rw-r--r--www-apps/phpBB/phpBB-2.0.20.ebuild38
4 files changed, 52 insertions, 1 deletions
diff --git a/www-apps/phpBB/ChangeLog b/www-apps/phpBB/ChangeLog
index 392a53679b84..e255dac1e2df 100644
--- a/www-apps/phpBB/ChangeLog
+++ b/www-apps/phpBB/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/phpBB
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.21 2006/01/03 11:10:20 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.22 2006/04/20 17:05:13 rl03 Exp $
+
+*phpBB-2.0.20 (20 Apr 2006)
+
+ 20 Apr 2006; Renat Lumpau <rl03@gentoo.org>
+ -files/2.0.19-postinstall-en.txt, +files/postinstall-en.txt,
+ -phpBB-2.0.19.ebuild, +phpBB-2.0.20.ebuild:
+ Version bump (#130165).
*phpBB-2.0.19 (03 Jan 2006)
diff --git a/www-apps/phpBB/files/digest-phpBB-2.0.20 b/www-apps/phpBB/files/digest-phpBB-2.0.20
new file mode 100644
index 000000000000..0a7cecc14511
--- /dev/null
+++ b/www-apps/phpBB/files/digest-phpBB-2.0.20
@@ -0,0 +1,3 @@
+MD5 195d199f7ce766bc6d522e0e9a3cb74d phpBB-2.0.20.tar.bz2 452282
+RMD160 a99ce2271034c7ffa13d7a5660fbc5fa6eb65222 phpBB-2.0.20.tar.bz2 452282
+SHA256 a269090b6f2ed8f003189b4d6c9db915b828eab3f9cf2ade619220cfebf93fe7 phpBB-2.0.20.tar.bz2 452282
diff --git a/www-apps/phpBB/files/postinstall-en.txt b/www-apps/phpBB/files/postinstall-en.txt
new file mode 100644
index 000000000000..9f15e7a444b1
--- /dev/null
+++ b/www-apps/phpBB/files/postinstall-en.txt
@@ -0,0 +1,3 @@
+Please use install/install.php to configure a new install of phpBB.
+Use install/update_to_latest.php to upgrade your existing version.
+After that, please delete the contribs/ and install/ directories
diff --git a/www-apps/phpBB/phpBB-2.0.20.ebuild b/www-apps/phpBB/phpBB-2.0.20.ebuild
new file mode 100644
index 000000000000..8f05c8dce4e0
--- /dev/null
+++ b/www-apps/phpBB/phpBB-2.0.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-2.0.20.ebuild,v 1.1 2006/04/20 17:05:14 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="phpBB is an open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://www.phpbb.com/files/releases/${P}.tar.bz2
+ mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+RDEPEND="virtual/httpd-php"
+
+S=${WORKDIR}/${PN}2
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ${S}/docs/*
+
+ cp -pPR * "${D}/${MY_HTDOCSDIR}"
+ rm -rf ${D}/${MY_HTDOCSDIR}/docs
+
+ echo "<?php trigger_error('Please use install/install.php to configure phpBB for your system!', E_USER_ERROR); ?>" > "${D}/${MY_HTDOCSDIR}/config.php"
+ webapp_serverowned "${MY_HTDOCSDIR}/config.php"
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ webapp_serverowned ${MY_HTDOCSDIR}/images/avatars
+ webapp_serverowned ${MY_HTDOCSDIR}/images/avatars/gallery
+ webapp_serverowned ${MY_HTDOCSDIR}/language
+ webapp_serverowned ${MY_HTDOCSDIR}/templates
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}