summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-09-07 14:41:57 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-09-07 14:41:57 +0000
commite1e486a88d78790d5e7972356bf3d37a3448db3f (patch)
tree33e0cc6aba95d48f2d7fa3bbf88abd2f909a7230 /www-apps
parenteinfo to elog transition (diff)
downloadgentoo-2-e1e486a88d78790d5e7972356bf3d37a3448db3f.tar.gz
gentoo-2-e1e486a88d78790d5e7972356bf3d37a3448db3f.tar.bz2
gentoo-2-e1e486a88d78790d5e7972356bf3d37a3448db3f.zip
Added gallery-2.2.3 to the tree in response to sec bug #191587.
(Portage version: 2.1.2.12)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/ChangeLog7
-rw-r--r--www-apps/gallery/files/digest-gallery-2.2.33
-rw-r--r--www-apps/gallery/gallery-2.2.3.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index ef4707882076..2ff36beff655 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.115 2007/07/29 17:27:25 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.116 2007/09/07 14:41:56 wrobel Exp $
+
+*gallery-2.2.3 (07 Sep 2007)
+
+ 07 Sep 2007; <wrobel@gentoo.org> +gallery-2.2.3.ebuild:
+ Added gallery-2.2.3 to the tree in response to sec bug #191587.
29 Jul 2007; Christian Heim <phreak@gentoo.org> gallery-1.5.3.ebuild,
gallery-1.5.5.ebuild:
diff --git a/www-apps/gallery/files/digest-gallery-2.2.3 b/www-apps/gallery/files/digest-gallery-2.2.3
new file mode 100644
index 000000000000..a0c95ec702c4
--- /dev/null
+++ b/www-apps/gallery/files/digest-gallery-2.2.3
@@ -0,0 +1,3 @@
+MD5 df5c1a6ecbf0b498417ceffc66fe5f3b gallery-2.2.3-full.tar.gz 11901089
+RMD160 1ae6474c48a7374540ff3f3b46d4d6c5cb34cb24 gallery-2.2.3-full.tar.gz 11901089
+SHA256 ce7d9c1c4497954e1828047be25b31c3a271b5c86c0c97bbc652b3746aa1b364 gallery-2.2.3-full.tar.gz 11901089
diff --git a/www-apps/gallery/gallery-2.2.3.ebuild b/www-apps/gallery/gallery-2.2.3.ebuild
new file mode 100644
index 000000000000..bf7b4959efd4
--- /dev/null
+++ b/www-apps/gallery/gallery-2.2.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.3.ebuild,v 1.1 2007/09/07 14:41:56 wrobel Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dcraw ffmpeg gd imagemagick mysql netpbm postgres unzip zip"
+
+RDEPEND="
+ media-libs/jpeg
+ dcraw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ gd? ( >=media-libs/gd-2 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+"
+
+S=${WORKDIR}/${PN}2
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ local php_flags="pcre session"
+ local DIE=
+
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags}; then
+ DIE="yes"
+ fi
+ if use gd; then
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ DIE="yes"
+ fi
+ fi
+
+ if [[ ${DIE} == "yes" ]]; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ if use gd; then
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "gd gd-external"
+ eerror
+ fi
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R * ${D}/${MY_HTDOCSDIR}
+ dohtml README.html
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en2.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}