summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-07-16 09:26:24 +0000
committerChristian Parpart <trapni@gentoo.org>2005-07-16 09:26:24 +0000
commitfe710427972e7a4d6d608c6641cecf3c50893538 (patch)
tree2d945155f50290876734d58fe43ae4425e9be864 /www-apps
parentcleaner (diff)
downloadgentoo-2-fe710427972e7a4d6d608c6641cecf3c50893538.tar.gz
gentoo-2-fe710427972e7a4d6d608c6641cecf3c50893538.tar.bz2
gentoo-2-fe710427972e7a4d6d608c6641cecf3c50893538.zip
cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mediawiki/Manifest5
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.0.ebuild114
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.0_rc1.ebuild114
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.1.ebuild114
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.2.ebuild114
-rw-r--r--www-apps/mediawiki/mediawiki-1.4.3.ebuild114
6 files changed, 0 insertions, 575 deletions
diff --git a/www-apps/mediawiki/Manifest b/www-apps/mediawiki/Manifest
index 86fb04433cc2..64678115390e 100644
--- a/www-apps/mediawiki/Manifest
+++ b/www-apps/mediawiki/Manifest
@@ -1,11 +1,6 @@
MD5 091c6d680f84099e227dc1968468cb0e ChangeLog 3571
MD5 9b808d7d4184d4e1c6e4dc157b12e159 mediawiki-1.3.11.ebuild 2899
MD5 e680f264ec262a15045a77a124a4009e mediawiki-1.3.12.ebuild 2899
-MD5 b215144f988569d3dbe184a36c8e8454 mediawiki-1.4.0.ebuild 2783
-MD5 b29637f11785b5fcd20652ea276ac6f2 mediawiki-1.4.0_rc1.ebuild 2783
-MD5 3450e5d30b1da713ff6e5528ce9ad2b0 mediawiki-1.4.1.ebuild 2783
-MD5 fd7c4e61967a81880fd72c08c64a6bd5 mediawiki-1.4.2.ebuild 2783
-MD5 fb69538222d4272080ef89f8ee490df1 mediawiki-1.4.3.ebuild 2783
MD5 f50afab86724625e0c724143fccbfcb5 mediawiki-1.4.4.ebuild 2781
MD5 0e201daa491640c742b312e06075cbc5 metadata.xml 225
MD5 1ecb081f1c270870be038f4bf733f298 mediawiki-1.3.13.ebuild 2899
diff --git a/www-apps/mediawiki/mediawiki-1.4.0.ebuild b/www-apps/mediawiki/mediawiki-1.4.0.ebuild
deleted file mode 100644
index 4df65645bfd2..000000000000
--- a/www-apps/mediawiki/mediawiki-1.4.0.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.0.ebuild,v 1.3 2005/05/04 22:13:51 trapni Exp $
-
-inherit webapp
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="imagemagick math"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="virtual/php
- >=dev-db/mysql-4
- math? ( virtual/tetex
- app-text/ghostscript
- media-gfx/imagemagick )
- imagemagick? ( media-gfx/imagemagick )"
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS="
- config
- extensions
- images
- includes
- includes/normal
- includes/templates
- includes/zhtable
- irc
- languages
- maintenance
- maintenance/archives
- maintenance/postgresql
- skins
- skins/amethyst
- skins/chick
- skins/common
- skins/common/images
- skins/disabled
- skins/monobook
- skins/myskin
- "
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
- for DOC in ${DOCS}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.doc
- rm -f docs/*.doc
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
- webapp_src_install
-}
diff --git a/www-apps/mediawiki/mediawiki-1.4.0_rc1.ebuild b/www-apps/mediawiki/mediawiki-1.4.0_rc1.ebuild
deleted file mode 100644
index b53c1bdf1954..000000000000
--- a/www-apps/mediawiki/mediawiki-1.4.0_rc1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.0_rc1.ebuild,v 1.1 2005/02/21 19:33:36 trapni Exp $
-
-inherit webapp
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
-IUSE="imagemagick math"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="virtual/php
- >=dev-db/mysql-4
- math? ( app-text/tetex
- app-text/ghostscript
- media-gfx/imagemagick )
- imagemagick? ( media-gfx/imagemagick )"
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS="
- config
- extensions
- images
- includes
- includes/normal
- includes/templates
- includes/zhtable
- irc
- languages
- maintenance
- maintenance/archives
- maintenance/postgresql
- skins
- skins/amethyst
- skins/chick
- skins/common
- skins/common/images
- skins/disabled
- skins/monobook
- skins/myskin
- "
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
- for DOC in ${DOCS}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.doc
- rm -f docs/*.doc
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
- webapp_src_install
-}
diff --git a/www-apps/mediawiki/mediawiki-1.4.1.ebuild b/www-apps/mediawiki/mediawiki-1.4.1.ebuild
deleted file mode 100644
index 1a081692827b..000000000000
--- a/www-apps/mediawiki/mediawiki-1.4.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.1.ebuild,v 1.2 2005/05/04 22:13:51 trapni Exp $
-
-inherit webapp
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="imagemagick math"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="virtual/php
- >=dev-db/mysql-4
- math? ( virtual/tetex
- app-text/ghostscript
- media-gfx/imagemagick )
- imagemagick? ( media-gfx/imagemagick )"
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS="
- config
- extensions
- images
- includes
- includes/normal
- includes/templates
- includes/zhtable
- irc
- languages
- maintenance
- maintenance/archives
- maintenance/postgresql
- skins
- skins/amethyst
- skins/chick
- skins/common
- skins/common/images
- skins/disabled
- skins/monobook
- skins/myskin
- "
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
- for DOC in ${DOCS}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.doc
- rm -f docs/*.doc
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
- webapp_src_install
-}
diff --git a/www-apps/mediawiki/mediawiki-1.4.2.ebuild b/www-apps/mediawiki/mediawiki-1.4.2.ebuild
deleted file mode 100644
index 0eebc3f2bd98..000000000000
--- a/www-apps/mediawiki/mediawiki-1.4.2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.2.ebuild,v 1.2 2005/05/04 22:13:51 trapni Exp $
-
-inherit webapp
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="imagemagick math"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="virtual/php
- >=dev-db/mysql-4
- math? ( virtual/tetex
- app-text/ghostscript
- media-gfx/imagemagick )
- imagemagick? ( media-gfx/imagemagick )"
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS="
- config
- extensions
- images
- includes
- includes/normal
- includes/templates
- includes/zhtable
- irc
- languages
- maintenance
- maintenance/archives
- maintenance/postgresql
- skins
- skins/amethyst
- skins/chick
- skins/common
- skins/common/images
- skins/disabled
- skins/monobook
- skins/myskin
- "
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
- for DOC in ${DOCS}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.doc
- rm -f docs/*.doc
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
- webapp_src_install
-}
diff --git a/www-apps/mediawiki/mediawiki-1.4.3.ebuild b/www-apps/mediawiki/mediawiki-1.4.3.ebuild
deleted file mode 100644
index 553ebc25cadf..000000000000
--- a/www-apps/mediawiki/mediawiki-1.4.3.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mediawiki/mediawiki-1.4.3.ebuild,v 1.1 2005/05/04 22:13:51 trapni Exp $
-
-inherit webapp
-
-DESCRIPTION="The MediaWiki wiki web application (as used on wikipedia.org)"
-HOMEPAGE="http://www.mediawiki.org"
-SRC_URI="mirror://sourceforge/wikipedia/${P/.0_/}.tar.gz"
-RESTRICT="nomirror"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="imagemagick math"
-
-S="${WORKDIR}/${P/.0_/}"
-
-DEPEND="math? ( >=dev-lang/ocaml-3.0.6 )"
-
-RDEPEND="virtual/php
- >=dev-db/mysql-4
- math? ( virtual/tetex
- app-text/ghostscript
- media-gfx/imagemagick )
- imagemagick? ( media-gfx/imagemagick )"
-
-src_compile() {
- if use math; then
- einfo "Compiling math support"
- cd math || die
- emake || die
- else
- einfo "No math support enabled. Skipping."
- fi
-
- # TODO: think about includes/zhtable/ support
-}
-
-src_install() {
- webapp_src_preinst
-
- # copy the app's main files excluding math support, docs, and tests
- local DIRS="
- config
- extensions
- images
- includes
- includes/normal
- includes/templates
- includes/zhtable
- irc
- languages
- maintenance
- maintenance/archives
- maintenance/postgresql
- skins
- skins/amethyst
- skins/chick
- skins/common
- skins/common/images
- skins/disabled
- skins/monobook
- skins/myskin
- "
- insinto ${MY_HTDOCSDIR}
- doins *.php *.inc *.phtml
- for DIR in ${DIRS}; do
- dodir ${MY_HTDOCSDIR}/${DIR}
- insinto ${MY_HTDOCSDIR}/${DIR}
- doins ${DIR}/*
- test -f ${DIR}/.htaccess && doins ${DIR}/.htaccess
- done
-
- # installing some docs
- local DOCS="AdminSettings.sample COPYING FAQ HISTORY INSTALL README RELEASE-NOTES UPGRADE"
- for DOC in ${DOCS}; do
- dodoc "${DOC}"
- rm -f "${DOC}"
- done
- dodoc docs/*.doc
- rm -f docs/*.doc
-
- docinto php-memcached
- dodoc docs/php-memcached/*
-
- # If imagemagick is enabled then setup for image upload.
- # We ensure the directory is prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use imagemagick; then
- webapp_serverowned ${MY_HTDOCSDIR}/images
- fi
-
- # If we've enabled math USE-flag, install math support.
- # We ensure the directories are prepared for writing. The post-
- # install instructions guide the user to enable the feature.
- if use math; then
- einfo "Installing math support"
- dodir ${MY_HTDOCSDIR}/math
- exeinto ${MY_HTDOCSDIR}/math
- doexe math/texvc
-
- # Docs
- docinto math
- dodoc math/README math/TODO
-
- # Working directories. Server writeable.
- dodir ${MY_HTDOCSDIR}/images/math
- webapp_serverowned ${MY_HTDOCSDIR}/images/math
- dodir ${MY_HTDOCSDIR}/images/tmp
- webapp_serverowned ${MY_HTDOCSDIR}/images/tmp
- fi
-
- webapp_postinst_txt en ${FILESDIR}/postinstall-1.4-en.txt
- webapp_src_install
-}