summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-11 16:58:09 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-11 16:58:09 +0000
commit3479521145211b027a4100535a6107d919c6712e (patch)
tree074d638a3181e91de1c2898e48dba2ea6203cf96 /www-client/conkeror
parentInitial import, will be used by TeX Live 2010 (diff)
downloadgentoo-2-3479521145211b027a4100535a6107d919c6712e.tar.gz
gentoo-2-3479521145211b027a4100535a6107d919c6712e.tar.bz2
gentoo-2-3479521145211b027a4100535a6107d919c6712e.zip
Version bump.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'www-client/conkeror')
-rw-r--r--www-client/conkeror/ChangeLog7
-rw-r--r--www-client/conkeror/conkeror-0.9.3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/www-client/conkeror/ChangeLog b/www-client/conkeror/ChangeLog
index a5906123a94c..fbfe7ffb1c47 100644
--- a/www-client/conkeror/ChangeLog
+++ b/www-client/conkeror/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/conkeror
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.15 2010/09/12 06:15:43 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.16 2010/10/11 16:58:09 ulm Exp $
+
+*conkeror-0.9.3 (11 Oct 2010)
+
+ 11 Oct 2010; Ulrich Mueller <ulm@gentoo.org> +conkeror-0.9.3.ebuild:
+ Version bump.
*conkeror-0.9.2_p20100830 (12 Sep 2010)
diff --git a/www-client/conkeror/conkeror-0.9.3.ebuild b/www-client/conkeror/conkeror-0.9.3.ebuild
new file mode 100644
index 000000000000..5fa83999ed84
--- /dev/null
+++ b/www-client/conkeror/conkeror-0.9.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/conkeror-0.9.3.ebuild,v 1.1 2010/10/11 16:58:09 ulm Exp $
+
+EAPI=3
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A Mozilla-based web browser whose design is inspired by GNU Emacs"
+HOMEPAGE="http://conkeror.org/"
+# snapshot from http://repo.or.cz/w/conkeror.git
+# conkeror.png is derived from http://commons.wikimedia.org/wiki/File:Conker.jpg
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/conkeror.png"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-libs/xulrunner-1.9"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}/conkeror.png" . || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ insinto /usr/lib/${PN}
+ doins -r branding chrome components content defaults help locale modules \
+ search-engines style tests || die
+ doins application.ini Info.plist || die
+
+ exeinto /usr/lib/${PN}
+ doexe conkeror-spawn-helper || die
+ exeinto /usr/lib/${PN}/contrib
+ doexe contrib/run-conkeror || die
+ dosym /usr/lib/${PN}/contrib/run-conkeror /usr/bin/conkeror || die
+ domenu "${FILESDIR}/conkeror.desktop" || die
+ doicon "${WORKDIR}/conkeror.png" || die
+
+ doman contrib/man/conkeror.1 || die
+ dodoc CREDITS || die
+ # Use the XULRunner found in the Prefix, not the system's one
+ sed -e "s:/etc/gre.d:\"${EPREFIX}/etc/gre.d\":g" -i "${ED}"/usr/lib/conkeror/contrib/run-conkeror || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}