summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-10 19:09:40 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-10 19:09:40 +0000
commit985fcf05d25be0aa2a0a7c66a47224d4de604e19 (patch)
tree7f221c8d394a1245c85e18afb1fdd96e7a659800 /www-client/conkeror
parentVersion bump thanks to Arfrever (diff)
downloadgentoo-2-985fcf05d25be0aa2a0a7c66a47224d4de604e19.tar.gz
gentoo-2-985fcf05d25be0aa2a0a7c66a47224d4de604e19.tar.bz2
gentoo-2-985fcf05d25be0aa2a0a7c66a47224d4de604e19.zip
Change install location from /usr/lib to /usr/share. Use our own wrapper script instead of the contributed one.
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'www-client/conkeror')
-rw-r--r--www-client/conkeror/ChangeLog9
-rw-r--r--www-client/conkeror/conkeror-0.9.4-r1.ebuild (renamed from www-client/conkeror/conkeror-0.9.4.ebuild)15
-rw-r--r--www-client/conkeror/files/conkeror.sh13
3 files changed, 28 insertions, 9 deletions
diff --git a/www-client/conkeror/ChangeLog b/www-client/conkeror/ChangeLog
index 4ec274e16715..ff328f6e4e13 100644
--- a/www-client/conkeror/ChangeLog
+++ b/www-client/conkeror/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/conkeror
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.21 2011/12/10 11:01:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/ChangeLog,v 1.22 2011/12/10 19:09:40 ulm Exp $
+
+*conkeror-0.9.4-r1 (10 Dec 2011)
+
+ 10 Dec 2011; Ulrich Mueller <ulm@gentoo.org> -conkeror-0.9.4.ebuild,
+ +conkeror-0.9.4-r1.ebuild, +files/conkeror.sh:
+ Change install location from /usr/lib to /usr/share. Use our own wrapper
+ script instead of the contributed one.
*conkeror-0.9.4 (10 Dec 2011)
diff --git a/www-client/conkeror/conkeror-0.9.4.ebuild b/www-client/conkeror/conkeror-0.9.4-r1.ebuild
index a0d75bba2bf0..7373745bbf8f 100644
--- a/www-client/conkeror/conkeror-0.9.4.ebuild
+++ b/www-client/conkeror/conkeror-0.9.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/conkeror-0.9.4.ebuild,v 1.1 2011/12/10 11:01:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/conkeror/conkeror-0.9.4-r1.ebuild,v 1.1 2011/12/10 19:09:40 ulm Exp $
EAPI=4
@@ -34,23 +34,22 @@ src_compile() {
}
src_install() {
- insinto /usr/lib/${PN}
+ insinto /usr/share/${PN}
doins -r branding chrome components content defaults help locale modules \
search-engines style tests
doins application.ini chrome.manifest Info.plist
- exeinto /usr/lib/${PN}
+ exeinto /usr/libexec/${PN}
doexe conkeror-spawn-helper
- exeinto /usr/lib/${PN}/contrib
- doexe contrib/run-conkeror
- dosym /usr/lib/${PN}/contrib/run-conkeror /usr/bin/conkeror
+ dosym ../../libexec/${PN}/conkeror-spawn-helper \
+ /usr/share/${PN}/conkeror-spawn-helper
+
+ newbin "${FILESDIR}/conkeror.sh" conkeror
domenu "${FILESDIR}/conkeror.desktop"
doicon "${WORKDIR}/conkeror.png"
doman contrib/man/conkeror.1
dodoc CREDITS
- # Use the XULRunner found in the Prefix, not the system's one
- sed -e "s:/etc/gre.d:\"${EPREFIX}/etc/gre.d\":g" -i "${ED}"/usr/lib/conkeror/contrib/run-conkeror
}
pkg_postinst() {
diff --git a/www-client/conkeror/files/conkeror.sh b/www-client/conkeror/files/conkeror.sh
new file mode 100644
index 000000000000..31c6bc98cd0f
--- /dev/null
+++ b/www-client/conkeror/files/conkeror.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+# Wrapper script for conkeror
+
+for cmd in xulrunner-2.0 xulrunner-1.9.2 firefox; do
+ xr=$(type -p ${cmd})
+ if [[ -n ${xr} ]]; then
+ [[ ${cmd} = firefox ]] && xr="${xr} -app"
+ exec ${xr} /usr/share/conkeror/application.ini "$@"
+ fi
+done
+
+echo "$0: xulrunner or firefox required, but not found." >&2
+exit 1