summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-04-10 15:57:12 +0000
committerBen de Groot <yngwin@gentoo.org>2009-04-10 15:57:12 +0000
commitc4e2f70322885129a56befaa1cb19ef0fae78e81 (patch)
tree77e7ecfa39f5a66bf74be2d899555a1a535dcb31 /www-client/dillo
parentwhitespace (diff)
downloadgentoo-2-c4e2f70322885129a56befaa1cb19ef0fae78e81.tar.gz
gentoo-2-c4e2f70322885129a56befaa1cb19ef0fae78e81.tar.bz2
gentoo-2-c4e2f70322885129a56befaa1cb19ef0fae78e81.zip
Add live ebuild to follow current development, which has interesting features as initial CSS and JavaScript support.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/ChangeLog8
-rw-r--r--www-client/dillo/dillo-9999.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index d7ae21793a2c..ff3c7c4a5f4b 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/dillo
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.69 2009/02/27 12:23:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.70 2009/04/10 15:57:12 yngwin Exp $
+
+*dillo-9999 (10 Apr 2009)
+
+ 10 Apr 2009; Ben de Groot <yngwin@gentoo.org> +dillo-9999.ebuild:
+ Add live ebuild to follow current development, which has interesting
+ features as initial CSS and JavaScript support.
27 Feb 2009; Raúl Porcel <armin76@gentoo.org> dillo-2.0.ebuild:
Re-add ~arm wrt #253083
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
new file mode 100644
index 000000000000..9e39f31e049c
--- /dev/null
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-9999.ebuild,v 1.1 2009/04/10 15:57:12 yngwin Exp $
+
+EAPI="2"
+inherit eutils multilib mercurial
+
+DESCRIPTION="Lean FLTK2-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+EHG_REPO_URI="http://hg.dillo.org/dillo"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc +gif ipv6 +jpeg +png ssl"
+
+RDEPEND="x11-libs/fltk:2[-cairo,jpeg=,png=]
+ sys-libs/zlib
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/dillo2-inbuf.patch
+ ./autogen.sh
+}
+
+src_configure() {
+ LDFLAGS="${LDFLAGS} -L/usr/$(get_libdir)/fltk" \
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake || die "make failed"
+ if use doc ; then
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodir /etc
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use doc; then
+ dohtml html/* || die "install documentation failed"
+ fi
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ doicon "${FILESDIR}"/dillo.png
+ make_desktop_entry dillo Dillo dillo
+
+ elog "Dillo has installed a default configuration into /etc/dillorc"
+ elog "You can copy this to ~/.dillo/ and customize it"
+}