summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-03-23 15:10:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-03-23 15:10:11 +0000
commitc051f1b5f4ec26bde9567918be72f43c14580e92 (patch)
tree8ac98ba25283e9e9809aecf5809197c41417f3d5 /www-client/epiphany/epiphany-1.4.7.ebuild
parentStable on sparc wrt #86033 (diff)
downloadgentoo-2-c051f1b5f4ec26bde9567918be72f43c14580e92.tar.gz
gentoo-2-c051f1b5f4ec26bde9567918be72f43c14580e92.tar.bz2
gentoo-2-c051f1b5f4ec26bde9567918be72f43c14580e92.zip
moved from net-www to www-client
(Portage version: 1.585-cvs)
Diffstat (limited to 'www-client/epiphany/epiphany-1.4.7.ebuild')
-rw-r--r--www-client/epiphany/epiphany-1.4.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/www-client/epiphany/epiphany-1.4.7.ebuild b/www-client/epiphany/epiphany-1.4.7.ebuild
new file mode 100644
index 000000000000..2be612ab3746
--- /dev/null
+++ b/www-client/epiphany/epiphany-1.4.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-1.4.7.ebuild,v 1.3 2005/03/23 15:10:11 seemant Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.4.1
+ >=x11-libs/pango-1.6
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.6.6
+ >=gnome-base/libgnomeui-2.6.0
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libbonoboui-2.2
+ >=gnome-base/orbit-2
+ >=gnome-base/gnome-vfs-2.3.1
+ >=net-www/mozilla-1.7.3
+ gnome? ( >=gnome-base/nautilus-2.5 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+
+ if [ ! -f ${ROOT}/usr/lib/mozilla/components/libwidget_gtk2.so ]
+ then
+ eerror "you need mozilla-1.7.3+ compiled against gtk+-2"
+ eerror "export USE=\"gtk2\" ;emerge mozilla -p "
+ die "Need Mozilla compiled with gtk+-2.0!"
+ fi
+
+}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # Fix include paths for our mozilla
+ epatch ${FILESDIR}/${PN}-1.4.6-fix_includes.patch
+ # Fix compilation/API breakage with mozilla 1.7.5.
+ # See bug #74972 ,<obz@gentoo.org>
+ epatch ${FILESDIR}/${PN}-1.4.6-moz-nsiurip.patch
+
+}