summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-10-17 21:29:37 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-10-17 21:29:37 +0000
commitecb38eeda8d7361d654dee63cfd3cba9e381d78b (patch)
tree6bbff08c9419de205c202e6c4639f97c7b61f6eb /www-client/epiphany
parentfix for bug 196147 in all versions (diff)
downloadgentoo-2-ecb38eeda8d7361d654dee63cfd3cba9e381d78b.tar.gz
gentoo-2-ecb38eeda8d7361d654dee63cfd3cba9e381d78b.tar.bz2
gentoo-2-ecb38eeda8d7361d654dee63cfd3cba9e381d78b.zip
bump to 2.20.1
(Portage version: 2.1.3.13)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.20.1.ebuild76
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.20.13
3 files changed, 86 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index eb6706f21a44..9b2e83292748 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.132 2007/10/11 22:54:16 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.133 2007/10/17 21:29:36 eva Exp $
+
+*epiphany-2.20.1 (17 Oct 2007)
+
+ 17 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.20.1.ebuild:
+ bump to 2.20.1
11 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org>
epiphany-2.16.3.ebuild, epiphany-2.18.2.ebuild, epiphany-2.18.3.ebuild:
diff --git a/www-client/epiphany/epiphany-2.20.1.ebuild b/www-client/epiphany/epiphany-2.20.1.ebuild
new file mode 100644
index 000000000000..8cca4428ecdc
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.20.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.20.1.ebuild,v 1.1 2007/10/17 21:29:36 eva Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python xulrunner spell"
+
+# FIXME: add webkit/gecko switch possibility
+# dang: *after* webkit actually works.
+
+RDEPEND=">=dev-libs/glib-2.13.4
+ >=x11-libs/gtk+-2.11.6
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ !xulrunner? ( >=www-client/mozilla-firefox-1.5 )
+ xulrunner? ( net-libs/xulrunner )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ >=gnome-base/gnome-common-2.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ --with-engine=mozilla \
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-2.20.1 b/www-client/epiphany/files/digest-epiphany-2.20.1
new file mode 100644
index 000000000000..d04252d5125c
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.20.1
@@ -0,0 +1,3 @@
+MD5 bacb5c7f1a421f6d5adbec35d4cab3ea epiphany-2.20.1.tar.bz2 4878092
+RMD160 05921c9228f29c401f4feec77e1601ef26c6138a epiphany-2.20.1.tar.bz2 4878092
+SHA256 2a1d9b9e928dd2cb7c3778d1990d5a42ae1b49b4d5e70d0bf86584a52d45bff1 epiphany-2.20.1.tar.bz2 4878092