summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-10-24 16:03:20 +0000
committerJory Pratt <anarchy@gentoo.org>2010-10-24 16:03:20 +0000
commitfe464f46087579d659d01b85cca0acdac49e4781 (patch)
tree47706039b084c701e6c081bd12221a7f68b8f960 /www-client/firefox-bin
parentstable ppc, bug 339234 (diff)
downloadgentoo-2-fe464f46087579d659d01b85cca0acdac49e4781.tar.gz
gentoo-2-fe464f46087579d659d01b85cca0acdac49e4781.tar.bz2
gentoo-2-fe464f46087579d659d01b85cca0acdac49e4781.zip
Fix firefox-bin stub creation
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'www-client/firefox-bin')
-rw-r--r--www-client/firefox-bin/ChangeLog5
-rw-r--r--www-client/firefox-bin/firefox-bin-3.6.11.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/www-client/firefox-bin/ChangeLog b/www-client/firefox-bin/ChangeLog
index 2ee397c70813..0c4138f4bdb7 100644
--- a/www-client/firefox-bin/ChangeLog
+++ b/www-client/firefox-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/firefox-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.35 2010/10/24 03:07:34 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.36 2010/10/24 16:03:20 anarchy Exp $
+
+ 24 Oct 2010; Jory A. Pratt <anarchy@gentoo.org> firefox-bin-3.6.11.ebuild:
+ Fix firefox-bin stub creation
23 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
firefox-bin-3.6.11.ebuild:
diff --git a/www-client/firefox-bin/firefox-bin-3.6.11.ebuild b/www-client/firefox-bin/firefox-bin-3.6.11.ebuild
index 4086e6b7e07c..d603ac317707 100644
--- a/www-client/firefox-bin/firefox-bin-3.6.11.ebuild
+++ b/www-client/firefox-bin/firefox-bin-3.6.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-3.6.11.ebuild,v 1.2 2010/10/24 03:07:34 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-3.6.11.ebuild,v 1.3 2010/10/24 16:03:20 anarchy Exp $
EAPI="2"
inherit eutils mozilla-launcher multilib mozextension
@@ -133,16 +133,25 @@ src_install() {
fi
# Create /usr/bin/firefox-bin
+if use amd64 ; then
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/${PN}
+#!/bin/sh
+unset LD_PRELOAD
+LD_LIBRARY_PATH="/opt/firefox/"
+GTK_PATH=/usr/lib32/gtk-2.0/
+exec /opt/${MY_PN}/${MY_PN} "\$@"
+EOF
+else
dodir /usr/bin/
cat <<EOF >"${D}"/usr/bin/${PN}
#!/bin/sh
unset LD_PRELOAD
LD_LIBRARY_PATH="/opt/firefox/"
-if use amd64 ; then
GTK_PATH=/usr/lib32/gtk-2.0/
-fi
exec /opt/${MY_PN}/${MY_PN} "\$@"
EOF
+fi
fperms 0755 /usr/bin/${PN}
# revdep-rebuild entry