summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-10-28 15:58:01 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-10-28 15:58:01 +0000
commit59643cac578336d7c4b06d373f107b060c01e456 (patch)
tree01ec21367d70b0a71dede008416a9fb5345f7782 /www-client/icecat
parentSmall fix (diff)
downloadgentoo-2-59643cac578336d7c4b06d373f107b060c01e456.tar.gz
gentoo-2-59643cac578336d7c4b06d373f107b060c01e456.tar.bz2
gentoo-2-59643cac578336d7c4b06d373f107b060c01e456.zip
Added patch to fix compilation against >=gtk+-2.21
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'www-client/icecat')
-rw-r--r--www-client/icecat/ChangeLog6
-rw-r--r--www-client/icecat/files/xulrunner-1.9.2-gtk+-2.21.patch23
-rw-r--r--www-client/icecat/icecat-3.6.11.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/www-client/icecat/ChangeLog b/www-client/icecat/ChangeLog
index b8848d4dc7d1..dff54d35957d 100644
--- a/www-client/icecat/ChangeLog
+++ b/www-client/icecat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/icecat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/icecat/ChangeLog,v 1.51 2010/10/28 14:49:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/icecat/ChangeLog,v 1.52 2010/10/28 15:58:01 polynomial-c Exp $
+
+ 28 Oct 2010; Lars Wendler <polynomial-c@gentoo.org>
+ +files/xulrunner-1.9.2-gtk+-2.21.patch, icecat-3.6.11.ebuild:
+ Added patch to fix compilation against >=gtk+-2.21
28 Oct 2010; Markos Chandras <hwoarang@gentoo.org> icecat-3.6.11.ebuild:
Stable on amd64 wrt bug #341821
diff --git a/www-client/icecat/files/xulrunner-1.9.2-gtk+-2.21.patch b/www-client/icecat/files/xulrunner-1.9.2-gtk+-2.21.patch
new file mode 100644
index 000000000000..8a1e83134bb0
--- /dev/null
+++ b/www-client/icecat/files/xulrunner-1.9.2-gtk+-2.21.patch
@@ -0,0 +1,23 @@
+# HG changeset patch
+# User Jonathan Callen <abcd@gentoo.org>
+# Parent 2599ed882191d88a8e8f0cb68492a156163c5ca7
+pass MOZ_GTK_CFLAGS to ensure proper includes are avaliable.
+
+diff --git a/toolkit/system/gnome/Makefile.in b/toolkit/system/gnome/Makefile.in
+--- a/toolkit/system/gnome/Makefile.in
++++ b/toolkit/system/gnome/Makefile.in
+@@ -84,13 +84,14 @@ EXTRA_DSO_LDOPTS += \
+ $(MOZ_LIBNOTIFY_LIBS) \
+ $(NULL)
+
+ LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/components/build/
+
+ include $(topsrcdir)/config/rules.mk
+
+ CXXFLAGS += \
++ $(MOZ_GTK2_CFLAGS) \
+ $(MOZ_GCONF_CFLAGS) \
+ $(MOZ_GNOMEVFS_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(MOZ_LIBNOTIFY_CFLAGS) \
+ $(NULL)
diff --git a/www-client/icecat/icecat-3.6.11.ebuild b/www-client/icecat/icecat-3.6.11.ebuild
index d8f19e5e5d51..a1b4914a0eb9 100644
--- a/www-client/icecat/icecat-3.6.11.ebuild
+++ b/www-client/icecat/icecat-3.6.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/icecat/icecat-3.6.11.ebuild,v 1.3 2010/10/28 14:49:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/icecat/icecat-3.6.11.ebuild,v 1.4 2010/10/28 15:58:01 polynomial-c Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -133,6 +133,8 @@ src_prepare() {
EPATCH_FORCE="yes" \
epatch "${WORKDIR}"
+ epatch "${FILESDIR}/xulrunner-1.9.2-gtk+-2.21.patch"
+
# Fix rebranding
sed -i 's|\$(DIST)/bin/firefox|\$(DIST)/bin/icecat|' browser/app/Makefile.in