summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-08 11:47:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-08 11:47:19 +0000
commit3e96937b4f8787b0b9b75693784cc59ae7b60c98 (patch)
tree1036522a03e01cc8c5cf418cf444dec9e087b1e8 /www-client/links
parentUpdate the mimetype cache for last change... (diff)
downloadgentoo-2-3e96937b4f8787b0b9b75693784cc59ae7b60c98.tar.gz
gentoo-2-3e96937b4f8787b0b9b75693784cc59ae7b60c98.tar.bz2
gentoo-2-3e96937b4f8787b0b9b75693784cc59ae7b60c98.zip
update the cache only with USE X
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'www-client/links')
-rw-r--r--www-client/links/links-2.5.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/www-client/links/links-2.5.ebuild b/www-client/links/links-2.5.ebuild
index 761ff6b37a98..1395538f9ea7 100644
--- a/www-client/links/links-2.5.ebuild
+++ b/www-client/links/links-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.5.ebuild,v 1.3 2012/01/08 11:44:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.5.ebuild,v 1.4 2012/01/08 11:47:19 ssuominen Exp $
EAPI=4
inherit autotools eutils fdo-mime
@@ -118,5 +118,10 @@ src_install() {
use suid && fperms 4755 /usr/bin/links
}
-pkg_postinst() { fdo-mime_desktop_database_update; }
-pkg_postrm() { fdo-mime_desktop_database_update; }
+pkg_postinst() {
+ use X && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ use X && fdo-mime_desktop_database_update
+}