summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-03-15 14:14:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-03-15 14:14:46 +0000
commit068291e6e6de7484d5c68e0fe8d70115af4bcacd (patch)
tree9c32a4ee40f4aead09ac4acfaff75a14a1cf17cb /www-client/lynx/lynx-2.8.4.1c.ebuild
parentforgoten to remove a # that was commenting a small sleep (diff)
downloadgentoo-2-068291e6e6de7484d5c68e0fe8d70115af4bcacd.tar.gz
gentoo-2-068291e6e6de7484d5c68e0fe8d70115af4bcacd.tar.bz2
gentoo-2-068291e6e6de7484d5c68e0fe8d70115af4bcacd.zip
Moved from net-www/lynx to www-client/lynx.
Diffstat (limited to 'www-client/lynx/lynx-2.8.4.1c.ebuild')
-rw-r--r--www-client/lynx/lynx-2.8.4.1c.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/www-client/lynx/lynx-2.8.4.1c.ebuild b/www-client/lynx/lynx-2.8.4.1c.ebuild
new file mode 100644
index 000000000000..e934a79b431e
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.4.1c.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.4.1c.ebuild,v 1.1 2005/03/15 14:14:46 seemant Exp $
+
+IUSE="ssl nls ipv6"
+
+MY_PV=${PV/.1c/rel.1}
+S=${WORKDIR}/${PN}2-8-4
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/${PN}2.8.4/${PN}${MY_PV}.tar.bz2
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}a.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}b.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}c.patch"
+KEYWORDS="x86 ppc sparc hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_unpack() {
+ unpack ${PN}${MY_PV}.tar.bz2
+ cd ${S}
+
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}a.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}b.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}c.patch || die
+
+ # GCC3.1 support -- check if it's really needed in
+ # future. Some users report complete success with -r3 --
+ # credit to lostlogix and carpaski. Resolves #3172
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ CFLAGS="${CFLAGS} -DANSI_VARARGS"
+
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ ${myconf} || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}