summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-28 21:34:29 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-28 21:34:29 +0000
commit673a90a6a8869d0d2aab0ec4e9291488e3af0405 (patch)
tree278140df46fb153f5d0dd4c063e2140dfb2b7828 /www-client/lynx
parentInitial commit. (diff)
downloadgentoo-2-673a90a6a8869d0d2aab0ec4e9291488e3af0405.tar.gz
gentoo-2-673a90a6a8869d0d2aab0ec4e9291488e3af0405.tar.bz2
gentoo-2-673a90a6a8869d0d2aab0ec4e9291488e3af0405.zip
Remove old.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'www-client/lynx')
-rw-r--r--www-client/lynx/ChangeLog7
-rw-r--r--www-client/lynx/files/lynx-2.8.7-include-locale.patch11
-rw-r--r--www-client/lynx/lynx-2.8.7_p1.ebuild136
-rw-r--r--www-client/lynx/lynx-2.8.7_p2.ebuild124
-rw-r--r--www-client/lynx/lynx-2.8.8_pre11.ebuild116
5 files changed, 6 insertions, 388 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 71fe1d7e7187..763d01d7e031 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.125 2012/05/28 16:49:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.126 2012/05/28 21:34:29 radhermit Exp $
+
+ 28 May 2012; Tim Harder <radhermit@gentoo.org> -lynx-2.8.7_p1.ebuild,
+ -lynx-2.8.7_p2.ebuild, -files/lynx-2.8.7-include-locale.patch,
+ -lynx-2.8.8_pre11.ebuild:
+ Remove old.
28 May 2012; Raúl Porcel <armin76@gentoo.org> lynx-2.8.8_pre12.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #414267
diff --git a/www-client/lynx/files/lynx-2.8.7-include-locale.patch b/www-client/lynx/files/lynx-2.8.7-include-locale.patch
deleted file mode 100644
index 0b600132560b..000000000000
--- a/www-client/lynx/files/lynx-2.8.7-include-locale.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/LYMain.c.orig 2009-10-04 22:18:14.000000000 -0700
-+++ src/LYMain.c 2009-10-04 22:29:54.000000000 -0700
-@@ -57,7 +57,7 @@
- #include <io.h>
- #endif
-
--#if defined(LOCALE) && !defined(HAVE_LIBINTL_H)
-+#if defined(LOCALE) && (!defined(HAVE_LIBINTL_H) || !defined(LC_ALL))
- #undef gettext /* Solaris locale.h prototypes gettext() */
- #include <locale.h>
- #ifndef HAVE_GETTEXT
diff --git a/www-client/lynx/lynx-2.8.7_p1.ebuild b/www-client/lynx/lynx-2.8.7_p1.ebuild
deleted file mode 100644
index 522a770064cb..000000000000
--- a/www-client/lynx/lynx-2.8.7_p1.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_p1.ebuild,v 1.15 2012/05/03 06:01:04 jdhore Exp $
-
-EAPI=2
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-if [[ "${PV/_p[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_p/rel.}"
-
-elif [[ "${PV/_rc[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_rc/pre.}"
-
-elif [[ "${PV/_pre[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_pre/dev.}"
-
-fi
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bzip2 cjk gnutls ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- if ! use ssl
- then
- elog "SSL support disabled; you will not be able to access secure websites."
- fi
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
-
- # missing include of locale.h when compiled with -O0 (bug #286198)
- epatch "${FILESDIR}/lynx-2.8.7-include-locale.patch"
-}
-
-src_configure() {
- local myargs
-
- if use ssl
- then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls
- then
- myargs="$myargs --with-gnutls" # ssl implementation = gnutls
- else
- myargs="$myargs --with-ssl" # ssl implementation = openssl
- fi
- fi
-
- if use unicode
- then
- myargs="$myargs --with-screen=ncursesw"
- fi
-
- econf \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- $myargs
-}
-
-src_compile() {
- # see bug #403905
- emake -j1 || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode
- then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}
diff --git a/www-client/lynx/lynx-2.8.7_p2.ebuild b/www-client/lynx/lynx-2.8.7_p2.ebuild
deleted file mode 100644
index 0242315ddff6..000000000000
--- a/www-client/lynx/lynx-2.8.7_p2.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_p2.ebuild,v 1.3 2012/05/03 06:01:04 jdhore Exp $
-
-EAPI="2"
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="bzip2 cjk gnutls ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- if ! use ssl ; then
- elog "SSL support disabled; you will not be able to access secure websites."
- fi
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || die
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}"/${PN}-2.8.7-configure-openssl.patch
-
- # missing include of locale.h when compiled with -O0 (bug #286198)
- epatch "${FILESDIR}"/${PN}-2.8.7-include-locale.patch
-}
-
-src_configure() {
- local myargs
-
- if use ssl ; then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls ; then
- myargs+=" --with-gnutls"
- else
- myargs+=" --with-ssl"
- fi
- fi
-
- if use unicode ; then
- myargs+=" --with-screen=ncursesw"
- fi
-
- econf \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- ${myargs}
-}
-
-src_compile() {
- # see bug #403905
- emake -j1 || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- sed -i \
- -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${D}"/etc/lynx.cfg || die
- if use unicode ; then
- sed -i \
- -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${D}"/etc/lynx.cfg || die
- fi
-
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}
diff --git a/www-client/lynx/lynx-2.8.8_pre11.ebuild b/www-client/lynx/lynx-2.8.8_pre11.ebuild
deleted file mode 100644
index 04e45df4f9c2..000000000000
--- a/www-client/lynx/lynx-2.8.8_pre11.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre11.ebuild,v 1.2 2012/05/03 06:01:04 jdhore Exp $
-
-EAPI=4
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )
- idn? ( net-dns/libidn )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- ! use ssl && elog "SSL support disabled; you will not be able to access secure websites."
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
- epatch "${FILESDIR}"/${PN}-2.8.6-mint.patch
-}
-
-src_configure() {
- local myargs
-
- if use ssl ; then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls ; then
- myargs+=" --with-gnutls" # ssl implementation = gnutls
- else
- myargs+=" --with-ssl" # ssl implementation = openssl
- fi
- fi
-
- use unicode && myargs+=" --with-screen=ncursesw"
-
- econf \
- --enable-nested-tables \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --enable-externs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable idn idna) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- $myargs
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode ; then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}