summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-14 16:41:43 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-14 16:41:43 +0000
commit65229527dd30bf062e8da68d6277569d2a3d3d66 (patch)
tree723ba8aba37851511713ee7b0e32522aff64715d /www-client/midori
parentRemove old ebuilds and duplicate gnome-use-flag related stuff to allow eclass... (diff)
downloadgentoo-2-65229527dd30bf062e8da68d6277569d2a3d3d66.tar.gz
gentoo-2-65229527dd30bf062e8da68d6277569d2a3d3d66.tar.bz2
gentoo-2-65229527dd30bf062e8da68d6277569d2a3d3d66.zip
Version bump and synced live ebuild
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'www-client/midori')
-rw-r--r--www-client/midori/ChangeLog7
-rw-r--r--www-client/midori/midori-0.3.3.ebuild60
-rw-r--r--www-client/midori/midori-9999.ebuild58
3 files changed, 86 insertions, 39 deletions
diff --git a/www-client/midori/ChangeLog b/www-client/midori/ChangeLog
index c7f6ecc1ee9b..c836649107d1 100644
--- a/www-client/midori/ChangeLog
+++ b/www-client/midori/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/midori
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.52 2011/03/07 13:37:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.53 2011/03/14 16:41:43 angelos Exp $
+
+*midori-0.3.3 (14 Mar 2011)
+
+ 14 Mar 2011; <angelos@gentoo.org> +midori-0.3.3.ebuild, midori-9999.ebuild:
+ Version bump and synced live ebuild
*midori-0.3.2-r1 (07 Mar 2011)
diff --git a/www-client/midori/midori-0.3.3.ebuild b/www-client/midori/midori-0.3.3.ebuild
new file mode 100644
index 000000000000..0138c894d381
--- /dev/null
+++ b/www-client/midori/midori-0.3.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.3.3.ebuild,v 1.1 2011/03/14 16:41:43 angelos Exp $
+
+EAPI=3
+inherit python waf-utils
+
+DESCRIPTION="A lightweight web browser based on WebKitGTK+"
+HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="doc gnome idn libnotify nls +unique vala"
+
+RDEPEND="dev-libs/libxml2
+ >=dev-db/sqlite-3.0
+ >=net-libs/libsoup-2.25.2
+ net-libs/webkit-gtk
+ x11-libs/gtk+:2
+ gnome? ( net-libs/libsoup-gnome )
+ idn? ( net-dns/libidn )
+ libnotify? ( x11-libs/libnotify )
+ unique? ( dev-libs/libunique )
+ vala? ( dev-lang/vala:0.10 )"
+DEPEND="${RDEPEND}
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+ DOCS=( AUTHORS ChangeLog INSTALL TODO )
+ HTML_DOCS=( data/faq.html data/faq.css )
+}
+
+src_prepare() {
+ # Make it work with slotted vala versions
+ sed -i -e "s/conf.env, 'valac'/conf.env, 'valac-0.10', var='VALAC'/" wscript || die
+}
+
+src_configure() {
+ strip-linguas -i po
+
+ waf-utils_src_configure \
+ --disable-docs \
+ --enable-addons \
+ $(use_enable doc apidocs) \
+ $(use_enable idn libidn) \
+ $(use_enable libnotify) \
+ $(use_enable nls) \
+ $(use_enable unique) \
+ $(use_enable vala)
+}
+
+pkg_preinst() { xfconf_pkg_preinst; }
+pkg_postinst() { xfconf_pkg_postinst; }
+pkg_postrm() { xfconf_pkg_postrm; }
diff --git a/www-client/midori/midori-9999.ebuild b/www-client/midori/midori-9999.ebuild
index e6acc026a21a..1ea5e705ec15 100644
--- a/www-client/midori/midori-9999.ebuild
+++ b/www-client/midori/midori-9999.ebuild
@@ -1,43 +1,44 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.27 2011/03/07 13:37:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.28 2011/03/14 16:41:43 angelos Exp $
EAPI=3
-inherit eutils multilib python xfconf git
+inherit git python xfconf waf-utils
DESCRIPTION="A lightweight web browser based on WebKitGTK+"
HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
-EGIT_REPO_URI="git://git.xfce.org/apps/midori"
-EGIT_PROJECT="midori"
SRC_URI=""
+EGIT_REPO_URI="git://git.xfce.org/apps/${PN}"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE="doc gnome +html idn libnotify nls +unique vala"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="doc gnome idn libnotify nls +unique vala"
-RDEPEND="libnotify? ( x11-libs/libnotify )
- >=net-libs/libsoup-2.25.2
- >=net-libs/webkit-gtk-1.1.1
+RDEPEND="dev-libs/libxml2
>=dev-db/sqlite-3.0
- dev-libs/libxml2
- >=x11-libs/gtk+-2.10:2
+ >=net-libs/libsoup-2.25.2
+ net-libs/webkit-gtk
+ x11-libs/gtk+:2
gnome? ( net-libs/libsoup-gnome )
idn? ( net-dns/libidn )
+ libnotify? ( x11-libs/libnotify )
unique? ( dev-libs/libunique )
vala? ( dev-lang/vala:0.10 )"
DEPEND="${RDEPEND}
|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
dev-util/intltool
- dev-util/pkgconfig
doc? ( dev-util/gtk-doc )
- html? ( dev-python/docutils )
nls? ( sys-devel/gettext )"
pkg_setup() {
python_set_active_version 2
+ DOCS=( AUTHORS ChangeLog INSTALL TODO )
+ HTML_DOCS=( data/faq.html data/faq.css )
}
+src_unpack() { git_src_unpack; }
+
src_prepare() {
# Make it work with slotted vala versions
sed -i -e "s/conf.env, 'valac'/conf.env, 'valac-0.10', var='VALAC'/" wscript || die
@@ -46,36 +47,17 @@ src_prepare() {
src_configure() {
strip-linguas -i po
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" ./waf \
- --prefix="/usr/" \
- --libdir="/usr/$(get_libdir)" \
- --docdir="/usr/share/doc/${PF}/html" \
+ waf-utils_src_configure \
--disable-docs \
--enable-addons \
$(use_enable doc apidocs) \
- $(use_enable html userdocs) \
$(use_enable idn libidn) \
$(use_enable libnotify) \
$(use_enable nls) \
$(use_enable unique) \
- $(use_enable vala) \
- configure || die
+ $(use_enable vala)
}
-src_compile() {
- # This is from dev-libs/boost, keep it synced
- jobs=$( echo " ${MAKEOPTS} " | \
- sed -e 's/ --jobs[= ]/ -j /g' \
- -e 's/ -j \([1-9][0-9]*\)/ -j\1/g' \
- -e 's/ -j\>/ -j1/g' | \
- ( while read -d ' ' j ; do if [[ "${j#-j}" = "$j" ]]; then continue; fi;
- jobs="${j#-j}"; done; echo ${jobs} ) )
- if [[ "${jobs}" != "" ]]; then NUMJOBS="-j"${jobs}; fi;
-
- ./waf build ${NUMJOBS} || die
-}
-
-src_install() {
- DESTDIR=${D} ./waf install || die
- dodoc AUTHORS ChangeLog INSTALL TODO || die
-}
+pkg_preinst() { xfconf_pkg_preinst; }
+pkg_postinst() { xfconf_pkg_postinst; }
+pkg_postrm() { xfconf_pkg_postrm; }