summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-06-13 04:26:21 +0000
committerMamoru Komachi <usata@gentoo.org>2005-06-13 04:26:21 +0000
commit558198661337a81066f6f67ee2195e8bcb7167c5 (patch)
treea720884dcc89df93bb4c124f85d0517b9c34ca54 /www-client/ochusha/ochusha-0.5.8.ebuild
parentarm stable (diff)
downloadgentoo-2-558198661337a81066f6f67ee2195e8bcb7167c5.tar.gz
gentoo-2-558198661337a81066f6f67ee2195e8bcb7167c5.tar.bz2
gentoo-2-558198661337a81066f6f67ee2195e8bcb7167c5.zip
Version bumped.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-client/ochusha/ochusha-0.5.8.ebuild')
-rw-r--r--www-client/ochusha/ochusha-0.5.8.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-client/ochusha/ochusha-0.5.8.ebuild b/www-client/ochusha/ochusha-0.5.8.ebuild
new file mode 100644
index 000000000000..853c4ca844e4
--- /dev/null
+++ b/www-client/ochusha/ochusha-0.5.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/ochusha/ochusha-0.5.8.ebuild,v 1.1 2005/06/13 04:26:21 usata Exp $
+
+inherit flag-o-matic
+
+IUSE="nls ssl debug"
+use debug && FEATURES="nostrip"
+
+DESCRIPTION="Ochusha - 2ch viewer for GTK+"
+HOMEPAGE="http://ochusha.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/15140/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64"
+
+DEPEND="virtual/xft
+ >=x11-libs/gtk+-2.2.4
+ >=dev-libs/glib-2.2.3
+ >=dev-libs/libxml2-2.5.0
+ >=gnome-base/libghttp-1.0.9
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+
+ use debug && append-flags -g
+
+ econf $(use_enable nls) \
+ $(use_with ssl) \
+ --enable-regex \
+ --disable-shared \
+ --enable-static \
+ --with-included-oniguruma || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc ABOUT-NLS ACKNOWLEDGEMENT AUTHORS BUGS \
+ ChangeLog INSTALL* NEWS README TODO
+}