summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-22 12:57:23 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-22 12:57:23 +0000
commit876d5cf59bd759189068fcdebbea3d91d47030dc (patch)
tree42ab70fb82878358afa293720b77b38a1915ceae /www-client/rekonq
parentPrepend allegro- to every manpage (key.3 will become allegro-key.3 for exampl... (diff)
downloadgentoo-2-876d5cf59bd759189068fcdebbea3d91d47030dc.tar.gz
gentoo-2-876d5cf59bd759189068fcdebbea3d91d47030dc.tar.bz2
gentoo-2-876d5cf59bd759189068fcdebbea3d91d47030dc.zip
Version bump by Michael (kensington) <gentoo@scribeofthenile.com> and David Heidelberger <d.okias@gmail.com> wrt bug #405403.
(Portage version: 2.2.0_alpha93/cvs/Linux i686)
Diffstat (limited to 'www-client/rekonq')
-rw-r--r--www-client/rekonq/ChangeLog8
-rw-r--r--www-client/rekonq/rekonq-0.9.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/www-client/rekonq/ChangeLog b/www-client/rekonq/ChangeLog
index 787a7a0185e2..2f99e664d551 100644
--- a/www-client/rekonq/ChangeLog
+++ b/www-client/rekonq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/rekonq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.39 2012/02/03 15:23:26 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.40 2012/03/22 12:57:23 johu Exp $
+
+*rekonq-0.9.0 (22 Mar 2012)
+
+ 22 Mar 2012; Johannes Huber <johu@gentoo.org> +rekonq-0.9.0.ebuild:
+ Version bump by Michael (kensington) <gentoo@scribeofthenile.com> and David
+ Heidelberger <d.okias@gmail.com> wrt bug #405403.
03 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org> rekonq-0.8.1.ebuild:
Fix LINGUAS handling (now rekonq adheres to KDE doc standards), bug 401525
diff --git a/www-client/rekonq/rekonq-0.9.0.ebuild b/www-client/rekonq/rekonq-0.9.0.ebuild
new file mode 100644
index 000000000000..5f9f9661c09c
--- /dev/null
+++ b/www-client/rekonq/rekonq-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/rekonq-0.9.0.ebuild,v 1.1 2012/03/22 12:57:23 johu Exp $
+
+EAPI=4
+
+WEBKIT_REQUIRED="always"
+QT_MINIMAL="4.8"
+KDE_MINIMAL="4.7"
+KDE_SCM="git"
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
+hu is it ja ko lt nb nds pl pt pt_BR ro ru sk sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv th tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+#upstream re-released 0.9.0
+MY_P=${P}-1
+
+DESCRIPTION="A browser based on qt-webkit"
+HOMEPAGE="http://rekonq.kde.org/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# All test fails
+RESTRICT="test"
+
+src_prepare() {
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ kde4-base_src_prepare
+}