summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-04 14:52:10 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-04 14:52:10 +0000
commit65fa1743c089269bd72865f6b726b3a479740c0d (patch)
treebf4612ddd035b04484a88e7e2cb1ca2c416bf08b /www-client/surf
parentduplicate comment, thanks to Gilles Dartiguelongue for noticing. (diff)
downloadgentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.tar.gz
gentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.tar.bz2
gentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.zip
Sync 0.6-r1 changes. Clean up 0.6-r1 some more.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/ChangeLog6
-rw-r--r--www-client/surf/files/surf-0.6-gentoo.patch14
-rw-r--r--www-client/surf/files/surf-9999-gentoo.patch133
-rw-r--r--www-client/surf/surf-0.6-r1.ebuild13
-rw-r--r--www-client/surf/surf-9999.ebuild23
5 files changed, 161 insertions, 28 deletions
diff --git a/www-client/surf/ChangeLog b/www-client/surf/ChangeLog
index c037beb5e789..77bbe9eaacc0 100644
--- a/www-client/surf/ChangeLog
+++ b/www-client/surf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/surf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.31 2013/10/04 14:35:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.32 2013/10/04 14:52:10 jer Exp $
+
+ 04 Oct 2013; Jeroen Roovers <jer@gentoo.org> surf-0.6-r1.ebuild,
+ surf-9999.ebuild, files/surf-0.6-gentoo.patch, +files/surf-9999-gentoo.patch:
+ Sync 0.6-r1 changes. Clean up 0.6-r1 some more.
04 Oct 2013; Jeroen Roovers <jer@gentoo.org> surf-0.6-r1.ebuild:
Determine REPLACING_VERSIONS to conditionally call ewarn.
diff --git a/www-client/surf/files/surf-0.6-gentoo.patch b/www-client/surf/files/surf-0.6-gentoo.patch
index 7fc29489834d..cda644baa84e 100644
--- a/www-client/surf/files/surf-0.6-gentoo.patch
+++ b/www-client/surf/files/surf-0.6-gentoo.patch
@@ -1,5 +1,5 @@
---- a/config.mk 2013-02-10 19:40:14.000000000 +0100
-+++ b/config.mk 2013-10-04 16:11:28.773331797 +0200
+--- a/config.mk
++++ b/config.mk
@@ -4,27 +4,27 @@
# Customize below to fit your system
@@ -16,14 +16,14 @@
-GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
-GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
-+GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 webkit-1.0)
-+GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 webkit-1.0)
++GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
++GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
# includes and libs
-INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
+INCS = -I. -I/usr/include $(X11INC) $(GTKINC)
-+LIBS = $(X11LIB) $(GTKLIB) -lgthread-2.0
++LIBS = $(X11LIB) $(GTKLIB)
# flags
-CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
@@ -42,8 +42,8 @@
# compiler and linker
-CC = cc
+CC ?= gcc
---- a/Makefile 2013-02-10 19:40:14.000000000 +0100
-+++ b/Makefile 2013-10-04 16:05:02.230549420 +0200
+--- a/Makefile
++++ b/Makefile
@@ -4,58 +4,58 @@
include config.mk
diff --git a/www-client/surf/files/surf-9999-gentoo.patch b/www-client/surf/files/surf-9999-gentoo.patch
new file mode 100644
index 000000000000..cda644baa84e
--- /dev/null
+++ b/www-client/surf/files/surf-9999-gentoo.patch
@@ -0,0 +1,133 @@
+--- a/config.mk
++++ b/config.mk
+@@ -4,27 +4,27 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX = /usr
++MANPREFIX = $(PREFIX)/share/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = $(shell $(PKG_CONFIG) --cflags x11)
++X11LIB = $(shell $(PKG_CONFIG) --libs x11)
+
+-GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
+-GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
++GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
++GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
+
+ # includes and libs
+-INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
++INCS = -I. -I/usr/include $(X11INC) $(GTKINC)
++LIBS = $(X11LIB) $(GTKLIB)
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -g ${LIBS}
++CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_BSD_SOURCE
++CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)
++LDFLAGS += $(LIBS)
+
+ # Solaris
+-#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+-#LDFLAGS = ${LIBS}
++#CFLAGS = -fast $(INCS) -DVERSION=\"$(VERSION)\"
++#LDFLAGS = $(LIBS)
+
+ # compiler and linker
+-CC = cc
++CC ?= gcc
+--- a/Makefile
++++ b/Makefile
+@@ -4,58 +4,58 @@
+ include config.mk
+
+ SRC = surf.c
+-OBJ = ${SRC:.c=.o}
++OBJ = $(SRC:.c=.o)
+
+ all: options surf
+
+ options:
+ @echo surf build options:
+- @echo "CFLAGS = ${CFLAGS}"
+- @echo "LDFLAGS = ${LDFLAGS}"
+- @echo "CC = ${CC}"
++ @echo "CFLAGS = $(CFLAGS)"
++ @echo "LDFLAGS = $(LDFLAGS)"
++ @echo "CC = $(CC)"
+
+ .c.o:
+ @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ $(CC) -c $(CFLAGS) $<
+
+-${OBJ}: config.h config.mk
++$(OBJ): config.h config.mk
+
+ config.h:
+ @echo creating $@ from config.def.h
+- @cp config.def.h $@
++ cp config.def.h $@
+
+-surf: ${OBJ}
++surf: $(OBJ)
+ @echo CC -o $@
+- @${CC} -o $@ surf.o ${LDFLAGS}
++ $(CC) -o $@ surf.o $(LDFLAGS)
+
+ clean:
+ @echo cleaning
+- @rm -f surf ${OBJ} surf-${VERSION}.tar.gz
++ rm -f surf $(OBJ) surf-$(VERSION).tar.gz
+
+ dist: clean
+ @echo creating dist tarball
+- @mkdir -p surf-${VERSION}
+- @cp -R LICENSE Makefile config.mk config.def.h README \
++ mkdir -p surf-$(VERSION)
++ cp -R LICENSE Makefile config.mk config.def.h README \
+ surf-open.sh arg.h TODO.md surf.png \
+- surf.1 ${SRC} surf-${VERSION}
+- @tar -cf surf-${VERSION}.tar surf-${VERSION}
+- @gzip surf-${VERSION}.tar
+- @rm -rf surf-${VERSION}
++ surf.1 $(SRC) surf-$(VERSION)
++ tar -cf surf-$(VERSION).tar surf-$(VERSION)
++ gzip surf-$(VERSION).tar
++ rm -rf surf-$(VERSION)
+
+ install: all
+- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+- @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f surf ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/surf
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+- @sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo installing executable file to $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp -f surf $(DESTDIR)$(PREFIX)/bin
++ chmod 755 $(DESTDIR)$(PREFIX)/bin/surf
++ @echo installing manual page to $(DESTDIR)$(MANPREFIX)/man1
++ mkdir -p $(DESTDIR)$(MANPREFIX)/man1
++ sed "s/VERSION/$(VERSION)/g" < surf.1 > $(DESTDIR)$(MANPREFIX)/man1/surf.1
++ chmod 644 $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ uninstall:
+- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/surf
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo removing executable file from $(DESTDIR)$(PREFIX)/bin
++ rm -f $(DESTDIR)$(PREFIX)/bin/surf
++ @echo removing manual page from $(DESTDIR)$(MANPREFIX)/man1
++ rm -f $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ .PHONY: all options clean dist install uninstall
diff --git a/www-client/surf/surf-0.6-r1.ebuild b/www-client/surf/surf-0.6-r1.ebuild
index a5e35e67c50e..5df6b2e1392c 100644
--- a/www-client/surf/surf-0.6-r1.ebuild
+++ b/www-client/surf/surf-0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6-r1.ebuild,v 1.4 2013/10/04 14:35:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6-r1.ebuild,v 1.5 2013/10/04 14:52:10 jer Exp $
EAPI=5
inherit eutils savedconfig toolchain-funcs
@@ -12,7 +12,6 @@ SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
COMMON_DEPEND="
dev-libs/glib
@@ -26,8 +25,8 @@ DEPEND="
virtual/pkgconfig
"
RDEPEND="
- ${COMMON_DEPEND}
!sci-chemistry/surf
+ ${COMMON_DEPEND}
x11-apps/xprop
x11-misc/dmenu
"
@@ -40,20 +39,20 @@ pkg_setup() {
elog "installed to support the download function."
elog "Without those, downloads will fail (gracefully)."
elog "You can fix this by:"
- elog " 1) Installing these packages, or"
- elog " 2) Setting USE=savedconfig and changing config.h accordingly."
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
fi
}
src_prepare() {
- epatch_user
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch_user
restore_config config.h
tc-export CC PKG_CONFIG
}
src_install() {
- emake DESTDIR="${D}" install
+ default
save_config config.h
}
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index 3dbb5b83269e..7bc41252b0fc 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-9999.ebuild,v 1.1 2013/09/12 15:33:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-9999.ebuild,v 1.2 2013/10/04 14:52:10 jer Exp $
EAPI=5
inherit eutils git-2 savedconfig toolchain-funcs
@@ -13,18 +13,22 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-DEPEND="
+COMMON_DEPEND="
dev-libs/glib
net-libs/libsoup
net-libs/webkit-gtk:2
x11-libs/gtk+:2
x11-libs/libX11
"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
RDEPEND="
!sci-chemistry/surf
+ ${COMMON_DEPEND}
x11-apps/xprop
x11-misc/dmenu
- ${DEPEND}
"
pkg_setup() {
@@ -41,20 +45,13 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
epatch_user
- sed -i \
- -e 's|{|(|g;s|}|)|g' \
- -e 's|\t@|\t|g;s|echo|@&|g' \
- -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
- -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
- -e 's|^CC.*|CC ?= gcc|g' \
- -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
- config.mk Makefile || die
restore_config config.h
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+ default
save_config config.h
}