summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-05-02 23:59:34 +0000
committerSebastian Pipping <sping@gentoo.org>2013-05-02 23:59:34 +0000
commit0385eb61655bbe96596d5a9dde1ec4c818f0d083 (patch)
tree18105476914bced715bd838362e74fec3c43714c /www-client
parentVersion bump the compability slot for security wrt #440154 (diff)
downloadgentoo-2-0385eb61655bbe96596d5a9dde1ec4c818f0d083.tar.gz
gentoo-2-0385eb61655bbe96596d5a9dde1ec4c818f0d083.tar.bz2
gentoo-2-0385eb61655bbe96596d5a9dde1ec4c818f0d083.zip
www-client/httrack: 3.47.7
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/httrack/ChangeLog8
-rw-r--r--www-client/httrack/files/httrack-3.47.7-cflags.patch27
-rw-r--r--www-client/httrack/httrack-3.47.7.ebuild40
3 files changed, 74 insertions, 1 deletions
diff --git a/www-client/httrack/ChangeLog b/www-client/httrack/ChangeLog
index 9ff35fe2fd34..3455e2bdab1a 100644
--- a/www-client/httrack/ChangeLog
+++ b/www-client/httrack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/httrack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/ChangeLog,v 1.47 2013/04/25 20:55:07 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/ChangeLog,v 1.48 2013/05/02 23:59:34 sping Exp $
+
+*httrack-3.47.7 (02 May 2013)
+
+ 02 May 2013; Sebastian Pipping <sping@gentoo.org> +httrack-3.47.7.ebuild,
+ +files/httrack-3.47.7-cflags.patch:
+ Bump to 3.47.7
25 Apr 2013; Sebastian Pipping <sping@gentoo.org> httrack-3.47.2.ebuild,
+files/httrack-3.47.2-ac-config-headers.patch:
diff --git a/www-client/httrack/files/httrack-3.47.7-cflags.patch b/www-client/httrack/files/httrack-3.47.7-cflags.patch
new file mode 100644
index 000000000000..aa414b96402f
--- /dev/null
+++ b/www-client/httrack/files/httrack-3.47.7-cflags.patch
@@ -0,0 +1,27 @@
+From f780de5a662deeea66df4dc9056ac642c447bbaf Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Fri, 3 May 2013 00:58:15 +0200
+Subject: [PATCH] Fix CFLAGS
+
+---
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c956081..7ceeb39 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -14,9 +14,8 @@ AM_PROG_LIBTOOL
+ AC_PROG_LN_S
+
+ ### Default CFLAGS
+-DEFAULT_CFLAGS=""
+-DEFAULT_CFLAGS="-O -g3 -Wall -Wcast-align -Wstrict-prototypes \
++DEFAULT_CFLAGS="-Wall -Wcast-align -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith \
+ -Wnested-externs -D_REENTRANT"
+ AC_SUBST(DEFAULT_CFLAGS)
+
+--
+1.8.1.5
+
diff --git a/www-client/httrack/httrack-3.47.7.ebuild b/www-client/httrack/httrack-3.47.7.ebuild
new file mode 100644
index 000000000000..c4154ad05219
--- /dev/null
+++ b/www-client/httrack/httrack-3.47.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/httrack-3.47.7.ebuild,v 1.1 2013/05/02 23:59:34 sping Exp $
+
+EAPI="4"
+
+AT_M4DIR='m4'
+inherit autotools eutils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://download.httrack.com/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.44.1+zlib-1.2.5.1.patch
+ epatch "${FILESDIR}"/${PN}-3.45.4-htmldir.patch
+ epatch "${FILESDIR}"/${PN}-3.47.7-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}