summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-12-18 06:31:00 +0000
committerNaohiro Aota <naota@gentoo.org>2011-12-18 06:31:00 +0000
commit0667b0240fd9e9aaa62df1b3ad0bcb29669a9cf0 (patch)
tree3d8d57224da9038df2c71a8ec8d24c5051d6f59a /www-client
parentAdd security fix. #390769 (diff)
downloadgentoo-2-0667b0240fd9e9aaa62df1b3ad0bcb29669a9cf0.tar.gz
gentoo-2-0667b0240fd9e9aaa62df1b3ad0bcb29669a9cf0.tar.bz2
gentoo-2-0667b0240fd9e9aaa62df1b3ad0bcb29669a9cf0.zip
Fix build with glibc-2.14
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/w3m/ChangeLog6
-rw-r--r--www-client/w3m/files/w3m-0.5.3-glibc214.patch58
-rw-r--r--www-client/w3m/w3m-0.5.3-r1.ebuild5
3 files changed, 66 insertions, 3 deletions
diff --git a/www-client/w3m/ChangeLog b/www-client/w3m/ChangeLog
index f37fd55bcd71..1210ddb220ec 100644
--- a/www-client/w3m/ChangeLog
+++ b/www-client/w3m/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/w3m
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.67 2011/05/18 03:44:20 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.68 2011/12/18 06:31:00 naota Exp $
+
+ 18 Dec 2011; Naohiro Aota <naota@gentoo.org> w3m-0.5.3-r1.ebuild,
+ +files/w3m-0.5.3-glibc214.patch:
+ Fix build with glibc-2.14
18 May 2011; Naohiro Aota <naota@gentoo.org> w3m-0.5.3-r1.ebuild:
Remove CVS directories. Fix bug #367499
diff --git a/www-client/w3m/files/w3m-0.5.3-glibc214.patch b/www-client/w3m/files/w3m-0.5.3-glibc214.patch
new file mode 100644
index 000000000000..2b18a8d112db
--- /dev/null
+++ b/www-client/w3m/files/w3m-0.5.3-glibc214.patch
@@ -0,0 +1,58 @@
+--- istream.c.~1.27.~ 2011-01-04 18:22:22.000000000 +0900
++++ istream.c 2011-06-24 08:15:23.522990618 +0900
+@@ -22,8 +22,8 @@
+ static void basic_close(int *handle);
+ static int basic_read(int *handle, char *buf, int len);
+
+-static void file_close(struct file_handle *handle);
+-static int file_read(struct file_handle *handle, char *buf, int len);
++static void file_close(struct afile_handle *handle);
++static int file_read(struct afile_handle *handle, char *buf, int len);
+
+ static int str_read(Str handle, char *buf, int len);
+
+@@ -114,7 +114,7 @@
+ stream = New(union input_stream);
+ init_base_stream(&stream->base, STREAM_BUF_SIZE);
+ stream->file.type = IST_FILE;
+- stream->file.handle = New(struct file_handle);
++ stream->file.handle = New(struct afile_handle);
+ stream->file.handle->f = f;
+ if (closep)
+ stream->file.handle->close = closep;
+@@ -658,13 +658,13 @@
+ }
+
+ static void
+-file_close(struct file_handle *handle)
++file_close(struct afile_handle *handle)
+ {
+ handle->close(handle->f);
+ }
+
+ static int
+-file_read(struct file_handle *handle, char *buf, int len)
++file_read(struct afile_handle *handle, char *buf, int len)
+ {
+ return fread(buf, 1, len, handle->f);
+ }
+--- istream.h.~1.12.~ 2003-10-21 01:41:56.000000000 +0900
++++ istream.h 2011-06-24 08:15:54.392991144 +0900
+@@ -20,7 +20,7 @@
+
+ typedef struct stream_buffer *StreamBuffer;
+
+-struct file_handle {
++struct afile_handle {
+ FILE *f;
+ void (*close) ();
+ };
+@@ -53,7 +53,7 @@
+
+ struct file_stream {
+ struct stream_buffer stream;
+- struct file_handle *handle;
++ struct afile_handle *handle;
+ char type;
+ char iseos;
+ int (*read) ();
diff --git a/www-client/w3m/w3m-0.5.3-r1.ebuild b/www-client/w3m/w3m-0.5.3-r1.ebuild
index 5317d51c4878..1cd4a129283a 100644
--- a/www-client/w3m/w3m-0.5.3-r1.ebuild
+++ b/www-client/w3m/w3m-0.5.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.3-r1.ebuild,v 1.4 2011/05/18 03:44:20 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.3-r1.ebuild,v 1.5 2011/12/18 06:31:00 naota Exp $
EAPI="3"
inherit eutils
@@ -31,7 +31,8 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}/${PN}-0.5.2-gc72.patch" \
- "${FILESDIR}/${PN}-0.5.3-parallel-make.patch"
+ "${FILESDIR}/${PN}-0.5.3-parallel-make.patch" \
+ "${FILESDIR}/${PN}-0.5.3-glibc214.patch"
find . -name CVS -type d | xargs rm -r
}