summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-05-16 19:30:24 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-05-16 19:30:24 +0000
commit0b9aaec91a7ea5304536e7efc256de84ff3c3dab (patch)
treea246cd4851ae24fce52b2d874933dfb00aefe045 /www-client
parentKeyworded ~sparc (diff)
downloadgentoo-2-0b9aaec91a7ea5304536e7efc256de84ff3c3dab.tar.gz
gentoo-2-0b9aaec91a7ea5304536e7efc256de84ff3c3dab.tar.bz2
gentoo-2-0b9aaec91a7ea5304536e7efc256de84ff3c3dab.zip
Fix building on amd64 with gcc4 (patch from Debian)
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla/ChangeLog6
-rw-r--r--www-client/mozilla/files/mozilla-1.7.8-amd64.patch71
-rw-r--r--www-client/mozilla/mozilla-1.7.8-r1.ebuild5
3 files changed, 80 insertions, 2 deletions
diff --git a/www-client/mozilla/ChangeLog b/www-client/mozilla/ChangeLog
index 620b7c159802..1d2506762a2d 100644
--- a/www-client/mozilla/ChangeLog
+++ b/www-client/mozilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/mozilla
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/ChangeLog,v 1.34 2005/05/15 19:47:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/ChangeLog,v 1.35 2005/05/16 19:30:24 azarah Exp $
+
+ 16 May 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/mozilla-1.7.8-amd64.patch, mozilla-1.7.8-r1.ebuild:
+ Fix building on amd64 with gcc4 (patch from Debian)
*mozilla-1.7.8-r1 (15 May 2005)
diff --git a/www-client/mozilla/files/mozilla-1.7.8-amd64.patch b/www-client/mozilla/files/mozilla-1.7.8-amd64.patch
new file mode 100644
index 000000000000..96215fb292d5
--- /dev/null
+++ b/www-client/mozilla/files/mozilla-1.7.8-amd64.patch
@@ -0,0 +1,71 @@
+--- gfx/src/freetype/nsFreeType.cpp 7 Feb 2004 15:22:30 -0000 1.24
++++ mozilla/gfx/src/freetype/nsFreeType.cpp 4 Mar 2005 19:59:53 -0000
+@@ -96,7 +96,7 @@
+ // Define the FreeType2 functions we resolve at run time.
+ // see the comment near nsFreeType2::DoneFace() for more info
+ //
+-#define NS_FT2_OFFSET(f) (int)&((nsFreeType2*)0)->f
++#define NS_FT2_OFFSET(f) (NS_PTR_TO_INT32(&((nsFreeType2*)0)->f))
+ FtFuncList nsFreeType2::FtFuncs [] = {
+ {"FT_Done_Face", NS_FT2_OFFSET(nsFT_Done_Face), PR_TRUE},
+ {"FT_Done_FreeType", NS_FT2_OFFSET(nsFT_Done_FreeType), PR_TRUE},
+--- netwerk/protocol/http/src/nsHttpConnectionMgr.cpp 1 Sep 2004 23:31:03 -0000 1.7.20.1
++++ mozilla/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp 4 Mar 2005 19:59:57 -0000
+@@ -834,8 +834,8 @@
+ void
+ nsHttpConnectionMgr::OnMsgUpdateParam(nsresult status, void *param)
+ {
+- PRUint16 name = (PRUint32(param) & 0xFFFF0000) >> 16;
+- PRUint16 value = PRUint32(param) & 0x0000FFFF;
++ PRUint16 name = (NS_PTR_TO_INT32(param) & 0xFFFF0000) >> 16;
++ PRUint16 value = NS_PTR_TO_INT32(param) & 0x0000FFFF;
+
+ switch (name) {
+ case MAX_CONNECTIONS:
+--- widget/src/gtk2/nsDragService.cpp 30 Oct 2003 01:48:41 -0000 1.5
++++ mozilla/widget/src/gtk2/nsDragService.cpp 4 Mar 2005 20:00:01 -0000
+@@ -838,7 +838,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ listTarget->target = g_strdup(gMimeListType);
+ listTarget->flags = 0;
+- listTarget->info = (guint)listAtom;
++ listTarget->info = (guint)(NS_PTR_TO_INT32(listAtom));
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with id %ld\n",
+ listTarget->target, listAtom));
+@@ -877,7 +877,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ listTarget->target = g_strdup(gTextUriListType);
+ listTarget->flags = 0;
+- listTarget->info = (guint)listAtom;
++ listTarget->info = (guint)NS_PTR_TO_INT32(listAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", listTarget->target, listAtom));
+@@ -914,7 +914,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ target->target = g_strdup(flavorStr);
+ target->flags = 0;
+- target->info = (guint)atom;
++ target->info = (guint)NS_PTR_TO_INT32(atom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("adding target %s with id %ld\n",
+ target->target, atom));
+@@ -931,7 +931,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ plainTarget->target = g_strdup(kTextMime);
+ plainTarget->flags = 0;
+- plainTarget->info = (guint)plainAtom;
++ plainTarget->info = (guint)NS_PTR_TO_INT32(plainAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", plainTarget->target, plainAtom));
+@@ -948,7 +948,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ urlTarget->target = g_strdup(gMozUrlType);
+ urlTarget->flags = 0;
+- urlTarget->info = (guint)urlAtom;
++ urlTarget->info = (guint)NS_PTR_TO_INT32(urlAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", urlTarget->target, urlAtom));
diff --git a/www-client/mozilla/mozilla-1.7.8-r1.ebuild b/www-client/mozilla/mozilla-1.7.8-r1.ebuild
index 4d4f6856f428..780b5b85315c 100644
--- a/www-client/mozilla/mozilla-1.7.8-r1.ebuild
+++ b/www-client/mozilla/mozilla-1.7.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/mozilla-1.7.8-r1.ebuild,v 1.1 2005/05/15 19:47:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla/mozilla-1.7.8-r1.ebuild,v 1.2 2005/05/16 19:30:24 azarah Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit multilib
@@ -85,6 +85,9 @@ src_unpack() {
# Fix building with gcc4
epatch ${FILESDIR}/${PN}-1.7.6-gcc4.patch
+ # Fix building on amd64 with gcc4 (patch from Debian)
+ epatch ${FILESDIR}/${P}-amd64.patch
+
# Mozilla Bug 292257, https://bugzilla.mozilla.org/show_bug.cgi?id=292257
# Mozilla crashes under some rare cases when plugin.default_plugin_disabled
# is true. This patch fixes that. Backported by hansmi@gentoo.org.