summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-09-14 14:08:22 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-09-14 14:08:22 +0000
commit3eef3b76c902dd67081ffad191f47b74cf67ea9d (patch)
treed965d1e499646d2b27cbad0646e2db5f8f6ad553 /www-client
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-3eef3b76c902dd67081ffad191f47b74cf67ea9d.tar.gz
gentoo-2-3eef3b76c902dd67081ffad191f47b74cf67ea9d.tar.bz2
gentoo-2-3eef3b76c902dd67081ffad191f47b74cf67ea9d.zip
Version bump for dev channel release. Now we use system libxml and libxslt again. Removed old version.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-7.0.517.5.ebuild (renamed from www-client/chromium/chromium-7.0.503.1.ebuild)97
-rw-r--r--www-client/chromium/chromium-9999.ebuild10
3 files changed, 64 insertions, 53 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index d59042ec1503..0b09807cbdd0 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.173 2010/09/11 16:10:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.174 2010/09/14 14:08:22 phajdan.jr Exp $
+
+*chromium-7.0.517.5 (14 Sep 2010)
+
+ 14 Sep 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-7.0.503.1.ebuild, +chromium-7.0.517.5.ebuild,
+ chromium-9999.ebuild:
+ Version bump for dev channel release. Now we use system libxml and libxslt
+ again. Removed old version.
11 Sep 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
chromium-7.0.503.1-r1.ebuild, chromium-9999.ebuild:
diff --git a/www-client/chromium/chromium-7.0.503.1.ebuild b/www-client/chromium/chromium-7.0.517.5.ebuild
index 615c806e3a30..c2f6fe0c41ca 100644
--- a/www-client/chromium/chromium-7.0.503.1.ebuild
+++ b/www-client/chromium/chromium-7.0.517.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.503.1.ebuild,v 1.2 2010/08/28 18:10:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.517.5.ebuild,v 1.1 2010/09/14 14:08:22 phajdan.jr Exp $
EAPI="2"
@@ -18,6 +18,8 @@ IUSE="cups gnome gnome-keyring sse2"
RDEPEND="app-arch/bzip2
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
+ dev-libs/libxml2
+ dev-libs/libxslt
>=dev-libs/nss-3.12.3
>=gnome-base/gconf-2.24.0
gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
@@ -32,7 +34,6 @@ DEPEND="${RDEPEND}
dev-lang/perl
>=dev-util/gperf-3.0.3
>=dev-util/pkgconfig-0.23
- >=gnome-base/gnome-keyring-2.28.2
sys-devel/flex"
RDEPEND+="
|| (
@@ -45,10 +46,6 @@ RDEPEND+="
x11-misc/xdg-utils
virtual/ttf-fonts"
-get_chromium_home() {
- echo "/usr/$(get_libdir)/chromium-browser"
-}
-
remove_bundled_lib() {
einfo "Removing bundled library $1 ..."
local out
@@ -59,10 +56,17 @@ remove_bundled_lib() {
fi
}
+pkg_setup() {
+ CHROMIUM_HOME="/usr/$(get_libdir)/chromium-browser"
+}
+
src_prepare() {
# Add Gentoo plugin paths.
epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
+ # Make compile-time dependency on gnome-keyring optional, bug #332411.
+ epatch "${FILESDIR}"/${PN}-gnome-keyring-r0.patch
+
remove_bundled_lib "third_party/bzip2"
remove_bundled_lib "third_party/codesighs"
remove_bundled_lib "third_party/cros"
@@ -72,14 +76,14 @@ src_prepare() {
remove_bundled_lib "third_party/libevent"
remove_bundled_lib "third_party/libjpeg"
remove_bundled_lib "third_party/libpng"
+ remove_bundled_lib "third_party/libxml"
+ remove_bundled_lib "third_party/libxslt"
remove_bundled_lib "third_party/lzma_sdk"
remove_bundled_lib "third_party/molokocacao"
remove_bundled_lib "third_party/ocmock"
remove_bundled_lib "third_party/pyftpdlib"
remove_bundled_lib "third_party/simplejson"
remove_bundled_lib "third_party/tlslite"
- # TODO: also remove third_party/libxml and third_party/libxslt when
- # http://crbug.com/29333 is fixed.
# TODO: also remove third_party/zlib. For now the compilation fails if we
# remove it (minizip-related).
}
@@ -89,73 +93,73 @@ src_configure() {
# Make it possible to build chromium on non-sse2 systems.
if use sse2; then
- myconf="${myconf} -Ddisable_sse2=0"
+ myconf+=" -Ddisable_sse2=0"
else
- myconf="${myconf} -Ddisable_sse2=1"
+ myconf+=" -Ddisable_sse2=1"
fi
# Use system-provided libraries.
# TODO: use_system_ffmpeg (http://crbug.com/50678).
- # TODO: use_system_libxml (http://crbug.com/29333).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_hunspell (upstream changes needed).
# TODO: use_system_ssl when we have a recent enough system NSS.
- myconf="${myconf}
+ myconf+="
-Duse_system_bzip2=1
-Duse_system_icu=1
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
+ -Duse_system_libxml=1
-Duse_system_zlib=1"
# The dependency on cups is optional, see bug #324105.
if use cups; then
- myconf="${myconf} -Duse_cups=1"
+ myconf+=" -Duse_cups=1"
else
- myconf="${myconf} -Duse_cups=0"
+ myconf+=" -Duse_cups=0"
fi
if use "gnome-keyring"; then
- myconf="${myconf} -Dlinux_link_gnome_keyring=1"
+ myconf+=" -Duse_gnome_keyring=1 -Dlinux_link_gnome_keyring=1"
else
# TODO: we should also disable code trying to dlopen
# gnome-keyring in that case.
- myconf="${myconf} -Dlinux_link_gnome_keyring=0"
+ myconf+=" -Duse_gnome_keyring=0 -Dlinux_link_gnome_keyring=0"
fi
# Enable sandbox.
- myconf="${myconf}
- -Dlinux_sandbox_path=$(get_chromium_home)/chrome_sandbox
- -Dlinux_sandbox_chrome_path=$(get_chromium_home)/chrome"
+ myconf+="
+ -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox
+ -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
# Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
# and the performance gain isn't worth it.
- myconf="${myconf} -Dv8_use_snapshot=0"
+ myconf+=" -Dv8_use_snapshot=0"
# Disable tcmalloc memory allocator. It causes problems,
# for example bug #320419.
- myconf="${myconf} -Dlinux_use_tcmalloc=0"
+ myconf+=" -Dlinux_use_tcmalloc=0"
# Use target arch detection logic from bug #296917.
local myarch="$ABI"
[[ $myarch = "" ]] && myarch="$ARCH"
if [[ $myarch = amd64 ]] ; then
- myconf="${myconf} -Dtarget_arch=x64"
+ myconf+=" -Dtarget_arch=x64"
elif [[ $myarch = x86 ]] ; then
- myconf="${myconf} -Dtarget_arch=ia32"
+ myconf+=" -Dtarget_arch=ia32"
elif [[ $myarch = arm ]] ; then
# TODO: check this again after
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39509 is fixed.
append-flags -fno-tree-sink
- myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
+ myconf+=" -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
else
die "Failed to determine target arch, got '$myarch'."
fi
if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
+ myconf+=" -Dno_strict_aliasing=1 -Dgcc_version=44"
fi
# Work around a likely GCC bug, see bug #331945.
@@ -166,9 +170,9 @@ src_configure() {
# Make sure that -Werror doesn't get added to CFLAGS by the build system.
# Depending on GCC version the warnings are different and we don't want
# the build to fail because of that.
- myconf="${myconf} -Dwerror="
+ myconf+=" -Dwerror="
- build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
+ build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die
}
src_compile() {
@@ -177,46 +181,43 @@ src_compile() {
CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" \
RANLIB="$(tc-getRANLIB)" \
- || die "compilation failed"
+ || die
}
src_install() {
- dodir "$(get_chromium_home)"
-
- exeinto "$(get_chromium_home)"
+ exeinto "${CHROMIUM_HOME}"
pax-mark m out/Release/chrome
doexe out/Release/chrome
- doexe out/Release/chrome_sandbox
- fperms 4755 "$(get_chromium_home)/chrome_sandbox"
- doexe out/Release/xdg-settings
- doexe "${FILESDIR}"/chromium-launcher.sh
+ doexe out/Release/chrome_sandbox || die
+ fperms 4755 "${CHROMIUM_HOME}/chrome_sandbox"
+ doexe out/Release/xdg-settings || die
+ doexe "${FILESDIR}"/chromium-launcher.sh || die
- insinto "$(get_chromium_home)"
- doins out/Release/chrome.pak || die "installing chrome.pak failed"
- doins out/Release/resources.pak || die "installing resources.pak failed"
+ insinto "${CHROMIUM_HOME}"
+ doins out/Release/chrome.pak || die
+ doins out/Release/resources.pak || die
- doins -r out/Release/locales
- doins -r out/Release/resources
+ doins -r out/Release/locales || die
+ doins -r out/Release/resources || die
# chrome.1 is for chromium --help
- newman out/Release/chrome.1 chrome.1
- newman out/Release/chrome.1 chromium.1
+ newman out/Release/chrome.1 chrome.1 || die
+ newman out/Release/chrome.1 chromium.1 || die
doexe out/Release/ffmpegsumo_nolink || die
doexe out/Release/libffmpegsumo.so || die
# Install icon and desktop entry.
- newicon out/Release/product_logo_48.png ${PN}-browser.png
- dosym "$(get_chromium_home)/chromium-launcher.sh" /usr/bin/chromium
+ newicon out/Release/product_logo_48.png ${PN}-browser.png || die
+ dosym "${CHROMIUM_HOME}/chromium-launcher.sh" /usr/bin/chromium || die
make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser" \
"MimeType=text/html;text/xml;application/xhtml+xml;"
- sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
- || die "desktop file sed failed"
+ sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop || die
# Install GNOME default application entry (bug #303100).
if use gnome; then
- dodir /usr/share/gnome-control-center/default-apps
+ dodir /usr/share/gnome-control-center/default-apps || die
insinto /usr/share/gnome-control-center/default-apps
- doins "${FILESDIR}"/chromium.xml
+ doins "${FILESDIR}"/chromium.xml || die
fi
}
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index c6d1a0db515c..23f95be1ab25 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.82 2010/09/11 16:10:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.83 2010/09/14 14:08:22 phajdan.jr Exp $
EAPI="2"
@@ -20,6 +20,8 @@ IUSE="cups gnome gnome-keyring sse2"
RDEPEND="app-arch/bzip2
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
+ dev-libs/libxml2
+ dev-libs/libxslt
>=dev-libs/nss-3.12.3
>=gnome-base/gconf-2.24.0
gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
@@ -119,14 +121,14 @@ src_prepare() {
remove_bundled_lib "third_party/libevent"
remove_bundled_lib "third_party/libjpeg"
remove_bundled_lib "third_party/libpng"
+ remove_bundled_lib "third_party/libxml"
+ remove_bundled_lib "third_party/libxslt"
remove_bundled_lib "third_party/lzma_sdk"
remove_bundled_lib "third_party/molokocacao"
remove_bundled_lib "third_party/ocmock"
remove_bundled_lib "third_party/pyftpdlib"
remove_bundled_lib "third_party/simplejson"
remove_bundled_lib "third_party/tlslite"
- # TODO: also remove third_party/libxml and third_party/libxslt when
- # http://crbug.com/29333 is fixed.
# TODO: also remove third_party/zlib. For now the compilation fails if we
# remove it (minizip-related).
}
@@ -143,7 +145,6 @@ src_configure() {
# Use system-provided libraries.
# TODO: use_system_ffmpeg (http://crbug.com/50678).
- # TODO: use_system_libxml (http://crbug.com/29333).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_hunspell (upstream changes needed).
# TODO: use_system_ssl when we have a recent enough system NSS.
@@ -153,6 +154,7 @@ src_configure() {
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
+ -Duse_system_libxml=1
-Duse_system_zlib=1"
# The dependency on cups is optional, see bug #324105.